Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
New Gran Turismo 4 Config+Shader 2017
#1
Hello everybody!

After almost 4 years I am again creating a new thread to guide you on the best way to configure PCSX2 for playing Gran Turismo 4. I had created a guide previously but it's now too old and a lot of the stuff does not apply anymore because of all the different changes within PCSX2. The emulator can run GT4 a lot better now and if you have a decent computer you really don't need to mess with the speedhacks as much as we used to do in the past. I have noticed that when watching replays the dive camera now works. You can now fully use photo mode. Also, there is a plugin available for wheel support which I've been enjoying for a few months now. I'm using a Driving Force GT wheel and it works perfectly! You can also run the game on a triple screen setup in Surround/Eyefinity with proper aspect ratio.

I'm assuming you already have an installation of PCSX2 ready for the game. If not, go and download it here: Download

I will start by giving you the emulator settings necessary to run the game at its best. I will also provide you with a shader configuration file to make the game look really nice. Shaders are now handled a little differently on new versions of PCSX2. So make sure to follow all instructions properly.



EMULATION SETTINGS

Under the PCSX2 window, go into "Config---Emulation Settings" remove the check mark from "Preset:" option and change the following settings only. Leave the rest of the settings on default.

  1. EE/IOP---Clamping Mode---Full (This setting is used so that the game correctly displays the times during the races)

  2. VUs---Clamping Mode---Extra (This setting is used so that the game correctly displays all text in main menu)
     3. GS Window---Aspect Ratio:---Widescreen (16:9)

     4. Speedhacks---microVU Hacks---MTVU (If you have a 2+ core processor, which you should, this will speed up the emulation)


        OPTIONAL

 
     5. Speedhacks---EE Cyclerate---2 (Use if your game needs a little help with the framerate)


Under the PCSX2 window, go into "System" and untick "Automatic Gamefixes". Do not forget this step because if you don't make this change the game will crash randomly when racing.



Go to "Config---Video GS---Plugin Settings" on the main window. Change the following settings only. Leave the rest on default.

  1. Renderer---D3D Hardware (Make sure that if you can use DX10 or DX11 use them because they will work better than DX9)


  2. D3D internal resolution---Custom (I have noticed that using your monitor's resolution or multiples of it run better than using 2x,3x, ect.) Depending on your video card, you can even run in 4k (3840x2160). That's the resolution I use and it works very well for me.


  3. Hardware Mode Settings---Allow 8-bit textures

     4. Hardware Mode Settings---Enable HW Hacks   Click on Configure Hacks button

         4a.  Activate "Align Sprite" option
         4b.  set TC Offset X to: 385  and  TC Offset Y to: 187 and click ok
         This setting will fix issue with wheels on your car not being properly centered/aligned when you watch replay.




 

CUSTOM SHADER CONFIGURATION FILE: 




As I said earlier, PCSX2 handles shaders a little differently now.


First you will need to download the attachment I'm providing.


.txt   GT4 2017 1.2 settings.txt (Size: 20,53 KB / Downloads: 5.716)

This attachment is going to be the Shader Configuration file used for modifying the look of the game. Download it and put it in your  Shaders folder inside the PCSX2. Do not put it inside any other folder.

Go to "Config---Video GS---Plugin Settings" on the main window.

Under "Shader Configuration:" click on "Configure" button.
Activate "Enable External Shader" option:

Under "External Shader Config" click on "Browse" button and select the file I provided.


Next, boot the game and go into the options of the game and change Aspect Ratio to 16:9 and video output to "Progressive 480p" and also make sure that all picture options are set to "0". Get in any race and press the Home key on your keyboard to activate/deactivate the shader. Then, have someone pick up your chin because you will like what you will see. Enjoy!!!

P.S. Remember. Only use shader during races and with 480p mode active. Deactivate shader to navigate menus as they will be too bright.

Here are some examples of how the game looks when you configure the shader properly:

------------No Shader Active------------
[Image: y3mv1s_ciOdc9MOH1ycpc6N-qGz2VvW3YdURnrz1...pmode=none]
-----------With Shader Active----------
[Image: y3m2tmOMqI5lMWN4j7phAL3gssOXuZIu0geKmbN7...pmode=none]
------------No Shader Active------------
[Image: y3mBmljHxDzokDda6HW6KgWvL6v-KwmuyVcXhpsh...pmode=none]
-----------With Shader Active----------
[Image: y3m1t_e9t_b8R69qQ3hze1KbcRDRLCdpyuuouPv-...pmode=none]
New Gran Turismo 4 Config+Shader 2017

Intel Core i5 OCed @ 4.00 Ghz - GeForce GTX 970 - 16 GB RAM Crucial Ballistic Sport PC3-16000 - Windows 10 Pro 64-bit
Reply

Sponsored links

#2
A few notes:

The game benefits from using recent git releases and needs the OpenGL (Hardware) renderer to fix brightness settings.

Custom Resolutions are not recommended and can cause graphical issues.

The 480p option is only available for the NTSC releases.

EDIT:
Quote:Under the PCSX2 window, go into "System" and untick "Automatic Gamefixes". Do not forget this step because if you don't make this change the game will crash randomly when racing.
That makes no sense as all "Automatic Gamefixes" does is enable the "VUs---Clamping Mode---Extra" you suggest.
Reply
#3
(01-29-2017, 02:16 PM)FlatOut Wrote: A few notes:

The game benefits from using recent git releases and needs the OpenGL (Hardware) renderer to fix brightness settings.

Custom Resolutions are not recommended and can cause graphical issues.

The 480p option is only available for the NTSC releases.

EDIT:
That makes no sense as all "Automatic Gamefixes" does is enable the "VUs---Clamping Mode---Extra" you suggest.
Custom Resolution in 16:9 ratio (1920×1080, 2560×1440 and 3840×2160) has worked better for me on this particular game. I makes the game run smoother and look sharper with no slowdowns on framerate. If I choose 3x game looks a bit blurry and I get some fps drops on certain maps. 4x and and above don't help either.
 
For some odd reason Automatic Gamefixes is causing random crashes with this game. It took me a while to figure it out. I have also found a post a little while back and someone suggesting to disable it cause they were having the same issue. As soon as I disabled it, no more crashes.
New Gran Turismo 4 Config+Shader 2017

Intel Core i5 OCed @ 4.00 Ghz - GeForce GTX 970 - 16 GB RAM Crucial Ballistic Sport PC3-16000 - Windows 10 Pro 64-bit
Reply
#4
I see you have a GTX 970 like I do. Does it not choke at the start of a race? I'm using 3840x2160 and at the start of a race 2-5 seconds it will stutter at a low of 10 fps. Also some irregular stutters on some maps like the Japan course where you go through a tunnel. I think this is due to a lot of memory allocation going on. I recommend a video card with 4GB or more VRAM and 8GB+ RAM if you use 4K UHD.

Hardware Mode Settings---Allow 8-bit textures
This depends on your setup. If you have a high end CPU, I recommend leaving this off, putting less stress on your GPU.

Also the things I said yesterday on the older thread still apply. Settings for DS4 and
Mipmapping on HALF - Make fences beautiful again (dont see a difference with FULL)
Interlacing BOB TFF - Best setting for fluent motion and anti-ghosting (in GT Mode, on the map, switch Interlacing mode with F5, try it out and you will see what this is)

Again:
EE/IOP---Clamping Mode---Full will result in certain license tests not working. Try out License B - 3 (with the red Honda CRX). It will freeze in the loading screen.
Setting this to Extra + Preserve Sign works best. Disabling Automatic fixes does not fix this.

Setup:
Intel 5820k @4.7Ghz (47/47/45/45/45/45 x 100.2)
Gigabyte G1 Gaming GTX 970 @1465 (core) @3985 (memory)
32GB DDR4 RAM 2133
Reply
#5
(01-29-2017, 02:16 PM)FlatOut Wrote: Custom Resolutions are not recommended and can cause graphical issues.

Agreed , however having a custom resolution that is actually upscaled properly is a good idea. Example I run it at 2.5x (or 2.6 forgot)  but since there is no option to set that value I chose custom (1664 x 1331). Doing some calculations on it it seems to be equal to 1080p.
CPU: I3-4160 3.6GHZ
Motherboard: Asrock B85M - DGS
RAM: Hyper X Savage 2x8GB 1.6GHZ cl9
GPU: Asus AMD Radeon R7 360 OC 2GB GDDR5
OS: Windows 7 Ultimate SP1 64bit
Reply
#6
That's a really odd aspect ratio...
Reply
#7
(01-29-2017, 04:53 PM)RobbeS Wrote: I see you have a GTX 970 like I do. Does it not choke at the start of a race? I'm using 3840x2160 and at the start of a race 2-5 seconds it will stutter at a low of 10 fps. Also some irregular stutters on some maps like the Japan course where you go through a tunnel. I think this is due to a lot of memory allocation going on. I recommend a video card with 4GB or more VRAM and 8GB+ RAM if you use 4K UHD.

Hardware Mode Settings---Allow 8-bit textures
This depends on your setup. If you have a high end CPU, I recommend leaving this off, putting less stress on your GPU.

Also the things I said yesterday on the older thread still apply. Settings for DS4 and
Mipmapping on HALF - Make fences beautiful again (dont see a difference with FULL)
Interlacing BOB TFF - Best setting for fluent motion and anti-ghosting (in GT Mode, on the map, switch Interlacing mode with F5, try it out and you will see what this is)

Again:
EE/IOP---Clamping Mode---Full will result in certain license tests not working. Try out License B - 3 (with the red Honda CRX). It will freeze in the loading screen.
Setting this to Extra + Preserve Sign works best. Disabling Automatic fixes does not fix this.

Setup:
Intel 5820k @4.7Ghz (47/47/45/45/45/45 x 100.2)
Gigabyte G1 Gaming GTX 970 @1465 (core) @3985 (memory)
32GB DDR4 RAM 2133

With the settings I provide I do not have any issues at the start of any race. Game is running at 60 fps at all times. Unless you are not putting your game to 480p mode, that's the only way I have seen the game not running smoothly.  The only time I see a drop in Framerate is on some night courses when viewing some replay or if there is a lot of lights sources being shown on the screen. Otherwise the game runs perfect. 
Interlacing should be off during races as when you have 480p active on the game, it's not necessary. Interlacing is only needed on selection menus. So if you have it set to auto it will switch to the necessary interlacing mode, or you can simply press F5 to toggle between interlacing modes to use on the menus like you suggested.

So, in a nutshell; if you run the game in 480p mode it runs smoother, and you don't need interlacing during races.

Settings for EE/IOP  and VUs clamping are needed for specific issues:

One will help to display text correctly on menu screens, and the other will help to display time related information during races. Also to display the race time related information of the opponents and their corresponding icons on the screen during races. It will also help to correct issues with ghost car reproduction on time trials or practice sessions.

Licences can be obtained by simply reverting these particular setting to default on problematic tests and then change them again when done.
I've done licences many times with no issues by simply switching to software mode when selecting the problematic test and once inside switching back to hardware mode and they will run successfully. It can be a hit or miss thing.
New Gran Turismo 4 Config+Shader 2017

Intel Core i5 OCed @ 4.00 Ghz - GeForce GTX 970 - 16 GB RAM Crucial Ballistic Sport PC3-16000 - Windows 10 Pro 64-bit
Reply
#8
I just lost all my cars. It said the save state of my memory card changed and I had to create new data. So I lost every car besides the one I was "driving". Is there any way I can spawn in these vehicles again?
Reply
#9
(01-30-2017, 03:57 PM)RobbeS Wrote: I just lost all my cars. It said the save state of my memory card changed and I had to create new data. So I lost every car besides the one I was "driving". Is there any way I can spawn in these vehicles again?
I had the same thing happen to me when I was messing around, but I was on a new file. Did you create the new data? If not, the old save data should still be on your memory card and restarting the game should fix it.
Reply
#10
(01-30-2017, 04:58 PM)FlatOut Wrote: I had the same thing happen to me when I was messing around, but I was on a new file. Did you create the new data? If not, the old save data should still be on your memory card and restarting the game should fix it.

Alright. Lost some cars from the licenses that I couldn't retrieve. Decided to restart the whole GT mode. Now I got the first 3 licenses all silver Smile. Imma backup the memory card and not create new data anymore Smile
Reply




Users browsing this thread: 1 Guest(s)