Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
New to pcsx2, having problems
#1
I am new to pcsx2, but not to emultation. I run gamecube games on dolphin with graphical enhancements, while maintaining a 60fps framerate. However, I have had a great deal of difficulty getting a playable framerate on pcsx2. The games I am running are sly cooper 1 and 2, and here are my computer specs:

Intel i7-3610 QM 2.3-3.3 ghz
16 gb ram
GTX 675M graphics card

It is a gaming laptop, and I have tried overclocking but it resulted in no gains. Hence, I am assuming the problem lies within the settings I am using, which are the standard ones.
Reply

Sponsored links

#2
Or you could also assume that the games are improperly emulated instead, and find something else to play Tongue
Reply
#3
What type of non default speed hack you use .
Pentium Dual-core G2010 2.8Ghz
RAM=4GB
nvidia GT 610
pcsx2 version-1.3.1  


Still surfing with Browser?, Try the pcsx2 forum App !
Reply
#4
(08-18-2013, 07:46 AM)Coornio Wrote: Or you could also assume that the games are improperly emulated instead, and find something else to play Tongue

I didn't see them on the list of bad games... unless there is another one (Looked at the one on the main website)

(08-18-2013, 07:51 AM)Brock lessner Wrote: What type of non default speed hack you use .

I have everything on default, downloaded from the main website. The only change I made was to enable MTVU, which resulted in a gain of 20fps from 30 to 50. However, I am having difficulty maintaining 50 and it jumps down to 40 regularly.
Reply
#5
Try to put ee and gs slider to 2 or set it by self what best for your game enable speed hacks and use native resolution !
Pentium Dual-core G2010 2.8Ghz
RAM=4GB
nvidia GT 610
pcsx2 version-1.3.1  


Still surfing with Browser?, Try the pcsx2 forum App !
Reply
#6
(08-18-2013, 08:02 AM)Brock lessner Wrote: Try to put ee and gs slider to 2 or set it by self what best for your game enable speed hacks and use native resolution !

Native resolution was already enabled, speed hacks were already enabled, sliders had no effect.
Reply
#7
Enable frame skip.
Pentium Dual-core G2010 2.8Ghz
RAM=4GB
nvidia GT 610
pcsx2 version-1.3.1  


Still surfing with Browser?, Try the pcsx2 forum App !
Reply
#8
make sure you set power plan to performance mode.
Sly Cooper series are a bit demanding, and your CPU may not be up to the par.

As a last resort, Throttlestop may help you too
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#9
Throttlestop helped in some areas of the game, frameskipping hurts my eyes too much... I guess I should invest more in the cpu when it comes time to replace this computer.
Reply
#10
(08-18-2013, 04:48 PM)PantherDeutschV Wrote: Throttlestop helped in some areas of the game, frameskipping hurts my eyes too much... I guess I should invest more in the cpu when it comes time to replace this computer.

frame skip does not work well in some games .
Pentium Dual-core G2010 2.8Ghz
RAM=4GB
nvidia GT 610
pcsx2 version-1.3.1  


Still surfing with Browser?, Try the pcsx2 forum App !
Reply




Users browsing this thread: 1 Guest(s)