Thread Rating:
  • 2 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Newbie needs help with Persona 4
#1
Exclamation 
Ok so I am new to the community and I am in dire need of help with a good Persona 4 configuration...
I picked it up yesterday about a half hour after I found out it came out and seeing as how I cannot afford a PS2 at the moment and the last one I had was stolen from me, this laptop is my only hope for playing it...
(Laptop specs are listed in my signature)

I thought I was doing fine because my CPU stays at about 30% (that's what it says at the top of the window, although task manager says 50-60) but then I compared my opening movie to several on youtube and realized I was running at about half the actual speed Ohmy
So I am going to list my configuration here and I need suggestions on what to tweak to squeeze as much speed as possible out, I'm not expecting full speed but the closer, the better:

Playstation Playground 1.0.0395
Cpu:
all boxes checked, vu skip= 45 limit, below 40 skip, 0 consecutive before skip, 4 frames to skip
Graphics:
GSdx 872m (MSVC 15.00, SSE2) 0.1.12
Windowed, Direct3D9 (Hardware), Pixel Shader 2.0, No Interlacing, 4:3 Aspect, Native checked, NLOOP Greyed, Alpha Checked (the rest unchecked)
Sound:
SPU2ghz Playground 1.9.0
Nearest Interpolation, Xaudio, Time stretching checked (the rest unchecked)
Cdvdrom drive:
Linuzapps Iso CDVD 0.7.0 (running off Iso in hopes for speed increases and an unstable DVD Drive)
USA Bios
Speedhacks:
None (at the recommendations of other posts in the forums)
Advanced:
All Boxes checked, all options set to Chop / Zero
No Gamefixes or Hacks
AMD Turion64 x2 2.0GHz
3Gbs RAM
Nvidia Geforce 7150m / 630i 128Mb VRAM (512 with Shared)
Windows XP Media Center
(mind you it's a laptop)
Reply

Sponsored links

#2
First of all, you put sound settings to hight for you cpu. In you case nosound or simpliest sound would be better. Then, Gsdx DX 9 known to have graphics's problems a lot with P4, either DX 10 or ZeroGS. Second, use x2 speedhacks, never do x3. And third, 30% of CPU -- is load of GSDX plugin thread. EE thread probably got all 95% of second core, and it's this thread which limit speed.
Reply
#3
(01-02-2009, 04:27 AM)Zeydlitz Wrote: First of all, you put sound settings to hight for you cpu. In you case nosound or simpliest sound would be better. Then, Gsdx DX 9 known to have graphics's problems a lot with P4, either DX 10 or ZeroGS. Second, use x2 speedhacks, never do x3. And third, 30% of CPU -- is load of GSDX plugin thread. EE thread probably got all 95% of second core, and it's this thread which limit speed.

Ok I'm experimenting with ZeroGS KOSMOS 0.97.1 with everything unchecked and 0xAA but I get a constant slow speed flickering at the title screen...
I can't play this game with out sound, the FMVs aren't subbed and I wouldn't know which sound plugin to use otherwise so please make a sound plugin recomendation...
And as for the speedhacks, a few other people have stated that the game runs better without any of em at all...
EDIT: ZeroGS KOSMOS 0.97.1 just isn't usable! It gives me flicker like crazy on a lot of screens
AMD Turion64 x2 2.0GHz
3Gbs RAM
Nvidia Geforce 7150m / 630i 128Mb VRAM (512 with Shared)
Windows XP Media Center
(mind you it's a laptop)
Reply
#4
I messed around with this game for a while, nothing did anything UNTIL I did two things in Advanced.

Under VU Recs Options I checkmarked both "Flush to Zero" and "Denormals are Zero"
And now the game runs like butter, like it literally runs absolutely amazing at 60 fps.


Oh wait, I saw that you did this already. Sorry to hear that. That's the only thing that made this game run at a constant 60 FPS regardless of any and all other settings I have on. I actually have all the eye candy I can find turned on now. The game looks 10x better then anything a ps2 could do. (Well maybe not 10x, but a lot better ;D)
Reply
#5
(01-02-2009, 04:48 AM)Kalabalana Wrote: I messed around with this game for a while, nothing did anything UNTIL I did two things in Advanced.

Under VU Recs Options I checkmarked both "Flush to Zero" and "Denormals are Zero"
And now the game runs like butter, like it literally runs absolutely amazing at 60 fps.
(01-02-2009, 04:01 AM)Roland Wrote: Advanced:
All Boxes checked, all options set to Chop / Zero
I already have both checked for both EE and VU as I stated in my opening post...
AMD Turion64 x2 2.0GHz
3Gbs RAM
Nvidia Geforce 7150m / 630i 128Mb VRAM (512 with Shared)
Windows XP Media Center
(mind you it's a laptop)
Reply
#6
Yeah saw that afterwards, I'm guessing your laptop just can't crunch the numbers fast enough. Sorry to hear that :x

I'm on a core 2 duo E6400 @ 2.13 Ghz and a 3870
Seems I'm golden even at 1920x1200
Reply
#7
Ok, so I tried ZeroGS KOSMOS 0.97.1 with everything unchecked and 0xAA an I get screen flickers at the title screen ( I suspect it's a 2d texture rendering thing but that's a complete stab in the dark from previous emu experiences) so ZeroGS KOSMOS 0.97.1 just isn't usable for me...
Perhaps someone can recommend another vid plugin, and apparently I need a better sound plugin but I don't know which one to use...?
AMD Turion64 x2 2.0GHz
3Gbs RAM
Nvidia Geforce 7150m / 630i 128Mb VRAM (512 with Shared)
Windows XP Media Center
(mind you it's a laptop)
Reply
#8
I've been messing around a little more, and i've found the game only seems to work normally when you select the "limit" radio option from the cpu menu.
Reply
#9
(01-02-2009, 05:36 AM)Kalabalana Wrote: I've been messing around a little more, and i've found the game only seems to work normally when you select the "limit" radio option from the cpu menu.


That actually seems to cause the FMVs to run slower...
Perhaps I should point out I am basing all my tests off the opening movie and how the title screen performs...
I did start a new game once but I cut it off while Igor was talking cuz at that point I decided I'm not playing until I can get it as fast as I can...
AMD Turion64 x2 2.0GHz
3Gbs RAM
Nvidia Geforce 7150m / 630i 128Mb VRAM (512 with Shared)
Windows XP Media Center
(mind you it's a laptop)
Reply
#10
I upgraded my plugins to GSDX 0.1.13, no speed increase noticed...
If Zeydlitz is correct then I suppose I need a better sound plugin...
Can someone recommend one with a good speed configuration?
Mind you "No Sound" is not an option, the FMVs are not subbed!
AMD Turion64 x2 2.0GHz
3Gbs RAM
Nvidia Geforce 7150m / 630i 128Mb VRAM (512 with Shared)
Windows XP Media Center
(mind you it's a laptop)
Reply




Users browsing this thread: 1 Guest(s)