Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
No Nvidia Hack in v. 1.4.0
#1
Any idea why this was removed? I have used it for a few games where, during cut scenes, the image will zoom in and out. The issue isn't as bad as the zooming in and out, but there is a flickering that sporadically occurs during cut scenes in these games. If I use v. 1.2.1, they play out smoothly, so I'll just revert to using the older version. Just curious why the hack was excluded.
Reply

Sponsored links

#2
its built into it there for it not need to be listed,
Reply
#3
I'm not exactly sure what the logic was on that but there have been several rendering improvements made under version 1.4.0 particularly involving opengl which is currently the renderer of choice. Just change to that and set your crc hack level to partial and tick the hardware depth option.

That should take care of it for you.
Reply
#4
logic was there was no side effects to have it on always so they built it in to gsdx cause nvidia will never fix the issue with DX11 out side of them randomly fixing it like they randomly caused it.

if your on nvidia gpu, you should be using opengl anyway at this point, short of the rare occasion DX11 might be better or faster.
Reply
#5
Tried the OpenGL (hardware) back-end, but it still has the same flickering as DX11 (hardware)... plus it appears there is no V-sync with OpenGL so there is "tearing" that doesn't happen with DX11 (hw).

Guess I'm going to stick with DX11 (hw) for now. I honestly could not see a difference in terms of rendering between either OpenGL or DX11 minus the "tearing" that occurs with OpenGL. Thanks for the suggestion though!

System specs:
Win10 Pro 64-bit
CPU: i5-3230M @2.6 Ghz (Turbo boosts to 3.2 Ghz)
RAM: 8GB
GPU: GTX 660M
Reply
#6
I'm just sorry it didn't work out for you. You shouldn't have any screen tearing or stretching with those settings.

I'm not sure how heavy you are into messing around with settings but there's always a lot of truth in just leaving things at their defaults. My best advice would be to clean install both your video card drivers as well as the emulator that way any unintentional setting changes will be restored to defaults and you can start fresh.

Then only change what you need too and nothing more. That might work out better for you.
Reply
#7
Which games exactly is this occurring in? (Name and region, and maybe add the CRC of the game as well you're having issues with)

Maybe gregory can look into it if it's really not functioning, because it's supposed to be automatically activated as far as I know.

But it could be that the game is missing from the GameDB file, causing the built-in thing not to activate? Not sure.
Intel Core i5-4670K @ 3.40GHz | 16GB (2x8GB) DDR3-1866 G.SKILL Sniper Series
AMD Radeon R9 280 @ 3 GB | 120GB SSD | Windows 7 Ultimate x64 (SP1)
Reply
#8
(02-07-2016, 05:07 AM)CTRL+ALT+DEFEAT Wrote: Tried the OpenGL (hardware) back-end, but it still has the same flickering as DX11 (hardware)... plus it appears there is no V-sync with OpenGL so there is "tearing" that doesn't happen with DX11 (hw).

Guess I'm going to stick with DX11 (hw) for now. I honestly could not see a difference in terms of rendering between either OpenGL or DX11 minus the "tearing" that occurs with OpenGL. Thanks for the suggestion though!

System specs:
Win10 Pro 64-bit
CPU: i5-3230M @2.6 Ghz (Turbo boosts to 3.2 Ghz)
RAM: 8GB
GPU: GTX 660M

fullscreen in opengl? that is cause opengl is forced in to fullscreen exlcusive when it should not, which both nvidia driver issue and pcsx2 issue that happen over 1000 builds ago. that dont seem to be priorty
Reply
#9
(02-07-2016, 02:11 PM)Ryudo Wrote: Which games exactly is this occurring in? (Name and region, and maybe add the CRC of the game as well you're having issues with)

Maybe gregory can look into it if it's really not functioning, because it's supposed to be automatically activated as far as I know.

But it could be that the game is missing from the GameDB file, causing the built-in thing not to activate? Not sure.

The cut scene flickering is in Castlevania: Curse of Darkness, NTSC, CRC: 0x3A44611. It doesn't zoom in and out like it did with earlier versions of PCSX2 if the Nvidia hack was disabled, it just flickers in random spots with version 1.4 and doesn't happen with version 1.2.1.

I'm sure it's working as intended if it was just "built-in" as an always on function; just didn't see it anywhere in the GSDX settings menu.

(02-07-2016, 08:42 PM)tsunami2311 Wrote: fullscreen in opengl? that is cause opengl is forced in to fullscreen exlcusive when it should not, which both nvidia driver issue and pcsx2 issue that happen over 1000 builds ago. that dont seem to  be priorty

Yep, I was running fullscreen.

Got it, I'll just stick with DX11 then.
Reply
#10
highly doubt texture flickering is due to the Nvidia hack being always on, it is more likely Nvidia screwed something up in drivers to cause it again, which happen rather often, just to be fix in another drivers, that or pcsx2 has had regression.
Reply




Users browsing this thread: 1 Guest(s)