Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
No audio with Xenosaga Episode 1
#1
Hey guys, I tried searching the forums, but this appears to be a unique problem. I have the Xenosaga Episode 1 DVD-9 game. Anyways, the emulator runs fine, I just get no audio whatsoever. I get audio with other PS2 games, but not with Xenosaga. I've fiddled around with the SPU2-X r5324 2.0.0 plugin to no avail. I'm noticing this unknown device 'hdd' line showing up which I don't see with other isos, is this the cause? Since it's playing audio for other isos, I don't think it's a sound card/driver issue.

Here's the logfile:

IOP Realtime Kernel Ver. 2.1

Copyright 1999-2001 © Sony Computer Entertainment Inc.

Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 ©SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
loadmodule: fname cdrom0:¥IOP¥SIO2MAN.IRX;1 args 0 arg
loadmodule: id 25, ret 0
loadmodule: fname cdrom0:¥IOP¥MCMAN.IRX;1 args 0 arg
loadmodule: id 26, ret 2
loadmodule: fname cdrom0:¥IOP¥MCSERV.IRX;1 args 0 arg
loadmodule: id 27, ret 2
loadmodule: fname cdrom0:¥IOP¥PADMAN.IRX;1 args 0 arg
loadmodule: id 28, ret 0
loadmodule: fname cdrom0:¥IOP¥LIBSD.IRX;1 args 0 arg
loadmodule: id 29, ret 0
loadmodule: fname cdrom0:¥IOP¥SSD.IRX;1 args 0 arg
SSD Ver 2.5.0.020108,0060.01
loadmodule: id 30, ret 0
loadmodule: fname cdrom0:¥IOP¥RSSD.IRX;1 args 0 arg
loadmodule: id 31, ret 0
Ssd init Suzuki sound driver version 2.5
Unknown device 'hdd'
Known devices are mcSadMemory Card) cdromSadCD-ROM ) romSadROM/Flash) ttySadCONSOLE)
Unknown device 'hdd'
Stream Buffer 1Bank 8192byte 16banks 131072byte used
Stream Buffer 1Bank 8192byte 16banks 131072byte used
Unknown device 'hdd'
Unknown device 'hdd'

Here are the plugin settings:
Interpolation: 4-Catmull-ROM PS2-like

Module: 1 - X Audio 2
Latency: 200 ms

Synchronizing mode: Time Stretch

Audio Expansion mode:
Stereo (none, default)

Every box is unchecked.


Any help is appreciated. I'm running Windows 7 Ultimate x64.
Reply

Sponsored links

#2
HDD stands for Hard Disk Drive, or commonly known as HD also. More meaningful information is the fail loading those files with return 2.
The log says it found SSD, so I suppose that's where the ISO is. I don't know how to interpret the line: Ssd init Suzuki sound driver version 2.5

If the emulator is installed at C:\Program Files or such "protected" directories, that's not even option anymore, install it on a user created directory.

3 Options

Although is mentioned other ISOs is not clear if you are running from the DVD or from image. If the first, try and create an image using imgburn.

From the image make sure "Iso" and not "Plugin" is set, unmount the image from any virtual device if is the case or remove the DVD from tray. Select the ISO from the CDVD menu.

Use boot CDVD (fast).

If still not working, return to option 1 and make sure imgburn made an ISO without errors.
Imagination is where we are truly real
Reply
#3
Also make sure that you download a newer version of PCSX2. 53xx is quite old and they're now around 56xx.
Reply
#4
(04-29-2013, 11:04 AM)nosisab Ken Keleh Wrote: HDD stands for Hard Disk Drive, or commonly known as HD also. More meaningful information is the fail loading those files with return 2.
The log says it found SSD, so I suppose that's where the ISO is. I don't know how to interpret the line: Ssd init Suzuki sound driver version 2.5

If the emulator is installed at C:\Program Files or such "protected" directories, that's not even option anymore, install it on a user created directory.

3 Options

Although is mentioned other ISOs is not clear if you are running from the DVD or from image. If the first, try and create an image using imgburn.

From the image make sure "Iso" and not "Plugin" is set, unmount the image from any virtual device if is the case or remove the DVD from tray. Select the ISO from the CDVD menu.

Use boot CDVD (fast).

If still not working, return to option 1 and make sure imgburn made an ISO without errors.

nosisab, I am already doing the 3 things that you are telling me to do. It is an iso and it is clicked on iso and the dvd is removed. I run it on boot fast as well. I did make the img using the read function from imgburn.

(04-29-2013, 02:51 PM)StriFe79 Wrote: Also make sure that you download a newer version of PCSX2. 53xx is quite old and they're now around 56xx.

Strife79, I tried downloading it but it says it's still in build 5350, where is the 56xx build. I don't think the build matters as Xenosaga has reportedly been functioning for the past few years on the emulator.
Reply
#5
Delete u'r current iso image.
Recreate iso image with imgburn by directly selecting u'r game Dvd & click on create image file from disc.
After successfully creating the iso image from imgburn check that u'r game dvd & iso image's sizes are same.
If not it's possible that u didn't do it properly.if it's same size,then go for further settings.
Go to plugin/bios selector in pcsx2-audio plugin settings-Spux r5559 (something like it,maybe u have other revison than 5559)-configure-
Interpolation-1.Linear/simple okay sound
Module-2.Direct sound (nice)-configure-Direct sound device-That u'r computer have

Then Go to pcsx2 cd/dvd tab-select iso-iso browser-browse to u'r new created iso image with imgburn.
Double click on that iso image to select it.
Go to system tab in pcsx2-select boot cd/dvd fast !!
Reply
#6
get the latest stable version from the home site 1.0.0 the SVNs may sometimes be unstable
Reply
#7
(04-29-2013, 08:03 PM)Preet Wrote: Delete u'r current iso image.
Recreate iso image with imgburn by directly selecting u'r game Dvd & click on create image file from disc.
After successfully creating the iso image from imgburn check that u'r game dvd & iso image's sizes are same.
If not it's possible that u didn't do it properly.if it's same size,then go for further settings.
Go to plugin/bios selector in pcsx2-audio plugin settings-Spux r5559 (something like it,maybe u have other revison than 5559)-configure-
Interpolation-1.Linear/simple okay sound
Module-2.Direct sound (nice)-configure-Direct sound device-That u'r computer have

Then Go to pcsx2 cd/dvd tab-select iso-iso browser-browse to u'r new created iso image with imgburn.
Double click on that iso image to select it.
Go to system tab in pcsx2-select boot cd/dvd fast !!

why you recommend him to change the Default "recommended" settings of SPU2-X ?
Reply
#8
(04-29-2013, 08:12 PM)The Old Refuge Wrote: why you recommend him to change the Default "recommended" settings of SPU2-X ?

because i know what i'm saying Smile
i'm using it for all games & direct sound is good.check it Wink
and he have sound problem that's why...sometimes direct sound solve some sound issues !!
Reply
#9
i do use it also but like XAudio do work for all games as well Tongue

most of the time the problem is the excessive use of Speedhacks Laugh
Reply
#10
(04-29-2013, 06:21 PM)TheStuntman Wrote: nosisab, I am already doing the 3 things that you are telling me to do. It is an iso and it is clicked on iso and the dvd is removed. I run it on boot fast as well. I did make the img using the read function from imgburn.


Strife79, I tried downloading it but it says it's still in build 5350, where is the 56xx build. I don't think the build matters as Xenosaga has reportedly been functioning for the past few years on the emulator.

Well, those messages are unknown by me except the return 2 means error and the file was not loaded, what could explain the whole issue.

But I'm not sure since never saw them before, somebody correct me if I'm wrong, please.

That's the reason to the recommendation of making a new ISO, looks like it may be corrupted. As far as I know, having the ISO on SSD should not be problem but you could try moving it to normal HD, even because SSDs are still small and you should avoid overload it with low priority media files.
Imagination is where we are truly real
Reply




Users browsing this thread: 1 Guest(s)