Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
No sound (AntergOS 64b, an Arch derivative)
#1
I'm using the 64bit version of AntergOS (an Arch derivative) I installed pcsx2 from the main repo, as well as the 32 bit libs for portaudiom, soundtouch, and wxgtk. Everything was install from the official repo, since the only reason given for using yogurt was to get the unlisted deps, which did manually. No mater what I choice in the configurations window for the sound, there isn't any. I've tried with two games so far -- Drakengard and Champians of Norrath. I'm getting tons of error messages in the log.

Code:
branch 58595a5b in delay slot!
branch 55555657 in delay slot!
EE: Unrecognized op 7677797a
EE: Unrecognized op 75757575
EE: Unrecognized op 75767778
EE: Unrecognized op 74747474
EE: Unrecognized op 74757576
EE: Unrecognized MMI op 73737373
EE: Unrecognized op 74747575
EE: Unrecognized op 74747474
EE: Unrecognized op 74757575
EE: Unrecognized op 74747474
EE: Unrecognized op 74757575
EE: Unrecognized op 74747474
EE: Unrecognized op 75757575
EE: Unrecognized op 74747475
EE: Unrecognized op 75757575
EE: Unrecognized op 74757575
EE: Unrecognized op 75757575
EE: Unrecognized MMI op 72737475
EE: Unrecognized op 75757575
EE: Unrecognized MMI op 72737475
EE: Unrecognized op 75757574
EE: Unrecognized MMI op 72737475
EE: Unrecognized op 75747474
EE: Unrecognized op 74747373
EE: Unrecognized op 74737272
EE: Unrecognized op 74747474
EE: Unrecognized op 74737271
EE: Unrecognized op 74747474
EE: Unrecognized op 74737271
EE: Unrecognized op 74747474
(EE pc:21B087EC) TLB Miss, addr=0xfffc2c2 [load]
(EE pc:21B087EC) TLB Miss, addr=0xfffc3c3 [load]
(EE pc:21B087EC) TLB Miss, addr=0xfff9794 [load]
(EE pc:21B087EC) TLB Miss, addr=0xfff9895 [load]
EE: Unrecognized COP0 op 41474d4f
EE: Unrecognized FPU/COP1 op 464d5253
Cop2 bad opcode: 49515454
(EE pc:21B08A74) TLB Miss, addr=0xfff9693 [load]
(EE pc:21B08A74) TLB Miss, addr=0xfff9693 [load]
EE: Unrecognized COP0 op 4142454b
EE: Unrecognized COP0 op 4344484d
branch 10101010 in delay slot!
branch 10101010 in delay slot!
(EE pc:21B1BC58) TLB Miss, addr=0xbab0 [store]
EE: Unrecognized op c9b08b80
EE: Unrecognized op c1958485
(EE pc:21B1FCC4) TLB Miss, addr=0xfffbfb8 [load]
(EE pc:21B1FCC4) TLB Miss, addr=0xfffb5a0 [store]
(EE pc:21B1FCC4) TLB Miss, addr=0xfff948d [load]
(EE pc:21B1FCC4) TLB Miss, addr=0xfff9f96 [load]
(EE pc:21B1FCC4) TLB Miss, addr=0x42459984 [load]
(EE pc:21B1FCC4) TLB Miss, addr=0x42459984 [store]
(EE pc:21B1FCC4) TLB Miss, addr=0xfff9588 [load]
(EE pc:21B1FCC4) TLB Miss, addr=0xfff9588 [store]
branch 5d5f615c in delay slot!
branch 595c5c5e in delay slot!
EE: Unrecognized MMI op 72645655
branch 5b5b6870 in delay slot!
(EE pc:21B38294) TLB Miss, addr=0x5258 [load]
branch 50516168 in delay slot!
branch 5b636e5d in delay slot!
branch 545d6d65 in delay slot!
branch 5e755c4b in delay slot!
(EE pc:21B53874) TLB Miss, addr=0xb5b0 [load]
(EE pc:21B53884) TLB Miss, addr=0x7c70 [store]
(EE pc:21B53884) TLB Miss, addr=0xb5b0 [load]
(EE pc:21B53884) TLB Miss, addr=0xb8b0 [store]
(EE pc:21B53884) TLB Miss, addr=0xb6b0 [load]
(EE pc:21B53884) TLB Miss, addr=0xb7b0 [store]
(EE pc:21B53884) TLB Miss, addr=0xa0a0 [store]
(EE pc:21B53884) TLB Miss, addr=0xb8b0 [store]
(EE pc:21B53884) TLB Miss, addr=0xa0a0 [store]
(EE pc:21B53884) TLB Miss, addr=0xb8b0 [store]
(EE pc:21B53884) TLB Miss, addr=0x9fa0 [store]
(EE pc:21B53884) TLB Miss, addr=0xb8b0 [store]
(EE pc:21B53884) TLB Miss, addr=0xb5b0 [load]
(EE pc:21B53884) TLB Miss, addr=0x7c70 [store]
(EE pc:21B53884) TLB Miss, addr=0x7970 [load]
(EE pc:21B53884) TLB Miss, addr=0x7b70 [store]
(EE pc:21B53884) TLB Miss, addr=0x308 [load]
(EE pc:21B53884) TLB Miss, addr=0xfffb9bb [load]
(EE pc:21B53884) TLB Miss, addr=0xfffbbbb [load]
(EE pc:21B53884) TLB Miss, addr=0x409 [load]
(EE pc:21B53884) TLB Miss, addr=0xfffb9ba [load]
(EE pc:21B53884) TLB Miss, addr=0x409 [load]
(EE pc:21B53884) TLB Miss, addr=0xfffb9ba [load]
(EE pc:21B53884) TLB Miss, addr=0x5 [load]
(EE pc:21B53884) TLB Miss, addr=0x106 [load]
(EE pc:21B5C5C0) TLB Miss, addr=0xfffbabb [load]
(EE pc:21B5C5C0) TLB Miss, addr=0xfffbaba [load]
(EE pc:21B5C5C0) TLB Miss, addr=0xfffb9ba [load]
(EE pc:21B5C5C0) TLB Miss, addr=0xfffbbbb [load]
(EE pc:21B5C5C0) TLB Miss, addr=0xfffb9b9 [load]
(EE pc:21B5C5C0) TLB Miss, addr=0xfffbbbb [load]
(EE pc:21B5C5C0) TLB Miss, addr=0xfffb9b9 [load]
(EE pc:21B5C5C0) TLB Miss, addr=0xa0a0 [store]
(EE pc:21B5C5C0) TLB Miss, addr=0xa1a0 [store]
branch 1e1e1e1e in delay slot!
branch 1f202121 in delay slot!
branch 18181717 in delay slot!
branch 1a191919 in delay slot!
branch 1e1d1d1d in delay slot!
branch 1f20201f in delay slot!
EE: Unrecognized FPU/COP1 op 45474e5b
EE: Unrecognized FPU/COP1 op 45586d89
EE: Unrecognized op eae9eae9
branch 1b1b1b19 in delay slot!
branch 10101010 in delay slot!
branch 10101010 in delay slot!
i7 4930k @4.3, 4x4 GB RAM @2133 (15-15-15-27, quad channel), EVGA 570 @stock, Arch 64b.
Reply

Sponsored links

#2
PCSX2 may not be compatible with that, obviously.

EDIT: Ignore what I said, probably the sound plug-ins are not compatible.
CPU:
Intel Core2 Duo T5450 (1.666 GHz)
[Image: gzztty.png]
GPU:
Mobile Intel® 965 Express Chipset Family (500 MHz)
GPU-Z Validation
Other:
RAM: DDR2-666 (2 GB)
---
Not a gaming PC, but I'll try to get a better one in the future.
Reply
#3
There was some obscure portaudio lib I needed to install extra from the repos to get sound in Antergos. I like this distro, but I think I'm beginning to prefer Ubuntu/Mint's "completeness" more as I never had this type of problem before.
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#4
(03-19-2014, 06:20 PM)MenDude Wrote: PCSX2 may not be compatible with that, obviously.

EDIT: Ignore what I said, probably the sound plug-ins are not compatible.

Could you be more specific?

(03-19-2014, 06:57 PM)DaTankAC Wrote: There was some obscure portaudio lib I needed to install extra from the repos to get sound in Antergos. I like this distro, but I think I'm beginning to prefer Ubuntu/Mint's "completeness" more as I never had this type of problem before.

I ran yaourt -Ss portaudio looking, but the only thing that seemed reasonable was lib32-portaudio_cpp which isn't installing for some reason. Can you be more specific? I'd post on the Arch board, but last time I did they deleted it. Other distros aren't allowed to be discussed there.

I'm thinking I should have just bitten the bullet and installed Arch properly. Sadly, I don't have time for that right now.

[edit] I went ahead and installed PCSX2 via yaourt, and I'm still getting the same audio issues.

[edit2] AH! Got some new error messages:

ALSA lib dlmisc.c:252Sadsnd1_dlobj_cache_get) Cannot open shared library /usr/lib32/alsa-lib/libasound_module_pcm_pulse.so
SPU2-X: SDL audio error: No available audio device"

This led me to look for more lib32s related to alsa. After following the rabit down a damned long hole, I found I was missing lib32-libpulse. Potentionally many other things, but at least I got it all.
i7 4930k @4.3, 4x4 GB RAM @2133 (15-15-15-27, quad channel), EVGA 570 @stock, Arch 64b.
Reply
#5
Do you have sdl2 and lib32 version installed? I'm sorry I can't remember what lib I exactly install, as I'm still getting used to the Arch methods, but it might have been that one that was the magic bullet. Antergos overall is pretty decent and does take out some of the brutal config-from-scratch requirements that Arch has,
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#6
(03-20-2014, 04:01 AM)DaTankAC Wrote: Do you have sdl2 and lib32 version installed? I'm sorry I can't remember what lib I exactly install, as I'm still getting used to the Arch methods, but it might have been that one that was the magic bullet. Antergos overall is pretty decent and does take out some of the brutal config-from-scratch requirements that Arch has,

Don't worry about it. In that second edit, I mentioned that I figured it out. Thanks though. If you feel like you want to help someone I have another problem for you to tackle here in a bit.

[edit] Cancel that. I found the problem already.
i7 4930k @4.3, 4x4 GB RAM @2133 (15-15-15-27, quad channel), EVGA 570 @stock, Arch 64b.
Reply
#7
Ahh, libpulse was the missing lib. Thanks, as it gives me the reminder now. I'm glad you solved it. The stable version pre-compiled in the repos spared me a lot of trouble with the other parts of getting pcsx2 to work. Smile
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply




Users browsing this thread: 1 Guest(s)