Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not happy with my FPS
I'm really not liking the fps im getting which would be 30-40 on games like soul caliber 4.
For my pc specs, it is
Intel Core i7
ATI 4850
(Windows Vista 64bit)
Yeah, im pretty sure my pc can handle it

For the GRAPHICS PLUGIN, im using GSdx 890 SSE41
Rend: Dx10 Hardware
Interlacing: Bob tff
Aspect Ratio: stretch
D3D: Native (1680x1050) ( i have also tried lower res to raise fps)
Texture Filtering and Wait vsync are enabled.

Is it possible for me to get higher a higher fps or is it simply that the emulator cant handle a high fps rate?

Thanks in advance.

Sponsored links

Native in the graphics plugin is not the native desktop resolution, only thing i can see there is that you have the resolution too high. Check the native checkbox then run the game, if the speed doesnt change then its something else, if it goes to full speed then you can then up the resolution how much you trial and error till you find the right median.
Laptop Rig:

Core 2 Duo @ 1.8Ghz
3 gb DDR2-800 RAM
256mb ATI HD 3430
Windows Vista Buisness 32-Bit

Desktop Rig:

P4 HT @ 3.0Ghz
3 gb DDR2-533 RAM
256mb ATI X1300
Windows XP Pro 32-Bit
Heres the thing.
If i uncheck Native and put a res like 1024 x 768 i end up getting vertical black lines on my screen, about 6 of them.
But no matter what i put the res, in the windowed mode it tells me im running at 640 x 448, when i have a game running of course.
Try getting the newest GSdx and PCSX2 beta, what games are you trying btw?
i guess ill try out the beta version than.
So far i have tried tekken 5 and soul caliber 4.
ill try gran turismo 4 whenever i set it up.

EDIT: Yeah, the beta didn't help with the fps.
the resolution in the title bar is the native resolution of the game currently emulated, that is the resolution which will be used to render the game in if the native checkbox is ticked, this native resolution will then be upscaled to the size of your pcsx2 window (looks rather ugly on computer monitors Wink ). if the native checkbox is not checked, then the resolution next to it is used for rendering. higher values will look better. also keep in mind that pcsx2 currently uses a max of two cores, only the software mode of gsdx is able to use more than that. in software mode you cannot choose a custom internal d3d resolution for better 3d graphics, it's always on native, forcing anti aliasing in your nvidia control panel might help in this case.
CPU Core i5-3570K@3.4GHz | GPU Nvidia Geforce GTX 570 | RAM 8GB DDR-3 1600MHz CL9 | OS Win7 Ultimate (x64) SP1
EMU PCSX2 v1.1.0 r5645 | GS GSdx SSE4 r5632 | SPU2 SPU2-X r5559 | PAD LilyPad r5403 | CDVD cdvdGigaherz r5403
Neither did the latest GSdx? hmmm have you tried enabling speedhacks "config > speedhacks" specially "VU Cycle Stealing" try setting it to slight or moderate
"Texture Filtering and Wait vsync are enabled"

Disable vsync...
The vertical black line I face in some game before but the best way to solve it under Gsdx is in D3d Internal res : 520 (Max) | 520 ~ Unlimited [eg: 520 | 1080]. Thus this will give a nice graphic without vertical black line but visible bad AA will shown due to low vertical res. NOte: If render under software mode this is not a problem because it will not shown the black line.
Ok the latest GSdx gave me very little improvements but what really helped me was using the EmotionEngine sync hacks ( found under speed hacks).
Also, i could not find the VU Cycle Stealing that you were talking about.

Users browsing this thread: 1 Guest(s)