Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not working with direct3D11
#1
Emulator won´t load Games and crash when I set gsdx plugin to direct3D11. I´m running on Windows 7 Ultimate 64 BIT, i5 2.80Ghz, 4GB RAM, Ati radeon HD5670 1Gb. Can anyone help me please? Games (i.e God of war 2) runs at a maximum of 35 fps ingame.
Thanks.
Reply

Sponsored links

#2
Try updating your DirectX:
http://go.microsoft.com/fwlink/?prd=1123...lcid=0x409
http://www.microsoft.com/downloads/detai...ceb6d8fa8d
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
Update to SP1
install the latest updates

install http://support.microsoft.com/kb/2488113
Reply
#4
in addition install all 4 Visual C++ 2008,2010 you MUST install BOTH 32-bit and 64-bit redist version because you haved win7 x64
http://www.microsoft.com/downloads/en/de...4b9f2bc1bf
http://www.microsoft.com/downloads/en/de...BF0912DB84
http://www.microsoft.com/downloads/en/de...8D7548C1B6
http://www.microsoft.com/downloads/en/de...50143D5867

Main Hub:i5-4670(3.4Ghz Factory Clocked),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply
#5
I have SP1 installed, I have Directx11 (see screenshot) and I´ve installed all visual C++2008 AND 2010. But the same happens, the program crashes when I set it to dx11 and try to load an iso.
What the heck!?


Attached Files Thumbnail(s)
   
Reply
#6
If you haven't updated your DirectX then you only have the base DirectX11 files, you still need need to update it (there's an update every few months).

So... did you try running the updater I linked to before? What did it say?
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#7
Ok, I did it. The first time I tried to use the dx installer it reported an error, yesterday I tried it again and it downloaded the latest update right, and I got it to work at 60fps average. I only have one question: I have Speedhacks enabled and both EE Cyclerate and VU Cycle Stealing set to 3 in order to get this fps, is this right? or there´s something wrong?
Thanks.
Reply
#8
Setting EE and VU cycle rate too high will cause both compatibility problems and random other problems. Some games it's weirdness (.hack//GU for example character models can have their internal skeletons break leading to deformations) other games it just causes additional slowdowns even if the FPS remains high.
[Image: 2748844.png]
Reply
#9
I tweaked down a bit those values and luckily Im still getting 60fps, although If I completely disable these speedhacks, fps goes down. So, Im using them but moderately and i.e God of war 2 is running great.
Thanks for your help peolpe!!!

Reply




Users browsing this thread: 1 Guest(s)