Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Nvidia Secondary gfx card
#1
The default graphics card on my laptop is the Intel HD integrated graphics, and I'd like to use my 630m instead. Under the Nvidia 3D settings, I have added PCSX2 1.0.0 rv5350.exe to the programs list and enabled the NVIDIA High-Performance Graphics option.

When loading up pcsx2 the console shows that it is still loading the intel 4000 graphics.
Binding GS: C:\Program Files (x86)\PCSX2 1.0.0\Plugins\gsdx32avx-r5350.dll
Windows 6.2.9200
Intel® HD Graphics 4000 (9.18.13.1090)

Is there something I'm missing? Thanks.

Also, yes I've restarted pcsx2.

These are the instructions I originally followed, that don't seem to work.
http://code.google.com/p/pcsx2/issues/detail?id=1026


Attached Files Thumbnail(s)
           
Reply

Sponsored links

#2
This is easy. Right click the PCSX2 runner, and mouse over "Run With Graphics Processor"

Choose your Nvidia card and it'll play on your 630m.
Reply
#3
It still shows the same console line. So is it actually loading the nvidia card or is it using the intel hd 4000

Loading plugins...
Binding GS: C:\Program Files (x86)\PCSX2 1.0.0\Plugins\gsdx32-avx-r5350.dll
Windows 6.2.9200
(GameDB) 9640 games on record (loaded in 174ms)
Intel® HD Graphics 4000 (9.18.13.1090)
Binding PAD: C:\Program Files (x86)\PCSX2 1.0.0\Plugins\lilypad-r5350.dll
Binding SPU2: C:\Program Files (x86)\PCSX2 1.0.0\Plugins\spu2-x-r5350.dll
Binding CDVD: C:\Program Files (x86)\PCSX2 1.0.0\Plugins\cdvdGigaherz.dll
Binding USB: C:\Program Files (x86)\PCSX2 1.0.0\Plugins\USBnull.dll
Binding FW: C:\Program Files (x86)\PCSX2 1.0.0\Plugins\FWnull.dll
Binding DEV9: C:\Program Files (x86)\PCSX2 1.0.0\Plugins\DEV9null.dll
Plugins loaded successfully.
Reply
#4
If doing that doesn't work you're looking at a problem with your computer. Try changing the universal default to your Nvidia card.

Go to your Nvidia control panel, click on the Global Settings tab, change it to your 630M, and click Apply.

If THAT doesn't work, I recommend calling support, because it's supposed to change when you tell it.
Reply
#5
The attached thumbnails show that I've done that, and I know it's not a problem with the card because it runs fine in dolphin and several mmo's
Reply
#6
I didn't say it was a problem with your card, just that it's a problem with your computer. If you're telling your computer to do something and it's not doing it, you should contact support.

Granted, when I try to change a program's default video card in the panel it doesn't work, but when I run it by right clicking, or change the universal default, it works.

If that option isn't working then there is an issue somewhere in your computer that's preventing it from doing so.
Reply
#7
also try going in pcsx2 to config/gs/plugin settings...look at the first or second dropdown box...you should be able to change your gpu device there
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#8
(02-17-2013, 01:20 AM)DaTankAC Wrote: also try going in pcsx2 to config/gs/plugin settings...look at the first or second dropdown box...you should be able to change your gpu device there

Maybe that's a special plugin you have, because I just have renderer<dx9/11 software/hardware and null
Reply
#9
(02-17-2013, 01:20 AM)DaTankAC Wrote: also try going in pcsx2 to config/gs/plugin settings...look at the first or second dropdown box...you should be able to change your gpu device there

As far as I recall, that's just selecting what version of the plugin to use, DirectX9-11.
Reply
#10
I get this after starting a game, so I guess it's working. Though there are some framerate drops that shouldn't be happening.
Initializing plugins...
Init GS
Windows 6.2.9200
NVIDIA GeForce GT 630M (9.18.13.1090)
Init PAD
Init SPU2
Init CDVD
Init USB
Init FW
Init DEV9
Plugins initialized successfully.
Reply




Users browsing this thread: 1 Guest(s)