Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
OPENGL drivers support for PCSX2
#11
Hum, do you run on the chroot? Why don't you use the multilib capabilitie?
Anyway
Quote:libGL error: MESA-LOADER: could not create udev device for fd 14
Somethings is wrong in your driver setting, no permission to access the GPU maybe.
Reply

Sponsored links

#12
This was setup a few years ago - the instruction was to use a 32bit chroot on 64bit hosts as there was no intention to port the assembly bits of pcsx2 to 64bit and there were difficulties setting things up (missing 32bit packages etc). However this was a few years ago - fair point, I know that Debian has been working on multiarch in the interim - I will test this later (likely today).

Yes, I assume its after a real device file that hasn't been mounted in the chroot (although its odd that it worked at all if thats the case).
Reply
#13
Keep the root to build pcsx2. Use multiarch to run it.
Reply
#14
Got you. I tried to install the 32bit dependencies, but got massive dependency hell (this feels familiar so I probably did this last time):

Code:
sudo aptitude install libaio-dev:i386 libasound2-dev:i386 libbz2-dev:i386 libcg:i386 libcggl:i386 libegl1-mesa-dev:i386 libgl1-mesa-dev:i386 libglew-dev:i386 libglu1-mesa-dev:i386 libgtk2.0-dev:i386 libjpeg-dev:i386 libsdl1.2-dev:i386 libsoundtouch-dev:i386 libsparsehash-dev libwxbase2.8-dev:i386 libwxgtk2.8-dev:i386 libx11-dev:i386 nvidia-cg-dev:i386  nvidia-cg-toolkit portaudio19-dev:i386 zlib1g-dev:i386
Note: selecting "libjpeg8-dev:i386" instead of the
      virtual package "libjpeg-dev"
The following NEW packages will be installed:
  binutils:i386{ab} cpp:i386{ab} cpp-4.8:i386{ab} gcc:i386{ab} gcc-4.8:i386{ab} gir1.2-atk-1.0:i386{ab} gir1.2-freedesktop:i386{ab} gir1.2-gdkpixbuf-2.0:i386{ab} gir1.2-glib-2.0:i386{ab}
  gir1.2-gtk-2.0:i386{ab} gir1.2-pango-1.0:i386{ab} libaio-dev:i386 libasan0:i386{a} libasound2-dev:i386 libatk1.0-0:i386{a} libatk1.0-dev:i386{ab} libatomic1:i386{a} libavahi-client-dev:i386{ab}
  libavahi-common-dev:i386{ab} libbz2-1.0:i386{a} libbz2-dev:i386 libc6-dev:i386{a} libcaca-dev:i386{ab} libcairo-gobject2:i386{a} libcairo-script-interpreter2:i386{a} libcairo2:i386{a}
  libcairo2-dev:i386{ab} libcg{a} libcg:i386 libcggl{a} libcggl:i386 libcloog-isl4:i386{a} libdatrie1:i386{a} libdbus-1-dev:i386{a} libdirectfb-dev:i386{ab} libdirectfb-extra:i386{a} libegl1-mesa:i386{a}
  libegl1-mesa-dev:i386{b} libegl1-mesa-drivers:i386{a} libexpat1-dev:i386{a} libfontconfig1-dev:i386{a} libfreetype6-dev:i386{ab} libgbm1:i386{a} libgcc-4.8-dev:i386{a} libgdk-pixbuf2.0-dev:i386{ab}
  libgirepository-1.0-1:i386{ab} libgl1-mesa-dev:i386{b} libgl1-mesa-dri:i386{a} libgl1-mesa-glx:i386{a} libglapi-mesa:i386{a} libglew-dev:i386 libglew1.10:i386{a} libglib2.0-dev:i386{ab}
  libglu1-mesa:i386{a} libglu1-mesa-dev:i386{b} libgomp1:i386{a} libgraphite2-3:i386{a} libgtk2.0-0:i386{a} libgtk2.0-dev:i386{b} libharfbuzz-dev:i386{ab} libharfbuzz-gobject0:i386{a}
  libharfbuzz-icu0:i386{a} libharfbuzz0b:i386{a} libice-dev:i386{a} libicu52:i386{a} libisl10:i386{a} libitm1:i386{a} libjack-dev:i386{a} libjack0:i386{ab} libjpeg8-dev:i386 libmpc3:i386{a}
  libmpfr4:i386{a} libopenvg1-mesa:i386{a} libpango-1.0-0:i386{a} libpango1.0-dev:i386{ab} libpangocairo-1.0-0:i386{a} libpangoft2-1.0-0:i386{a} libpangoxft-1.0-0:i386{a} libpcre3-dev:i386{a}
  libpcrecpp0:i386{a} libpixman-1-0:i386{a} libpixman-1-dev:i386{ab} libpng12-dev:i386{ab} libportaudio2:i386{a} libportaudiocpp0:i386{a} libpthread-stubs0-dev:i386{a} libpulse-dev:i386{a}
  libpulse-mainloop-glib0:i386{a} libpython-stdlib:i386{a} libpython2.7-minimal:i386{a} libpython2.7-stdlib:i386{a} libquadmath0:i386{a} libreadline6:i386{a} libsdl1.2-dev:i386{b} libslang2-dev:i386{a}
  libsm-dev:i386{a} libsoundtouch-dev:i386 libsoundtouch0:i386{a} libsparsehash-dev libthai0:i386{a} libts-dev:i386{a} libwayland-client0:i386{a} libwayland-cursor0:i386{a} libwayland-dev:i386{ab}
  libwayland-egl1-mesa:i386{a} libwayland-server0:i386{a} libwxbase2.8-0:i386{a} libwxbase2.8-dev:i386 libwxbase3.0-0:i386{a} libwxgtk2.8-0:i386{a} libwxgtk2.8-dev:i386 libx11-dev:i386
  libx11-xcb-dev:i386{ab} libxau-dev:i386{a} libxcb-dri2-0-dev:i386{a} libxcb-dri3-dev:i386{a} libxcb-glx0-dev:i386{a} libxcb-present-dev:i386{a} libxcb-render0-dev:i386{a} libxcb-shape0:i386{a}
  libxcb-shm0:i386{a} libxcb-shm0-dev:i386{a} libxcb-sync-dev:i386{a} libxcb-xfixes0:i386{a} libxcb1-dev:i386{a} libxcomposite-dev:i386{ab} libxcomposite1:i386{a} libxcursor-dev:i386{a}
  libxdamage-dev:i386{ab} libxdmcp-dev:i386{a} libxext-dev:i386{a} libxfixes-dev:i386{ab} libxft-dev:i386{ab} libxft2:i386{a} libxi-dev:i386{ab} libxinerama-dev:i386{a} libxinerama1:i386{a}
  libxrandr-dev:i386{a} libxrandr2:i386{a} libxrender-dev:i386{a} libxshmfence-dev:i386{a} libxxf86vm-dev:i386{a} linux-libc-dev:i386{a} mesa-common-dev:i386{ab} nvidia-cg-dev{a} nvidia-cg-dev:i386
  nvidia-cg-toolkit portaudio19-dev:i386 python:i386{ab} python-minimal:i386{ab} python2.7:i386{ab} python2.7-minimal:i386{ab} uuid-dev:i386{ab} wx-common:i386{a} wx2.8-headers:i386{a} zlib1g-dev:i386
0 packages upgraded, 156 newly installed, 0 to remove and 7 not upgraded.
Need to get 74.8 MB/80.6 MB of archives. After unpacking 343 MB will be used.
The following packages have unmet dependencies:
gir1.2-atk-1.0 : Conflicts: gir1.2-atk-1.0:i386 but 2.12.0-1 is to be installed.
gir1.2-atk-1.0:i386 : Conflicts: gir1.2-atk-1.0 but 2.12.0-1 is installed.
libgl1-mesa-dev : Conflicts: libgl1-mesa-dev:i386 but 10.1.2-1 is to be installed.
libgl1-mesa-dev:i386 : Conflicts: libgl1-mesa-dev but 10.1.2-1 is installed.
libjack-jackd2-0 : Conflicts: libjack-0.116:i386 which is a virtual package.
                    Conflicts: libjack0:i386 but 1:0.124.1+20140122git5013bed0-2 is to be installed.
libglu1-mesa-dev : Conflicts: libglu1-mesa-dev:i386 but 9.0.0-2 is to be installed.
libglu1-mesa-dev:i386 : Conflicts: libglu1-mesa-dev but 9.0.0-2 is installed.
libxdamage-dev : Conflicts: libxdamage-dev:i386 but 1:1.1.4-1 is to be installed.
libxdamage-dev:i386 : Conflicts: libxdamage-dev but 1:1.1.4-1 is installed.
libpixman-1-dev : Conflicts: libpixman-1-dev:i386 but 0.32.4-1 is to be installed.
libpixman-1-dev:i386 : Conflicts: libpixman-1-dev but 0.32.4-1 is installed.
libfreetype6-dev : Conflicts: libfreetype6-dev:i386 but 2.5.2-1 is to be installed.
libfreetype6-dev:i386 : Conflicts: libfreetype6-dev but 2.5.2-1 is installed.
libgirepository-1.0-1 : Conflicts: libgirepository-1.0-1:i386 but 1.40.0-2 is to be installed.
libgirepository-1.0-1:i386 : Conflicts: libgirepository-1.0-1 but 1.40.0-2 is installed.
python-minimal : Conflicts: python-minimal:i386 but 2.7.6-1 is to be installed.
python-minimal:i386 : Conflicts: python-minimal but 2.7.6-1 is installed.
libsdl1.2-dev : Conflicts: libsdl1.2-dev:i386 but 1.2.15-9 is to be installed.
libsdl1.2-dev:i386 : Conflicts: libsdl1.2-dev but 1.2.15-9 is installed.
cpp-4.8 : Conflicts: cpp-4.8:i386 but 4.8.2-21 is to be installed.
cpp-4.8:i386 : Conflicts: cpp-4.8 but 4.8.2-21 is installed.
libpango1.0-dev : Conflicts: libpango1.0-dev:i386 but 1.36.3-1 is to be installed.
libpango1.0-dev:i386 : Conflicts: libpango1.0-dev but 1.36.3-1 is installed.
libegl1-mesa-dev : Conflicts: libegl1-mesa-dev:i386 but 10.1.2-1 is to be installed.
libegl1-mesa-dev:i386 : Conflicts: libegl1-mesa-dev but 10.1.2-1 is installed.
libdirectfb-dev : Conflicts: libdirectfb-dev:i386 but 1.2.10.0-5 is to be installed.
libdirectfb-dev:i386 : Conflicts: libdirectfb-dev but 1.2.10.0-5 is installed.
libjack0:i386 : Conflicts: libjack-0.116 which is a virtual package.
libavahi-client-dev : Conflicts: libavahi-client-dev:i386 but 0.6.31-4 is to be installed.
libavahi-client-dev:i386 : Conflicts: libavahi-client-dev but 0.6.31-4 is installed.
gir1.2-pango-1.0 : Conflicts: gir1.2-pango-1.0:i386 but 1.36.3-1 is to be installed.
gir1.2-pango-1.0:i386 : Conflicts: gir1.2-pango-1.0 but 1.36.3-1 is installed.
libxcomposite-dev : Conflicts: libxcomposite-dev:i386 but 1:0.4.4-1 is to be installed.
libxcomposite-dev:i386 : Conflicts: libxcomposite-dev but 1:0.4.4-1 is installed.
uuid-dev : Conflicts: uuid-dev:i386 but 2.20.1-5.7 is to be installed.
uuid-dev:i386 : Conflicts: uuid-dev but 2.20.1-5.7 is installed.
libwayland-dev : Conflicts: libwayland-dev:i386 but 1.4.0-1 is to be installed.
libwayland-dev:i386 : Conflicts: libwayland-dev but 1.4.0-1 is installed.
libx11-xcb-dev : Conflicts: libx11-xcb-dev:i386 but 2:1.6.2-1 is to be installed.
libx11-xcb-dev:i386 : Conflicts: libx11-xcb-dev but 2:1.6.2-1 is installed.
gir1.2-gdkpixbuf-2.0 : Conflicts: gir1.2-gdkpixbuf-2.0:i386 but 2.30.7-1 is to be installed.
gir1.2-gdkpixbuf-2.0:i386 : Conflicts: gir1.2-gdkpixbuf-2.0 but 2.30.7-1 is installed.
python2.7 : Conflicts: python2.7:i386 but 2.7.6-8 is to be installed.
python2.7:i386 : Conflicts: python2.7 but 2.7.6-8 is installed.
libglib2.0-dev : Conflicts: libglib2.0-dev:i386 but 2.40.0-3 is to be installed.
libglib2.0-dev:i386 : Conflicts: libglib2.0-dev but 2.40.0-3 is installed.
gir1.2-gtk-2.0 : Conflicts: gir1.2-gtk-2.0:i386 but 2.24.23-1 is to be installed.
gir1.2-gtk-2.0:i386 : Conflicts: gir1.2-gtk-2.0 but 2.24.23-1 is installed.
gir1.2-freedesktop : Conflicts: gir1.2-freedesktop:i386 but 1.40.0-2 is to be installed.
gir1.2-freedesktop:i386 : Conflicts: gir1.2-freedesktop but 1.40.0-2 is installed.
binutils : Conflicts: binutils:i386 but 2.24.51.20140425-1 is to be installed.
binutils:i386 : Conflicts: binutils but 2.24.51.20140425-1 is installed.
libxi-dev : Conflicts: libxi-dev:i386 but 2:1.7.2-1 is to be installed.
libxi-dev:i386 : Conflicts: libxi-dev but 2:1.7.2-1 is installed.
gcc : Conflicts: gcc:i386 but 4:4.8.2-4 is to be installed.
gcc:i386 : Conflicts: gcc but 4:4.8.2-4 is installed.
gir1.2-glib-2.0 : Conflicts: gir1.2-glib-2.0:i386 but 1.40.0-2 is to be installed.
gir1.2-glib-2.0:i386 : Conflicts: gir1.2-glib-2.0 but 1.40.0-2 is installed.
libpng12-dev : Conflicts: libpng12-dev:i386 but 1.2.50-1 is to be installed.
libpng12-dev:i386 : Conflicts: libpng12-dev but 1.2.50-1 is installed.
cpp : Conflicts: cpp:i386 but 4:4.8.2-4 is to be installed.
cpp:i386 : Conflicts: cpp but 4:4.8.2-4 is installed.
libcaca-dev : Conflicts: libcaca-dev:i386 but 0.99.beta18-1.1 is to be installed.
libcaca-dev:i386 : Conflicts: libcaca-dev but 0.99.beta18-1.1 is installed.
libxfixes-dev : Conflicts: libxfixes-dev:i386 but 1:5.0.1-1 is to be installed.
libxfixes-dev:i386 : Conflicts: libxfixes-dev but 1:5.0.1-1 is installed.
gcc-4.8 : Conflicts: gcc-4.8:i386 but 4.8.2-21 is to be installed.
gcc-4.8:i386 : Conflicts: gcc-4.8 but 4.8.2-21 is installed.
libcairo2-dev : Conflicts: libcairo2-dev:i386 but 1.12.16-2 is to be installed.
libcairo2-dev:i386 : Conflicts: libcairo2-dev but 1.12.16-2 is installed.
python : Conflicts: python:i386 but 2.7.6-1 is to be installed.
python:i386 : Conflicts: python but 2.7.6-1 is installed.
libxft-dev : Conflicts: libxft-dev:i386 but 2.3.1-2 is to be installed.
libxft-dev:i386 : Conflicts: libxft-dev but 2.3.1-2 is installed.
python2.7-minimal : Conflicts: python2.7-minimal:i386 but 2.7.6-8 is to be installed.
python2.7-minimal:i386 : Conflicts: python2.7-minimal but 2.7.6-8 is installed.
mesa-common-dev : Conflicts: mesa-common-dev:i386 but 10.1.2-1 is to be installed.
mesa-common-dev:i386 : Conflicts: mesa-common-dev but 10.1.2-1 is installed.
libgdk-pixbuf2.0-dev : Conflicts: libgdk-pixbuf2.0-dev:i386 but 2.30.7-1 is to be installed.
libgdk-pixbuf2.0-dev:i386 : Conflicts: libgdk-pixbuf2.0-dev but 2.30.7-1 is installed.
libharfbuzz-dev : Conflicts: libharfbuzz-dev:i386 but 0.9.28-1 is to be installed.
libharfbuzz-dev:i386 : Conflicts: libharfbuzz-dev but 0.9.28-1 is installed.
libatk1.0-dev : Conflicts: libatk1.0-dev:i386 but 2.12.0-1 is to be installed.
libatk1.0-dev:i386 : Conflicts: libatk1.0-dev but 2.12.0-1 is installed.
libgtk2.0-dev : Conflicts: libgtk2.0-dev:i386 but 2.24.23-1 is to be installed.
libgtk2.0-dev:i386 : Conflicts: libgtk2.0-dev but 2.24.23-1 is installed.
libavahi-common-dev : Conflicts: libavahi-common-dev:i386 but 0.6.31-4 is to be installed.
libavahi-common-dev:i386 : Conflicts: libavahi-common-dev but 0.6.31-4 is installed.
open: 1546; closed: 4637; defer: 274; conflict: 392                                                                                                                                                              oInternal error: found 2 (choice -> promotion) mappings for a single choice.
open: 1929; closed: 5189; defer: 340; conflict: 461                                                                                                                                                              .Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
open: 2148; closed: 6010; defer: 351; conflict: 472                                                                                                                                                              oInternal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
open: 2614; closed: 7351; defer: 386; conflict: 509                                                                                                                                                              oThe following actions will resolve these dependencies:

       Remove the following packages:                                              
1)       audacity                                                                  
2)       avidemux                                                                  
3)       avidemux-plugins                                                          
4)       blender                                                                  
5)       espeak                                                                    
6)       ffmpeg                                                                    
7)       freedoom                                                                  
8)       gir1.2-farstream-0.1                                                      
9)       gnome-media                                                              
10)      gnome-sushi                                                              
11)      gstreamer0.10-plugins-good                                                
12)      gstreamer1.0-plugins-good                                                
13)      libasound2-plugins                                                        
14)      libav-tools                                                              
15)      libavdevice53                                                            
16)      libblkid-dev                                                              
17)      libespeak1                                                                
18)      libfarstream-0.1-0                                                        
19)      libfarstream-0.1-dev                                                      
20)      libfluidsynth1                                                            
21)      libjack-jackd2-0                                                          
22)      libportaudio2                                                            
23)      libpurple-bin                                                            
24)      libpurple0                                                                
25)      libsdl-mixer1.2                                                          
26)      libsdl-mixer1.2-dev                                                      
27)      mplayer2                                                                  
28)      pidgin                                                                    
29)      pidgin-dbg                                                                
30)      pidgin-festival                                                          
31)      pidgin-plugin-pack                                                        
32)      prboom                                                                    
33)      prboom-plus                                                              
34)      quodlibet                                                                
35)      redeclipse                                                                
36)      smc                                                                      
37)      smc-music                                                                
38)      smplayer                                                                  
39)      smplayer-l10n                                                            
40)      timidity                                                                  
41)      timidity-daemon                                                          
42)      uuid-dev                                                                  
43)      wireshark                                                                

       Keep the following packages at their current version:                      
44)      binutils:i386 [Not Installed]                                            
45)      cpp:i386 [Not Installed]                                                  
46)      cpp-4.8:i386 [Not Installed]                                              
47)      gcc:i386 [Not Installed]                                                  
48)      gcc-4.8:i386 [Not Installed]                                              
49)      gir1.2-atk-1.0:i386 [Not Installed]                                      
50)      gir1.2-freedesktop:i386 [Not Installed]                                  
51)      gir1.2-gdkpixbuf-2.0:i386 [Not Installed]                                
52)      gir1.2-glib-2.0:i386 [Not Installed]                                      
53)      gir1.2-gtk-2.0:i386 [Not Installed]                                      
54)      gir1.2-pango-1.0:i386 [Not Installed]                                    
55)      libatk1.0-dev:i386 [Not Installed]                                        
56)      libavahi-client-dev:i386 [Not Installed]                                  
57)      libavahi-common-dev:i386 [Not Installed]                                  
58)      libcaca-dev:i386 [Not Installed]                                          
59)      libcairo2-dev:i386 [Not Installed]                                        
60)      libdirectfb-dev:i386 [Not Installed]                                      
61)      libegl1-mesa-dev:i386 [Not Installed]                                    
62)      libfontconfig1-dev:i386 [Not Installed]                                  
63)      libfreetype6-dev:i386 [Not Installed]                                    
64)      libgdk-pixbuf2.0-dev:i386 [Not Installed]                                
65)      libgirepository-1.0-1:i386 [Not Installed]                                
66)      libgl1-mesa-dev:i386 [Not Installed]                                      
67)      libglew-dev:i386 [Not Installed]                                          
68)      libglib2.0-dev:i386 [Not Installed]                                      
69)      libglu1-mesa-dev:i386 [Not Installed]                                    
70)      libgtk2.0-dev:i386 [Not Installed]                                        
71)      libharfbuzz-dev:i386 [Not Installed]                                      
72)      libpango1.0-dev:i386 [Not Installed]                                      
73)      libpixman-1-dev:i386 [Not Installed]                                      
74)      libpng12-dev:i386 [Not Installed]                                        
75)      libpulse-dev:i386 [Not Installed]                                        
76)      libsdl1.2-dev:i386 [Not Installed]                                        
77)      libslang2-dev:i386 [Not Installed]                                        
78)      libwayland-dev:i386 [Not Installed]                                      
79)      libx11-xcb-dev:i386 [Not Installed]                                      
80)      libxcomposite-dev:i386 [Not Installed]                                    
81)      libxcursor-dev:i386 [Not Installed]                                      
82)      libxdamage-dev:i386 [Not Installed]                                      
83)      libxfixes-dev:i386 [Not Installed]                                        
84)      libxft-dev:i386 [Not Installed]                                          
85)      libxi-dev:i386 [Not Installed]                                            
86)      mesa-common-dev:i386 [Not Installed]                                      
87)      python:i386 [Not Installed]                                              
88)      python-minimal:i386 [Not Installed]                                      
89)      python2.7:i386 [Not Installed]                                            
90)      python2.7-minimal:i386 [Not Installed]                                    

       Leave the following dependencies unresolved:                                
91)      audacity-data recommends audacity                                        
92)      libbrasero-media3-1 recommends gstreamer1.0-plugins-good                  
93)      dir2ogg recommends mplayer                                                
94)      eureka recommends freedoom | game-data-packager | boom-wad | doom-wad    
95)      gnome-applets recommends gnome-media                                      
96)      nautilus recommends gnome-sushi                                          
97)      pidgin recommends gstreamer0.10-plugins-good                              
98)      task-xfce-desktop recommends quodlibet                                    
99)      libwebkit2gtk-3.0-25 recommends gstreamer1.0-plugins-good                
100)     libwebkitgtk-1.0-0 recommends gstreamer1.0-plugins-good                  
101)     libwebkitgtk-3.0-0 recommends gstreamer1.0-plugins-good                  
102)     wireshark-common recommends wireshark (>= 1.10.7-2) | tshark (>= 1.10.7-2)
103)     youtube-dl recommends libav-tools | ffmpeg                                
104)     youtube-dl recommends libav-tools | ffmpeg (>= 4:0.6) | ffprobe          
105)     youtube-dl recommends mplayer2 | mplayer                                  
106)     libc6-dev:i386 recommends gcc:i386 | c-compiler:i386                      
107)     python-minimal:i386 recommends python:i386                                
108)     python2.7-minimal:i386 recommends python2.7:i386

I think I earlier took this to mean pcsx2 couldn't coexist with the real OS.
Reply
#15
No don't use dev package (it is for build). You only need the runtime lib (it is the same but dependency aren't the same)
Reply
#16
(05-21-2014, 10:14 PM)gregory Wrote: No don't use dev package (it is for build). You only need the runtime lib (it is the same but dependency aren't the same)

Ah, sorry, being braindead. I managed to get pcsx2-dev to run now in the main OS, however the final problem (it seems) is the sound plugin - turns out I have been using an old zerospu2 compile that is no longer built by default. Running pcsx2 in the host OS flags this 'dynamic library' as invalid, so I deleted it. However instead of allowing me to select spu2x as the successor, only SPU2 null is showing (both shared object files are present in the plugins directory). I reenabled zerospu2 compilation, and now after installing that isn't available in the menu either.

So while I now have successful accelerated video:

Code:
glX-Version 1.4 with Direct Rendering
Supported Opengl version: 3.3 (Core Profile) Mesa 10.1.2 on GPU: Gallium 0.4 on AMD RV770. Vendor: X.Org

audio is dead.

This time there are no errors to tell me why it doesnt want to show the correct audio plugin as an option.
Reply
#17
Easy you miss 32 bits lib for spu2x. You can check them with the ldd tool on the .so file.
Reply
#18
Thanks again, I'll need to remember that. The next problem looks to be a blocker though - now libsoundtouch0:i386 is installed, I can select use the audio plugin but sound is still dead.

Code:
*** SPU2-X Warning:
    The savestate you are trying to load was not made with this plugin.
    Audio may not recover correctly.  Save your game to memorycard, reset,

    and then continue from there.

ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib dlmisc.c:252:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib/i386-linux-gnu/alsa-lib/libasound_module_pcm_pulse.so
ALSA lib dlmisc.c:252:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib/i386-linux-gnu/alsa-lib/libasound_module_pcm_pulse.so
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
* SPU2-X: Enumerating PortAudio devices:
*** Device 0: 'HDA ATI SB: ALC889 Digital (hw:0,1)' (ALSA)
*** Device 1: 'HDA ATI HDMI: 0 (hw:1,3)' (ALSA)
*** Device 2: 'Sennheiser SC60 for Lync: USB Audio (hw:2,0)' (ALSA)
*** Device 3: 'sysdefault' (ALSA)
*** Device 4: 'iec958' (ALSA)
*** Device 5: 'spdif' (ALSA)
*** Device 6: 'default' (ALSA)
*** Device 7: 'dmix' (ALSA)
* SPU2-X: PortAudio error: Invalid device
* SPU2-X: Init SPU2 core 0
* SPU2-X: Init SPU2 core 1

Pulse audio is blacklisted here (I have a perfectly working ALSA setup), but '/usr/lib/i386-linux-gnu/alsa-lib/libasound_module_pcm_pulse.so' is owned by libasound2-plugins:i386. I have tried to install this, but via libavcodec55:i386 it depends on libmp3lame0:i386 which introduces another break:

Code:
The following NEW packages will be installed:
  libmp3lame0:i386{b}
0 packages upgraded, 1 newly installed, 0 to remove and 7 not upgraded.
Need to get 384 kB of archives. After unpacking 628 kB will be used.
The following packages have unmet dependencies:
libmp3lame0 : Conflicts: libmp3lame0:i386 but 3.99.5+repack1-3 is to be installed.
libmp3lame0:i386 : Breaks: libmp3lame0 (!= 3.99.5+repack1-3) but 1:3.99.5-0.0 is installed.
The following actions will resolve these dependencies:

<lots of removals etc>

Currently libmp3lame0:amd64 has version '3.99.5-0.0', so I bet this is a version mismatch between the amd64 and i386 packages. Will probably have to wait for Debian to sort itself out before I can progress.
Reply
#19
sid -> testing migration is not synchronous. Otherwise did you try both sdl and portaudio on spu2x?
Reply
#20
This problem is purely with the host OS atm - the amd64 and i386 packages there - so I don't think I should be hitting up against Testing/Unstable issues. I looked further into the breakage and realised libmp3lame0:amd64 had an invalid version:

Code:
# aptitude versions libmp3lame0

Package libmp3lame0:                        
p A 3.99.5+repack1-3                    stable,testing,unstable                             990
i A 1:3.99.5-0.0                                                                                           100

The package must have been installed as part of the special install required for avidemux from the 3rd party Debian Multimedia site - once I force 'downgraded' it to the known version, avidemux needed to be removed.

Once I sorted that out, I was able to run pcsx normally after some SPU2X configuration Smile I would like to donate £20 to you - do you have a Paypal address? Thanks for all your help - running this in the host OS is definitely an improvement.

I'm very disappointed that even with OpenGL3.3, pcsx2 release build still fails to run GTA3 at normal framerate, and when smoke is on the screen, can easily get down to 25fps. In Final Fantasy X, Shiva's summon when she descends into the ice crystal slows down considerably too - I guess I'll need to wait another year or so to see if things have sped up enough to consider it a PlayStation 2 replacement (both pcsx2 and radeon improvements presumably).
Reply




Users browsing this thread: 1 Guest(s)