Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Odd way to speed up emulator with a video?
#1
For some reason, though the emulator (0.9.8 r4600) usually lags a bit, I find that when I open up a youtube video (the video doesn't need to be playing), I get a massive speedup. By massive speedup, I mean, it used to be about 50 fps, and after opening up the video, it gets to around 100 fps (and forces me to use a frame limiter).

Is there any reason for this? Am I just insane? Has this question been asked before?

EDIT: Thanks guys, those responses actually make a lot of sense. And thanks for the links as well. Glad to know I'm not crazy....
Reply

Sponsored links

#2
If I were to take a wild guess, I would guess that your GPU isn't being put under enough stress so it never switches over to a higher clock. However, when you open a YouTube video and your GPU handles the video, it switches to a higher clock, allowing you more speed.

But don't take my word for it; I'm technologically illiterate.
Want to contribute? Don't know how? Check out the PCSX2 Wiki page!



Keep safe with MyWOT.

I have everything...
Reply
#3
If I had to guess,
I'd say you may have encounter something like this...

http://forums.pcsx2.net/Thread-Higher-res-higher-FPS

My experience was not a result of phases.
Not sure what else to say.

BTW - What are your system specs...?
Reply
#4
@Rezard Isn't that thread dealing with video cards and how fast they process certain things, like how modern cards process bigger textures faster?

While a similar effect, it doesn't seem to apply here. But again, I really don't know much and I did a lot of skimming.
Want to contribute? Don't know how? Check out the PCSX2 Wiki page!



Keep safe with MyWOT.

I have everything...
Reply
#5
pscx2 isn't triggering most of the highperformance switches. i guess this also running under iest or c&q. the youtube trick is common cause flash get's accelerated with the hardware video decoder forcing the clock to raise. you can especially see that with for example gpu observer gadget or something. in oticed that too and use that usually when watching sharpened full HD on my lap where the player doesn't trigger the gpu to performance.

so.. yeah.. this correctly found out. Wink
Reply
#6
I think this is the related thread:
http://forums.pcsx2.net/Thread-very-crit...-ATI-cards

I've searched about a way to tell the gpu to be in high performance mode, but I've found nothing yet. It seems to be a driver thing, and this could very well be a driver bug. I'm currently using some beta drivers, and sometimes the 2d clock just doesn't change no matter the application I run. There seem to be some optirun for linux that can do something like that with nVIDIA cards, which might offer some clue. But I really doubt it.

As of now, try setting your power manangement profile to high performance? Worth the try.
[Image: nbKSK.jpg]
Reply
#7
If you're using an NVIDIA card, go to your NVIDIA control panel and select "Prefer maximum performance" for the power management option. Also make sure that your battery plan in also High Performance.
[Image: signat11.jpg]

My Guide to PCSX2 for Windows (outdated, but still generally accurate)
Reply




Users browsing this thread: 1 Guest(s)