Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Official Comment Thread] Playground beta versions and svn compiles
#1
Ok people, all your comments on betas or svn compiles go in here Smile

Note this is not for bug reports, but for things like : considerations on speed, improvements, the like.... Anything you feel the team should know Smile

Sponsored links

#2
I play game suekoden V, with official playgroung and beta svn.563. That game was working fine, but if i enable waitcycles sync hack in svn.563, i play that game and see with very rare random encounter of enemy, i notice that in world map and maybe in dungeon too. That's like a silly bugs to me, he..X4.
Notebook ASUS A43TA|CPU AMD Llano APU A6-3400m Triple core (1 core disable) OC to 2.6+Ghz|GPU CF|HD 6520 400Mhz/667Mhz iGPU|HD6650M OC 780Mhz/985Mhz dGPU|RAM 8GB DDR3 1333|Windows 7 Ultimate Sp.1 x64 bit.
>> Emulation speed differs for each game. There will be some you can run fast easily, but others will simply require more powerfull hardware <<.
#3
It's a hack,it breaks things,that's why you can turn it on and off...So a hack breaking a game is not a bug.
[Image: newsig.jpg]
#4
Yeah wtf, but i prefer to call that a silly bug (no offense).
Yeah wtf, but i prefer to call that a silly bug (no offense).
Notebook ASUS A43TA|CPU AMD Llano APU A6-3400m Triple core (1 core disable) OC to 2.6+Ghz|GPU CF|HD 6520 400Mhz/667Mhz iGPU|HD6650M OC 780Mhz/985Mhz dGPU|RAM 8GB DDR3 1333|Windows 7 Ultimate Sp.1 x64 bit.
>> Emulation speed differs for each game. There will be some you can run fast easily, but others will simply require more powerfull hardware <<.
#5
EE x1.5 Cycle Rate and IOP x2 Cycle Rate speedhacks of 563 gives a bigger speedup and doesn't make the videos skippy
#6
Is there any way to pause emulation without leaving the GS window, you know, like just using the Pause key on the keyboard? Sometimes (very rarely, but still) the emulator crashes while trying to reclaim focus on the GS window whenever I press on Execute, in order to resume playing. It'd be nice if it wouldn't have to reinitialize video, because I guess that's why sometimes it crashes.
To be human is to know the fear of death, yet keep on fighting.
#7
You can disable the GS Close-on-escape trick from the Misc menu. Uncheck it and Pcsx2 behaves as it did in the "old days." Admittedly, if you don't play games fullscreen then there's little reason to have the Close-on-Esc option enabled anyway.
Jake Stine (Air) - Programmer - PCSX2 Dev Team
#8
(01-13-2009, 11:32 AM)Air Wrote: You can disable the GS Close-on-escape trick from the Misc menu. Uncheck it and Pcsx2 behaves as it did in the "old days." Admittedly, if you don't play games fullscreen then there's little reason to have the Close-on-Esc option enabled anyway.
Yep, I play windowed most of the time. Smile

Thank you.
To be human is to know the fear of death, yet keep on fighting.
#9
Hey guys,

First time posting on the PCSX2 forums (I'm also on the dolphin emu ngemu forums) and I've had, I guess you could say, a curious thing happen lol.

With the latest SVN's, basically anything after the official PG SVN 563 pinned on the beta thread, Devil May Cry [NTSC] will crash on "Stage 4: Black Knight" after walking a few steps, having the phantom re-appear, and walking into the first door on Dante's right (gamers left). This will happen irregardless of speed hacks, advanced options, plugins, and cpu options.

Another interesting note on this bug is that if you avoid the first door and walk all the way back to the puppet room with the airplane, or the room with the time-god statue and then walk back to the door that causes the crashes, the emu will render a bar going across the screen at the top about an inch in width and then crash.

I know a lot of changes are going on with the core right now as well as the TLB version of the emu, but this was seen with both the VM and the TLB. My specs for my pc are below if anyones interested; I searched the forums as well as google and I'm assuming no one else has encountered this hence why I posted it here Smile. Feel free to yell if I've posted in the wrong thread / format.

E8400 Intel Core2Duo @ 3.6GHZ
4GB G-skill PC6400 5-5-5-15
2x8800 GT 512 MB SLI stock
Windows Vista 64-bit Ultimate SP1

PS: I know it's a bug, but I'm assuming the General Discussion page is only for the official beta and the bug report thread is again only for the beta pinned, so.. heh.
#10
I try 3 game with latest beta pp ver.590, FFXII, sukoden V, phantasy star universe, all of them have many bugs compare with official and rev.563. ffxii In old rev. Just fine except missing of letter but in latest beta with many bugs on it. First like FMV frame speed 60fps but seems like 30fps, i try it with vu skip. In rev.563 just fine (smooth). Second have blank picture after continue in game but in old just fine. Sukoden v in rev.563 just fine in FMV with vu skip and else but in latest beta, in vu skip FMV like jumpy frame and have blank picture after continue in game. If i try with Vm that game suddenly close in beggining after loading bios but with VTLB Just running fine. Phantasy SU. same problem with 2 game before. I had all of those games with clean ini file and reconfig back the setting. Meanwhile i have to stay away with rev.590 and play with old rev.563 or official playground.
Notebook ASUS A43TA|CPU AMD Llano APU A6-3400m Triple core (1 core disable) OC to 2.6+Ghz|GPU CF|HD 6520 400Mhz/667Mhz iGPU|HD6650M OC 780Mhz/985Mhz dGPU|RAM 8GB DDR3 1333|Windows 7 Ultimate Sp.1 x64 bit.
>> Emulation speed differs for each game. There will be some you can run fast easily, but others will simply require more powerfull hardware <<.




Users browsing this thread: 1 Guest(s)