Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Okami very slow videos
#1
Hey there, this problem is really annoying as it wasn't a problem until I uninstalled and reinstalled PCSX2.

basically I could run Okami full speed 3xscaling no problem, everything ran full speed, now after reinstalling PCSX2 its full speed until the little fairy starts speaking and it dies. These parts played perfect before, I've checked everything I can possibly check; BIOS, plugins(sound, graphics, pad, dvd) nothing can get rid of it when it played perfect before. As well as this problem, it now seems to take up 100% of my video card when playing these parts, previously I could actually play it 4xscaled but with bearable slowdown, now it won't have a chance of playing at that level.

here's my specs;
i5-460m
ATI 5650m
4gb DDR3

I haven't changed anything else on my comp either.

Any ideas or a solution to the slow video problem?

any help would be greatly appreciated

regards Alex
Reply

Sponsored links

#2
So, what kind of slow down are you talking about? can you play full speed at X3? X2? native? What's consuming most CPU, EE or GS? (check the title bar, EE: xx% GS: xx%) if it's EE, try to use some speed hacks. If it's the GS, try lowering resolution and also try the '8-bit textures' hack.
[i7-3630qm/gt650m-2G/Win-7] [i7-4500u/R.HD8850m/Win-8.1] [2010-MBA/OSX-10.9.x]. Scroll smoothly with SmoothWheel for Firefox.
Reply
#3
Thanks for replying, ingame plays perfect, its just when the little fairy starts talking, pretty much every time actually, thats the only time it slows to 20FPS from 60FPS/70FPS delimited.

-I play at 3x, texture filtering, 8 bit textures, DX11.
-Emulator options, EE/VU=2/1, all speedhacks on (incl. fast disc speed)
-Ingame, EE=80/GS=15-20%, video EE=40/GS= 7%
-Ingame, GPU load=69-75%, video = 100% load, seems like it dumps the rendering of the video completely on the graphics card.

its like its using the GPU wrong, it managed another scale up before, it might seem picky but lowering the resolution or scaling means losing noticeable smoothness, when it was possible to play so much more with my card.

Reply
#4
Maybe DX9 would work better.
[i7-3630qm/gt650m-2G/Win-7] [i7-4500u/R.HD8850m/Win-8.1] [2010-MBA/OSX-10.9.x]. Scroll smoothly with SmoothWheel for Firefox.
Reply
#5
(05-24-2011, 01:36 PM)avih Wrote: Maybe DX9 would work better.

it actually plays freakishly similiar, same problem, i've reinstalled my video drivers as well, no change.

EDIT: removed all speedhacks still no change

edit2: it doesn't seem to be related to what settings I disable, it always plays at 20FPS. I've changed performance, the only thing that I can change is the resolution which improves it but it still doesn't explain the discrepancy between full speed ingame graphics and 20FPS video speed.

I've reduced the resolution to 1600x900 just now which seems good enough, but it still seems like a weird bug or something.

thanks for the replies, I'll post back if I can fix it.

regards Alex
Reply
#6
sorry to double post, but the only thing I can find is that nothing affects the slow motion cut scenes other than changing the resolution. NOTHING else affects it, no speedhacks, texture filter removal, will change it all. Reducing the resolution is the only thing that speeds it up.

Just wondering does this count as a bug?

regards Alex
Reply
#7
http://www.youtube.com/watch?v=vEp_uV_LL8U

thought I'd post a video, still can't find a reason for the slowdown. Its still in 3x scaling gameplay runs beautifully, cutscenes kill it.

there's no speedhacks, texture filtering is on. The video recording seems to have knocked off 10FPS normally its 60PFS


any ideas, anyone? I really want to play through this game but with this slowdown makes it unplayable

cheers Alex
Reply
#8
I found a weird thing happening when changing resolutions with my i5 CPU it refuses to boost up to 2.8ghz when running the cut scenes at really high rez or scaling. ran at native the CPU boosts up and it runs at 60FPS.

I'll edit and get a video up showing it.





the video recorder cut out the intel widget that shows CPU boosting but fullscreen it and check the EE and you'll see that the CPU either splits into 4 1.73ghz cores (instead of 2.8ghz dual cores) or just lets my GPU roast itself trying to cope with emulating the scenes on its own at 100% load. But only at higher res.

anyone came across this? or is it just hyperthreading being crap?

EDIT: confirmed it with CPU-Z bounces between 1.2ghz and 2.8ghz when in the cutscenes stays down at 1.2ghz. Any ideas how to fix this?

regards Alex
Reply
#9
(05-29-2011, 09:19 PM)zanderman2009 Wrote: I found a weird thing happening when changing resolutions with my i5 CPU it refuses to boost up to 2.8ghz when running the cut scenes at really high rez or scaling. ran at native the CPU boosts up and it runs at 60FPS.

I'll edit and get a video up showing it.





the video recorder cut out the intel widget that shows CPU boosting but fullscreen it and check the EE and you'll see that the CPU either splits into 4 1.73ghz cores (instead of 2.8ghz dual cores) or just lets my GPU roast itself trying to cope with emulating the scenes on its own at 100% load. But only at higher res.

anyone came across this? or is it just hyperthreading being crap?

EDIT: confirmed it with CPU-Z bounces between 1.2ghz and 2.8ghz when in the cutscenes stays down at 1.2ghz. Any ideas how to fix this?

regards Alex

found an answer. it was the latest intel drivers I had, being a consciencious laptop owner, got the latest intel drivers for the CPU and after that it sowed right down. long story short, works perfectly at 3xscaled res, texture filtering on, videos and all 60FPS at 2.8ghz superb with windows reinstall and original intel drivers.

this thread can be closed now

thanks for the replies
Reply
#10
intel doesn't have cpu drivers.......
Reply




Users browsing this thread: 1 Guest(s)