Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Onimusha 2 - Graphic Problem
Hi guys,

I'm new here and I first want to say hello to everybody in this forum!

My problem is, as shown in the name of the thread, a graphic problem in the game Onimusha 2.

The character (you, the player) is always in the foreground. For example if there is a table in the room and the character stands behind it, you can see the whole body although you should only see his torso because the table should cover his legs. This problem always occurs no matter which items exist in the background. Everything else seems emulated nearly perfect.

Please help me! Maybe someone had this problem too and could give me an advice. Thanks!

By the way: The problem occurred with PCSX 0.9.6, -r1888 and -0.9.7 (r3119)

Sponsored links

Should work fine with a (Software) renderer in GSdx. Try other graphic plugins too.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
I'm not sure but I think I tried this already before and the graphic problem was gone but the game speed was too slow. Anyway I'll try again. Thanks for your help! :-)
Hi Shadow Lady, so now I tried to emulate the game with a software renderer in GSdx as you said. It worked fine which means the graphic problem I mentioned before was gone but unfortunately the graphic in general was not that acute anymore and there were pixels to see. Any ideas to make the game smoother and also a bit more faster even with a software renderer? Thanks...
Nope. Software tries to be as accurate as possible, this includes running at the original resolution of the PS2 so there's no way to increase that unless you modify the source code and even if you could then it would increase the CPU load anyway making it slower.

Unless you have a quad-core CPU there's not much you can do about speed either, if you have a quad then increase the SW. Threads option to 2 or 3.

I suppose the other plugins have the same problem then? There's not really much to do about it, play it with the glitch or play it in software I guess Tongue2
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Thanks for your reply again! Yes I have a quad-core CPU so I'll try to change the SW. Hmm... I guess you're right so I must decide whether I wanna play fast 'n' nice but with the fu*** glitch or without glitch but a bit more slowly and with PS2 resolution :-S

I'll see... but anyway you was a great help so thank you very much!
Hi all !

I had same problem. I'm using latest pcsx2-4980 . So what's the problem with Direct3D11 Hardware renderer ?

Thanks for any helps.
It's much faster than software mode and less accurate. That's about it Tongue
[Image: newsig.jpg]
ok. it faster but why you dont fix it ?
Because it's hard and sometimes impossible to fix something. There are a billion bugs, if we could fix everything PCSX2 would be perfect already
[Image: newsig.jpg]

Users browsing this thread: 1 Guest(s)