Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
OpenGL Hardware Depth? (Shadows in games)
#1
I was recently able to make the purchase of an i7 4970k and a GTX 970 and since then I've been getting back into PCSX2. I've been reading up on the new OpenGL stuff that's been happening and monkeying with it on my PC. From what I've read OpenGL is a bit more accurate particularly with post processing and stuff. I've read a few times now, I believe on .hack//infection and FFXII, and maybe others, that shadows can now be made to function accurately in Hardware mode. Trouble is I can't get them to work. I'm reading that you have to turn the CRC Hacks down to Partial and Hardware Depth on and they should function properly, it's not working for me though  Sad I'm currently using pcsx2-v1.3.1-1593-g902e295-windows-x86, any thoughts?
Reply

Sponsored links

#2
Did you try 1.4.0 or 1.5.0 git version?
Reply
#3
(01-14-2016, 02:48 PM)gregory Wrote: Did you try 1.4.0 or 1.5.0 git version?

actually looks like maybe I have 1.3.1, which is strange because I just downloaded it a week or so ago, I must have somehow gotten to the wrong downloads page, I'll be trying 1.5 here in a moment
Reply
#4
(01-15-2016, 01:19 AM)randomusername Wrote: actually looks like maybe I have 1.3.1, which is strange because I just downloaded it a week or so ago, I must have somehow gotten to the wrong downloads page, I'll be trying 1.5 here in a moment

well, I tried the 1.4 installer, and I tried a dev version of 1.5 and neither of them had the shadows functioning properly. .hack//infection was the game I tested, and the shadows DO function, but only if you zoom the camera fully out, and also have the camera set to a certain angle. Same exact thing that happened in all other versions of PCSX2 I've tried.
Reply
#5
Hum. I know that some shadows were fixed in at least a .hack game.
1/ Disable all hack on the core (vu cycle stealing)
2/ Disable user hack on gsdx
3/ enable accurate date / accurate blending / hardware depth
4/ And set the CRC to the openGL level
Reply
#6
(01-15-2016, 12:43 PM)gregory Wrote: Hum. I know that some shadows were fixed in at least a .hack game.
1/ Disable all hack on the core (vu cycle stealing)
2/ Disable user hack on gsdx
3/ enable accurate date / accurate blending / hardware depth
4/ And set the CRC to the openGL level

1. I did a brand new install of both 1.4 and 1.5 so vu cycle stealing and ee cyclerate were default/off
2. I've tried having enable hw hacks checked and unchecked
3. had hardware depth and accurate date checked, changed blending unit accuracy from basic up to ultra
4. changed crc level to partial (opengl recommended) as well as minimum and none

I read something about an video card drivers sometimes being an issue so double checked and made sure they were updated.

Shadows ARE being shown on other characters, but only in the distance, the main character's shadow is not shown, and once another character gets close enough to the main character/or camera you can see the shadow disappear. It's like a backward draw distance.
Reply
#7
just tested Final Fantasy XII to make sure it wasn't just an issue with .hack, and yeah shadows aren't showing up in Final Fantasy either. Particularly the first tutorial scene where you fight a flying mech enemy.
Reply
#8
bumpity bump bump
Reply




Users browsing this thread: 1 Guest(s)