Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
OpenGL renderer is slow on AMD GPU due to inefficient driver. Sorry.
#1
Opengl plunigs says me this
3.x GL context successfully created
OpenGL information. GPU: AMD Radeon R9 200 Series. Vendor: ATI Technologies Inc.. Driver:
Core Profile Forward-Compatible Context 15.300.1025.1001
Buggy driver detected, GL_ARB_separate_shader_objects will be disabled
Note the extension was fixed on Mesa 11.1, you will need a manual overwrite to use it
INFO: GL_EXT_texture_filter_anisotropic is available
INFO: GL_ARB_gpu_shader5 is available
INFO: GL_ARB_draw_buffers_blend is available
INFO: GL_ARB_separate_shader_objects is NOT SUPPORTED
INFO: GL_ARB_shader_image_load_store is available
INFO: GL_ARB_copy_image is available
INFO: GL_ARB_buffer_storage is available
INFO: GL_ARB_clear_texture is available
INFO: GL_ARB_clip_control is available
INFO: GL_ARB_direct_state_access is available
INFO: GL_ARB_texture_barrier is available
OpenGL renderer is slow on AMD GPU due to inefficient driver. Sorry.
What can I do?
Reply

Sponsored links

#2
Nothing amd have to solve it, i have a 290x and i have the same problem
CPU: Intel Core i7 4790K @ 4 Ghz
CPU Cooler: Corsair H75
MoBo: MSI Z97S SLI KRAIT  
GPU: AMD Radeon R9 290X
RAM: Corsair 16 GB 1600 Mhz

Desktop
[Image: 1086677.png]

Laptop
[Image: 872520.png]
Reply
#3
Quote: Buggy driver detected, GL_ARB_separate_shader_objects will be disabled
=> https://community.amd.com/thread/194895

Quote:OpenGL renderer is slow on AMD GPU due to inefficient driver. Sorry.
=> fastest solution buy an Nvidia card !
=> hardest solution: recode the plugin with vulkan (or improve the open source driver and switch to linux).
Reply
#4
(01-26-2016, 05:24 PM)gregory Wrote: => https://community.amd.com/thread/194895

=> fastest solution buy an Nvidia card !
=> hardest solution: recode the plugin with vulkan (or improve the open source driver and switch to linux).

well dolphin emulater good for me now. Its opengl plunig works awesome in ultra settings but sadly pcsx2 won't work with amd that awesome.
Reply
#5
At least they have a fix for the buggy extension.
Reply
#6
(01-29-2016, 12:37 AM)gregory Wrote: At least they have a fix for the buggy extension.

I've few question if the developers of the Opengl blending mode ever read this.

Do you think it will fix the  slow rendering?
Every game I tried  with my R7 260x  never get more than 30 fps whatever the blending option. The game all run fine In D3d11 hardware or software without any speed hack. 

I also noticed that with more speed hack on some title I can get  higher FPS in OpenGL.. Which is unexpected as the game run full speed already with the other renderer.
Do it mean that the fix for this missing instruction use more CPU letting less power available for the emulation?  

Or do the shader conversion just really use more CPU whatever the situation?

 If true do you think it's possible to make the shader conversion on a separate thread?  I'm not sure how it internally work but the software mode can split the load on multiple thread and it make me think that it might be possible to do for this task too.
Reply
#7
No, the buggy extension would barely impact speed. In theory it could but it depends on the driver implementation. And again AMD driver implementation is rather slow.

Normally driver already does their jobs (not limited to the shader compilation) in separate thread. It is true for DX drivers, and also for Nvidia GL driver. But somewhat I'm feeling that AMD implementation is more limited.
Reply
#8
TBH in my recent testing as long as you don't crank up the blending unit accuracy then OGL is not that slow on AMD. However with blending unit accuracy set to high it gets brutal.

Compare a scene in KH1 I tested:

DX11: 310FPS
OGL HW(with blending unit set to low): 200 FPS
OGL HW(with blending unit set to high): 31 FPS

OFC my single threaded is very high(2450) and I'm sure that helps.
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#9
Yeah Blending Unit Accuracy set to anything higher than Basic absolutely kills the performance for me.

With Full and Ultra it essentially becomes unplayable for me. And even on High it's really bad most of the time lol.
Intel Core i5-4670K @ 3.40GHz | 16GB (2x8GB) DDR3-1866 G.SKILL Sniper Series
AMD Radeon R9 280 @ 3 GB | 120GB SSD | Windows 7 Ultimate x64 (SP1)
Reply
#10
The performance impact should be less in the latest git, but obviously unavoidable.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply




Users browsing this thread: 1 Guest(s)