Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Optimal PCSX2 settings for my computer
#1
Hey everyone!
Having moved out of my house for university, I find myself distanced from a bunch of my old PS2 games that I didn't bring with me and I'm now really in the mood to play them, so I turned to PCSX2, trouble is, most games aren't running all that well. I'm primarily playing RPGs and while stuff like FFX runs perfectly, I'm surprisingly having trouble with games like Wild Arms 3 as it runs slowly (dips from about 60FPS to 20-30), and was wondering if anyone could tell me the best settings for my computer not only for Wild Arms 3, but for most games. My specs are as follows:

Processor: Intel core i5-2450M CPU @2.50GHz
Memory: 6GB
System type: 64-bit Windows 7 Home Premium
Graphics Card: Nvidia Geforce GT 525M

I understand my computer isn't fantastic by any stretch, but any and all help is hugely appreciated, thanks!

(Oh, and just to clarify, yes, I own all games I'm emulating, but like I mentioned, I'm playing them from ISOs)
Reply

Sponsored links

#2
1. Tick Native in GSdx

2. Enable speed hacks including MTVU

3. Play around with Allow 8-bit textures option in GSdx and see which one gives you more FPS

4. Go to Config -> Emulation Settings, at EE/IOP tab, change Clamp mode to None, the same goes for VU tab.


5. Set your windows power plan to High performance
Reply
#3
make sure that the pcsx2 uses the nvidia card and not the internal.
I have about the same PC and play almost all games
set ee cyclerate to 2 and vu cycle stealing to 1 if you can not play a game
Reply
#4
Thanks, everything seems to be working great now!
Reply
#5
For some games skipdraw option in HW hacks gives also good results.
Reply




Users browsing this thread: 1 Guest(s)