Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Optimal settings for SotC?
#1
Hi all, I'm trying to run Shadow of the Colossus with the best possible framerate and I'm wondering what I should tweak. I've been spending quite a while tweaking already but I'm not totally experienced in this so all I'm doing is just trial and error Wacko

My rig is (a laptop):
Intel Core 2 Duo T9300 @ 2.50 GHz
4.00 GB RAM
ATI Mobility Radeon HD 3650 (512 MB)

The game slows down quite a bit with a colossus in view, though never really dips below 30 FPS. I average around 45 FPS, though this is according to the information that the emulator gives me. Sometimes the emulator can give me 60 FPS even though it's clearly not running at PS2-console speed, so I don't know how seriously I can take that.

Anyways, I'm using Vista 32 bit (yes, yes, 32 bit system with 4 GB RAM is a waste, I know) but I'm running GSdx 9. Is there a GSdx 10 that I can use for DirectX 10 since I have Vista? Does it make a large difference?

I'm running currently at 640x480 full screen, Texture filtering on, "Limit" on frame filtering (IE can't go above 60 FPS), skipping frames lower than 50FPS with 1 consecutive Frame and skipping 2 at a time. For speed hacks I'm using the x3 Cycle Rate (the emu says it's best for this game), and I have all three hacks on the right checked (INTC Hack, Enable IOP x2 Cycle Rate, WaitCycles Sync Hack).

Do I have it properly set up? Anything I should change? This is the setup in which I see the best results, though perhaps I overlooked something or need an extra plugin that doesn't come with PCSX2 0.9.6 (which is what I'm using, btw). Thanks a lot in advance!
Reply

Sponsored links

#2
try dx10, it's works better for a lot of games. In gsdx plugin, just select dx10 hardware, the option should be there in the pulldown menu.

As for fullscreen, so far I have tested, fullscreen mode doesn't work really well. I especially have problems exiting from fullscreen mode. Therefore I mostly play in window mode.

Anyway, I am still waiting to get shadow of the colossus from my friend. It would help if you found the best settings and post it here. Thanks.
Windows 7 x64
Intel G2020 2.9GHz, 4GB RAM, Nvidia GT630GT 2048mb
Reply
#3
Fullscreen works. All you gotta do is go to the LilyPad Settings and uncheck the "Hide on fullscreen escape" hack under the "hacks" section and you'll be able to atl+tab out of the game as well as press Esc and all that stuff.

Oddly enough, changing my settings to Direct3D 10 Hardware actually makes my game slower. Are you sure that's the setting I'm supposed to be changing?Blink
Reply
#4
Like I said before, I haven't tested this game myself so it's possible dx9 works better for this game. But generally, DX10 seems to work better for most games.
Windows 7 x64
Intel G2020 2.9GHz, 4GB RAM, Nvidia GT630GT 2048mb
Reply
#5
I have it on hardware dx10 at 1920x1080 with texture filtering on.
My CPU I have verything on set at frameskip. I'm using x3 cycle rate and thats it. My FPS never go under 50, but my screen goes near white while on the plains, and I can't figure out why.
Reply
#6
To zenith:
This game has a visual problem when playing on higher resolutions than native (that's the near-white screen you talk about. The higher the resolution, the whiter your screen will be on the plains).

---
To RRTwo
Check x3 cycle hack and every hack you can enable. Use DX10 if available. Use GSDX plugin that supports your set of instructions (i think your CPU is able to support SSE4.1).

Also, in the game's options, check "Progressive Scan". This option makes your game runs faster since it enables a game's built-in frame skip. This is important.
SAGER NP8690 | i7-620M 2.66Ghz | 6GB RAM | ATI 5870M 1GB GDDR5 | FullHD 1080p 15.6'' | 500GB HDD 7200RPM | WINDOWS 7
Reply
#7
(04-15-2009, 04:44 PM)dotHack Wrote: To zenith:
This game has a visual problem when playing on higher resolutions than native (that's the near-white screen you talk about. The higher the resolution, the whiter your screen will be on the plains).

---
To RRTwo
Check x3 cycle hack and every hack you can enable. Use DX10 if available. Use GSDX plugin that supports your set of instructions (i think your CPU is able to support SSE4.1).

Also, in the game's options, check "Progressive Scan". This option makes your game runs faster since it enables a game's built-in frame skip. This is important.

Thanks for the tips! The Progressive Scan really did improve the FPS overall by like 5, so thanks!

One question about DX10. To use DX10, do I change the renderer to Direct3D 10 Hardware? Because I tried doing that and the emulator forces windowed and actually runs the game slower.
Reply
#8
At last!! manage to try our this game.

Preliminary testing seems that dx10 work better. In dx9, I get cpu usage up to 99%. But in dx10 usage is only around 57%. It does slow down in some section especially when more mountains are showing. But the light is too bright. Adjusting the in game's brightness doesn't help. dx10 is brighter than dx9. Still, it's quite playable. I have met the first colossus but this game is very hard to play without gamepad.
Windows 7 x64
Intel G2020 2.9GHz, 4GB RAM, Nvidia GT630GT 2048mb
Reply
#9
(04-14-2009, 06:24 AM)RRTWo Wrote: The game slows down quite a bit with a colossus in view, though never really dips below 30 FPS. I average around 45 FPS, though this is according to the information that the emulator gives me. Sometimes the emulator can give me 60 FPS even though it's clearly not running at PS2-console speed, so I don't know how seriously I can take that.
Very seriously. Did you ever play SotC on a real PS2? It's one of the most stuttering games on the system. Even if the emulator shows you "60fps" it only means that the emulation is running the game as fast, as does a real PS2. SotC's framerate on the PS2 can dip even as low as 10-15fps. Nothing can remedy that.
Split your lungs with blood and thunder when you see the white whale.
Reply
#10
(04-16-2009, 03:57 PM)abubin Wrote: At last!! manage to try our this game.

Preliminary testing seems that dx10 work better. In dx9, I get cpu usage up to 99%. But in dx10 usage is only around 57%. It does slow down in some section especially when more mountains are showing. But the light is too bright. Adjusting the in game's brightness doesn't help. dx10 is brighter than dx9. Still, it's quite playable. I have met the first colossus but this game is very hard to play without gamepad.

This most likely means that you're limited by your video card.
Reply




Users browsing this thread: 1 Guest(s)