Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Optimization Help For a Noob!
#1
Hello! Thanks to your wonderful threads Ive *almost* got PCSX working perfectly! However, I think I need to optimise it more as in certain circumstances (FFX, battle scenes and walking around alot of rendered stuff) Im losing FPS down to 80% or below...

I want to improve it but I dont know where to start:

PCSX2 0.9.6
Graphics: GSdx 89(MSVC 15.00, SSSE3) 0.1.14, Windowed, Direct3D 10 (Hardware), D3D internal res: 1024 x 1024
Sound: SPU2-X 1.10, Linear, Disable Effects Processing, XAudio 2
Controller: SSSPSX PAD Plugin Pressure Mod 1.7.0
Cdvdrom: Gigaherz's CDVD Plugin 0.7.0
Dev9: DEV9null Driver 0.3.0
Usb: USBnull Driver 0.5.0
FireWire: FWnull Driver 0.4.0
Bios: USA v0.1.60(07/02/2002) Console
CPU Config: EERec, VU0Rec, VU1rec, Multi threaded GS mode, Frame Limiting - Limit
Speed Hacks: INTC Sync Hack, Enable IOP x 2 Cycle Rate, Use x 2 Cycle Rate

My Specs:
Pentium® Dual-Core CPU T4200 2.00GHz
4.00GB Ram
Windows 7 64-bit
ATI Mobility Radeon HD 4500 Series (512mb?)

I know a laptop isnt the greatest thing to try and run these with but I assumed my specs would be able to manage it - hopefully Im not wrong

Ive read that running the game off the memory (linuz) rather than from an iso is faster but I couldnt get Linuz to work properly...

Thanks in advance for any advice - really looking forward to replaying FFX!
Reply

Sponsored links

#2
If your problem is slowdowns and drop in FPS. Then try "Skip frames" option in Config/Cpu/Frame limiting in PCSX2. Apart from that your Cpu is more on the slower side @2.0Ghz and that is a BIG FACTOR. try playing at native res by selecting it in graphics options or try to play in Directx 9 mode. these options will surely give an increase in performance. also try and not have many applications and processes and services in background. disable internet. and playing in full-screen helps.
Click image for Prev. rigs Cool
[Image: MYNEWPCGII.png]
Reply
#3
Try the latest beta it is faster and well going to 80% speed is not that bad really specially for your cpu and graphics card which dont really help much for speed. Maybe try ticking "native" in GSdx settings, and use the speedhacks "Idle Loop Fast-forward" and "vu cycle stealing" set to slight in the beta might help a bit also, other than that not much can be done because of your hardware and your other settings look good enough.

What do you mean you couldnt get Linuz to work? what errors appear?
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#4
(11-25-2009, 08:10 PM)Shadow Lady Wrote: Try the latest beta it is faster and well going to 80% speed is not that bad really specially for your cpu and graphics card which dont really help much for speed. Maybe try ticking "native" in GSdx settings, and use the speedhacks "Idle Loop Fast-forward" and "vu cycle stealing" set to slight in the beta might help a bit also, other than that not much can be done because of your hardware and your other settings look good enough.

What do you mean you couldnt get Linuz to work? what errors appear?

I set it to my iso - clicked run CD - it gave an error - I probably need to look into this more...

Ill try the beta, but if not, its the hardware....

I have a desktop

XP
Intel Core Duo 2.66GHz
2GB RAM
NVIDIA GeForce 9600GT

- would this be better? Id assume so as everything tells me its the processor...
Reply
#5
What error did Linuz ISO cdvd give?
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#6
Try Run > Execute instead?

And that desktop should run most games fine, especially if you overclock the CPU to around 3.2Ghz or above.
[Image: yunacopy.jpg]
Reply
#7
(11-26-2009, 09:36 AM)boogerthe2nd Wrote: Try Run > Execute instead?

And that desktop should run most games fine, especially if you overclock the CPU to around 3.2Ghz or above.

Hey again - havnt replied or fiddled with the Linuz problem (which I assume has something to do with admin privaledges on my laptop - I wish I could remember how to turn them off) as I tried my desktop and it works absolutely perfectly with no tweaking... so have been buried in FFX!

Im thinking the extra .66GHz made the difference!

Thanks folks!
Reply




Users browsing this thread: 1 Guest(s)