Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 1.0 + ZZOGL 0.4 = only sound in a black screen
#1
Sad 
Hi,

I'm trying to run Shadow of the Colossus but i have only the sound in a black screen.

I'm using ZZ Ogl PG 0.4.0 [libzzogl-0.4.0] plugin and USA BIOS 1.6 on PCSX2 1.0.0.
Under Linux 3.2 + GNOME 3.4 and the last package from PCSX2's PPA.
* Proc: Intel® Core™ i3-2120 CPU @ 3.30GHz × 4, 32-bit
* Video: Intel® Sandybridge Desktop x86/MMX/SSE2

Useful info:
Code:
$ lspci | grep -i graph
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
$ glxinfo | grep "separate_shader\|OpenGL"
OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Desktop x86/MMX/SSE2
OpenGL version string: 3.0 Mesa 8.0.4
OpenGL shading language version string: 1.30
OpenGL extensions:
    GL_ARB_vertex_array_bgra, GL_EXT_separate_shader_objects,

Terminal output:
Code:
me@gnulinux:~$ pcsx2
Interface is initializing.  Entering Pcsx2App::OnInit!
Applying operating system default language...
Loading language translation databases for 'Portuguese (Brazilian)' [pt_BR]
Command line parsing...
Command line parsed!
ZZOgl-PG:  Calling GSinit.
ZZOgl-PG:  GSinit finished.
ZZOgl-PG:  Calling GSopen2.
ZZOgl-PG:  Capturing ZZOgl window.
ZZOgl-PG:  Got Doublebuffered Visual!
ZZOgl-PG:  glX-Version 1.4 with Direct Rendering
ZZOgl-PG:  Supported Opengl version : 3.0 Mesa 8.0.4

ZZOgl-PG:  Using multitexturing.
ZZOgl-PG:  Maximum texture size is 8192 for Tex_2d and 4096 for Tex_NV.
ZZOgl-PG:  Disabling MRT depth writing.
ZZOgl-PG:  Use GL_RGBA32F for blockdata.
ZZOgl-PG:  Fill bilinear blocks OK.!
ZZOgl-PG:  Initialization successful.
ZZOgl-PG:  Disabling MRT depth writing.
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib pcm_dmix.c:957:(snd_pcm_dmix_open) The dmix plugin supports only playback stream
Cannot connect to server socket err = Arquivo ou diretório não encontrado
Cannot connect to server request channel
jack server is not running or cannot be started
* SPU2-X: Enumerating PortAudio devices:
*** Device 0: 'HDA Intel PCH: HDA Generic (hw:0,0)' (ALSA)
*** Device 1: 'sysdefault' (ALSA)
*** Device 2: 'front' (ALSA)
*** Device 3: 'surround40' (ALSA)
*** Device 4: 'surround51' (ALSA)
*** Device 5: 'surround71' (ALSA)
*** Device 6: 'pulse' (ALSA)
*** Device 7: 'dmix' (ALSA)
*** Device 8: 'default' (ALSA) (selected)
ZZOgl-PG:  Disabling MRT depth writing.
ZZOgl-PG:  Current game CRC is c19a374e.
ZZOgl-PG:  Found CRC[c19a374e] in crc game list.
(...)
ZZOgl-PG:  Failed to create 8192x3 texture.
ZZOgl-PG:  SetTexVariablesInt error.
ZZOgl-PG:  Failed to create 8192x8 texture.
ZZOgl-PG:  SetTexVariablesInt error.
ZZOgl-PG:  Failed to create 8192x2 texture.
ZZOgl-PG:  SetTexVariablesInt error.
ZZOgl-PG:  Failed to create 8192x1 texture.
ZZOgl-PG:  SetTexVariablesInt error.
ZZOgl-PG:  Failed to create 8192x1 texture.
ZZOgl-PG:  SetTexVariablesInt error.
ZZOgl-PG:  Failed to create 8192x3 texture.
ZZOgl-PG:  SetTexVariablesInt error.
ZZOgl-PG:  Failed to create 8192x1 texture.
ZZOgl-PG:  SetTexVariablesInt error.
ZZOgl-PG:  Failed to create 8192x1 texture.
ZZOgl-PG:  SetTexVariablesInt error.
(...)


Log window:
Code:
PCSX2 1.0.0.r0  - compiled on Jan 12 2013
Savestate version: 0x9a080000

Host Machine Init:
    Operating System =  Linux 3.2.0-4-686-pae i686
    Physical RAM     =  3948 MB
    CPU name         =  Intel(R) Core(TM) i3-2120 CPU @ 3.30GHz
    Vendor/Model     =  GenuineIntel (stepping 07)
    CPU speed        =  3.289 ghz (4 logical threads)
    x86PType         =  Standard OEM
    x86Flags         =  bfebfbff 1d9ae3bf
    x86EFlags        =  28100000

x86 Features Detected:
    MMX.. SSE.. SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX

Installing POSIX SIGSEGV handler...
Reserving memory for recompilers...

Loading plugins...
    Binding   GS: /usr/lib/games/pcsx2/libzzogl-0.4.0.so
    Binding  PAD: /usr/lib/games/pcsx2/libonepad-1.1.0.so
    Binding SPU2: /usr/lib/games/pcsx2/libspu2x-2.0.0.so
    Binding CDVD: /usr/lib/games/pcsx2/libCDVDnull.so
    Binding  USB: /usr/lib/games/pcsx2/libUSBnull-0.7.0.so
    Binding   FW: /usr/lib/games/pcsx2/libFWnull-0.7.0.so
    Binding DEV9: /usr/lib/games/pcsx2/libdev9null-0.5.0.so
Plugins loaded successfully.

(GameDB) 9640 games on record (loaded in 212ms)
HLE Notice: ELF does not have a path.


Initializing plugins...
    Init GS
    Init PAD
    Init SPU2
    Init CDVD
    Init USB
    Init FW
    Init DEV9
Plugins initialized successfully.

Opening plugins...
    Opening GS
    Opening PAD
    Opening SPU2
    Opening CDVD
isoFile open ok: /home/me/Games/Shadow of the Colossus/1.ISO
    Image type  = DVD
    Fileparts   = 1
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (1315408 sectors)
    Opening USB
    Opening FW
    Opening DEV9
McdSlot 0: /home/me/.config/pcsx2/memcards/Mcd001.ps2
McdSlot 1: /home/me/.config/pcsx2/memcards/Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
    Bios Found: USA     v01.60(19/03/2002)  Console
    BIOS rom1 module not found, skipping...
    BIOS rom2 module not found, skipping...
    BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59,94 fps
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_974.72;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
ELF (cdrom0:\SCUS_974.72;1) Game CRC = 0xC19A374E, EntryPoint = 0x00100010
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_974.72;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC

Sponsored links

#2
Intel driver doesn't work with PCSX2 (black screen on zzogl and not yet supported feature on GSdx). I really don't know why! Could be a bug in zzogl but it run fine with nouveau and the free radeon driver.
#3
New try with God Of War 2 with the same fail, but the "ZZOgl-PG: Failed to create ####x# texture" errors.
#4
Hum the error appears because zzogl try to allocate a too big texture for your intel GPU (limited to 4096...). Normally there is a slow 4k path, don't know why it isn't used.

Edit: where in GoW2? menu is enough?
#5
Gregory, some output may help you to understand why zzogl is not working with Intel graph?
Only ask for a command line then i send the result.
Thanks!
#6
just tell me your pcsx2 version, you can use this command "dpkg -l |grep pcsx2". Texture error feel like somethings I already fixed.
#7
$ dpkg -l | grep pcsx2
ii pcsx2-unstable 1:1.0.0-0ubuntu6 i386 Playstation 2 emulator
(from PPA)
#8
You're in quantal right ?
Normally there is a newer version (2:5445-2). I kind of mess with versionning I mix stable and unstable.
Try the following
"apt-cache search pcsx2"
Then on each output (like pcsx2-unstable) do
"apt-cache policy ..previous_output.."
#9
Version 1.1.0.0 (from PPA) works okay for me in Linux with Intel graphics (2500k).

I use the oibaf PPA for video driver and I enable SNA in xorg.conf, both of these are recommended for gaming anyhow.

Have to use ZZOGL 0.4 and "Full" boot (Fast appears to be broken), and there are performance issues and glitches in the one game I've tested (Katamari Damacy) so it's not really playable as it is, but it works!

Just tried Shadow of the Colossus and it ignores input at the Progressive Scan prompt so I can't get in-game.
#10
Hum that good to hear. Lots of user have issue with Intel driver. Hopefully they may have fixed it in latest version.

Could you please install apitrace 32 bits and test that the trace attached to this thread is working fine.

Could you tell me all your driver version?
mesa, ddx, xorg? And the output of this command "glxinfo | grep version"




Users browsing this thread: 1 Guest(s)