Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 Beta 1888 on Windows 7 x64 and FFX ... NICE!
#1
Haven't played FFX in ages, so decided to fire it up on the latest beta and check the performance with my not-so-good system ...
And it works great! Nice to play FFX in high resolution, it really makes the game even more great to play ( despite some textures here and there that is very low res ).
There are some scenes where it drops to around 80% speed, but hey, that's not even noticable, and when running the game in widescreen 1920X1200, I totally can survive a drop in FPS on a few places, hehe.
Haven't gotten that far, just got to talk to Yuna, but so far everything seems bugless ( except the Pause-screen xD And who cares if that is scrambled xD )

System :
Intel Core 2 Duo E8200 ( not overclocked )
GeForce GT8800
4GB RAM
Windows 7 Ultimate x64
Samsung SyncMaster 24"

EDIT: There are some pauses here and there, longest was for 10 sec in the first underwater battle, doesn't really bug me though. It happens rarely.
Also, using GSdx 1873 with internal res @ 1920X1200
Reply

Sponsored links

#2
Make sure you set EE Rec clamping mode to FULL and the VU Rec clamping mode to extra + preserve sign so that some of the later parts will not be glitched (i.e. controls are reversed in the airship's upper deck, and in some of the cloister trials/some bosses and monsters are facing backwards esp. *spoiler alert* Yunalesca). It will also fix the random crashes later on (specially after Yuna's sending @ kilika). The performance hit is negligible with your specs, and since FFX is one of the less demanding games, it may be unnoticeable.
[Image: 813647.png]
+ geforce GT 440 @ Win7 64bit
Reply
#3
(11-05-2009, 03:18 AM)ellachen0417 Wrote: Make sure you set EE Rec clamping mode to FULL and the VU Rec clamping mode to extra + preserve sign
Ah, thanks a lot Smile
Gonna play around a bit with the speedhacks as well, however, last time I did that the videos went haywire.
Reply
#4
If you can overclock that CPU to around 3-3.2Ghz (should be able to on stock voltage), you'll pretty much have no slowdowns at all throughout.
[Image: yunacopy.jpg]
Reply
#5
(11-05-2009, 08:59 AM)boogerthe2nd Wrote: If you can overclock that CPU to around 3-3.2Ghz (should be able to on stock voltage), you'll pretty much have no slowdowns at all throughout.

I really can't say I have any noticable slowdowns after setting on almost all Speed Hacks ( game running just fine, even with the microVU beta's on ).
I do have a Zalman fan, however, due to the heat inside here it goes on max speed when overclocking the CPU and it's not really quiet xD
So far the game runs way good enough for me in 1920X1200, so I'll stick to stock for now.
The VU cycle stealing doesn't seem to work all that well, even on the lowest setting Wink
Reply
#6
Well I must say this new pcsx2 beta 1888 beefed up the speed in games, I get 60fps in Final Fantasy X and a few games runs just a little below that but not to bad. I have tried it in Windows XP sp3 and it ran slower in some parts, now I run Windows 7 and it works better.
Systems Specs:
Cpu: Athlon II X2 240 2.80 GHz
Vid: Radeon 4200 Hd on board video
Ram: 2Gb pc6400
Os: Windows 7
Reply
#7
yeah the game run perfect to me thanks for the hard work...
Reply
#8
Shocked 
After doing much googling (hint: use quotations for specific phrases) I've reached this thread and hopefully the help to my situation....
I've been lurking in the forums for quite some time, and have reached the end of the road as far as it goes without reaching out. Sad

I am having a difficult time getting Final Fantasy X running decently on my machine. Below are the computer specs and PCSX2 details.

I noticed Xeno has an eerily similar system as I do -- only interesting thing is he/she has a slower proc and less RAM but is able to get purportedly 60fps in Final Fantasy X...so I'm sure there is a way or even a little detail I have overlooked.

Right now I am consistently averaging 38-45 fps in FFX.


System:

AMD Phenom X2 810 2.6ghz
8GB DDR3 RAM
Radeon HD 4200 Integrated Graphics
Windows Server 2008 x64


PCSX2:

Pcsx2 Beta r1888

GSdx 1873 SSE2 0.1.15
(for some reason, it will not detect any higher SSE)

SPU2-X 1.2.0
Lillypad svn r1853 0.10.0
Linuz ISO 0.9.0

I also have the full DirectX runtimes installed via the "Windows Experience Server Feature in Server Manager...I also seeked out the MS download and ran that manually after adding the Server Feature.

Aero is also turned off if that helps.

Attached are the screens for PCSX2.


Thanks guys. Laugh


Attached Files Thumbnail(s)
   
Reply
#9
Lower the Clamps in advanced settings at least to normal, having them that high may fix specific parts but overall will make things much slower
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#10
I observed no performance hit with the EE Recs clamping set to Full, but a large performance hit with the VU Recs clamping set to Extra+Preserve Sign. Fortunately, most of what the higher clamping settings fix are still fixed with EE Recs clamping set to Full and VU Recs clamping set to Normal. That's what I've found to be ideal.

Also, I'd use the microVU status flag hack.
Reply




Users browsing this thread: 1 Guest(s)