Thread Rating:
  • 3 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2-CE for Mac (Wineskin) Oct 2015 Guide
Hey there! I got it working now. But the only problem I'm having is fixing the settings. When I play the games walls starts to do this flicker thing when I move the camera. Is this a problem with the gs plugin settings? The speed and resolution in game is great but the walls are just messing up for some reason. Is this a problem with the shadows in game? Or maybe it's just the way the game is? I have played the same game before on version 9.8 but 1.40 isn't working as well. I'm just trying to get kh2 to play on a higher resolution. I got rid of those anoying jagged lines but now there's a problem with the walls. Anyone know how to fix this?

Sponsored links

(10-18-2015, 07:28 AM)MacUser Wrote: ***UPDATED 25th of August 2016***

****WARNING - it appears that vcrun2015 installation is failing for some people. Until that issue is resolved you may have difficulty getting this working. For now I suggest using version 1415 which only needs D3DX9_36 installed****

****Warning - The DirectX9 renderer for GSDX has ceased development and been removed from future developer builds. As the DX10, DX11 and OGL renderers do not yet work in Wine, the last build that will work is 1.5.0 v.512.*****  

****Warning - The last Wineskin engine to work is WS9Wine 1.9.11*****  

There has been a lot of developments and improvements since ConsoleEmu's first post. The guide in his thread is outdated and just causes confusion for people wanting to get PCSX2 up and running on OS X. 

The purpose of this post is firstly to help get new users started, and then to show how to keep the app updated. PCSX2-CE uses a Wineskin wrapper around the PC version of PCSX2, and both need to be kept updated.  

You will need to download the following:

Wineskin Winery: used to keep the Wineskin wrapper updated. Get it here.

PCSX2: The last build of PCSX2 that works with vcrun2015 is 1.5.0 v512. The last build to work without vcrun2015 is 1.3.1 v1415

PCSX2-CE: The wrapper first made by ConsoleEmu. Get v 1.2.1 from his site here.

Wineskin Winery: 

This is the app where you download updates to the wrapper and the engine for Wineskin. (Open it up and check for updates once every month or two. If you notice any regressions, you can always download an older engine). 

Just open the Wineskin Winery app and check for updates. You should download the latest wrapper (2.6.2 as of this post) and also WS9Wine1.9.11. Newer builds don't work as of this post.


Download and decompress. (The folder will have the build number, it's best to keep this as it is for future reference). 

1: Install your BIOS: create a folder inside called "bios" and copy your PS2 BIOS into it. If you don't have your BIOS handy, search this forum or Google it. (Please do not post questions about BIOS here, it's off-topic and answered better elsewhere)


Download and decompress. You will get a folder containing the app, a winetricks command, and the licensing docs (also a readme, but this post is more relevant). There is also a bios folder that is an alias to the one contained in the wrapper. Ignore this alias, since we are going to delete the folder it points to.

1: Copy the new PCSX2 build to the wrapper: 

Step A: Right-click on the PCSX2-CE app and select "Show Package Contents". Go to drive_c and Program files to see the old PCSX2 folder. 

Step B: Copy the new PCSX2 folder into Program Files (delete the old one while you are at it) 

2: Update the wrapper and engine: 

Step A: Open up the Wineskin app contained in the package (you should have seen it earlier when you did 1 above)

Step B: Select Advanced, then Tools. 

Step C: Select Update Wrapper (it will probably quit when it's finished, open again for the next step). 

Step D: Select Change Engine Used and wait for it to finish.

3: Redirect the wrapper to run the new version of PCSX2:

Under the Configuration tab, reassign which .exe file is run by clicking the Browse button at the top. Choose the new PCSX2.exe

4: Install d3dx9_36 and vcrun2015: 

Again open the wineskin app, select Advanced and Tools, then Winetricks. On the bottom left click Update Winetricks. 

Step A: Expand the dlls list and scroll down to d3dx9_36. Select and click Run. Allow the script to compete. (This will take a long time. Wait for it to say it's finished).

Step B: Do the same for vcrun2015. 

*Note: some users are having difficulty installing vcrun2015. If this happens, you can try installing msxml3 first. However, if it still doesn't work you should use build 1.3.1 v1415

*Note: In order to see what has been successfully installed in the package, click the gear/option button and select "show installed" column.

You are now ready to run the PCSX2-CE app. 
First time run:

When you run it for the first time, a setup wizard will run. You need to choose your language, bios, and plugin settings. 

- Configure the SPU2-X plugin. You need to change XAudio2 to Portaudio. (Wine will support XAudio in the future, but as of posting Portaudio is still required).  

- Configure the CDVD, USB, FW and Dev9 plugins all as Null.

Note for updating: 

- When you download a new build of PCSX2, don't forget to copy over the bios, inis and memcard folders. (Always press the alt key, since OS X tends to just copy over an alias otherwise).

You should have PCSX2 up and running at this stage. If you have any problems or issues with the above steps, please post here. Also, if it works for you let us know too.

I hope this post helps new users get started, and also how to keep themselves updated.
Think you can help, when I get to

2: Update the wrapper and engine: 

Step A: Open up the Wineskin app contained in the package (you should have seen it earlier when you did 1 above)

When I open Wineskin it will sit and say "Wineskin is currently busy Please Wait..." and nothing else. Any sugestions to fix this so I can get PCSX2-CE to work?

MacOS Sierra 10.12.3
CPU 2.4 GHz Intel Core 2 Duo
Memory 4 Gb 1067 MHz DDR3
Graphics NVIDIA GeForce 320M 256 MB
Quote:When I open Wineskin it will sit and say "Wineskin is currently busy Please Wait..." and nothing else. Any sugestions to fix this so I can get PCSX2-CE to work?

I have exactly the same problem at this step. The Wineskinn app in the package won't open (same Wineskin is busy message), and that means I can't update it. Is there a workaround?
For those who keeps getting the "Wineskin is busy, please wait" message, try:

- Right click on the -> Show Package Contents -> Contents -> MacOS -> Wineskin (but this Wineskin will open in Terminal first, and then the app will open).

Mine worked this way. But please note that I'm just a curious noob who will do about anything to follow the guide lol.

Also I've been following the guide closely but I got stuck at installing d3dx9_36.dll. Vcrun2015 and msxml3 seemed to install properly but no matter how many times I click Run for d3dx9_36, it just wouldn't do. Is there a round way for this? I'm running MacBook Pro 15" Mid-2012 on OS Sierra. I'll input the log here if any of this helps, I really can't seem to decipher anything. Thanks in advance for any help!

Quote:Using winetricks 20170614-next - sha256sum: e6e2e828e44a4da6338f545f137560e4cbb4412d8a54d4798a8916b0e78ba103 with wine-1.9.11 and WINEARCH=win32
Executing w_do_call d3dx9_36
Executing load_d3dx9_36 
Executing cabextract -q -d /Users/imac/Desktop/pcsx2ce-1.2.1-565/ -L -F *d3dx9_36*x86* /Users/imac/.cache/winetricks/directx9/directx_Jun2010_redist.exe
Executing cabextract -q -d /Users/imac/Desktop/pcsx2ce-1.2.1-565/ -L -F d3dx9_36.dll /Users/imac/Desktop/pcsx2ce-1.2.1-565/*.cab
/Users/imac/Desktop/pcsx2ce-1.2.1-565/*.cab: No such file or directory
Note: command cabextract -q -d /Users/imac/Desktop/pcsx2ce-1.2.1-565/ -L -F d3dx9_36.dll /Users/imac/Desktop/pcsx2ce-1.2.1-565/*.cab returned status 1.  Aborting.

 Winetricks Commands Finished!!

I'm able to finish up and load the, but now I can't seem to load any ISOs (the window freezes). Help, anyone?
(11-25-2016, 06:30 PM)azoreseuropa Wrote: Both works fine using 50Hz for Klonoa Europe and works just fine. 

Now, I try both using fast boot and full boot for 60Hz with Klonoa Europe and its crashes.

(11-25-2016, 11:50 PM)macrobius Wrote: Got it to work using ZeroGS ( which furthers my suspicion that the shaders in GSdx are hosed.

Thank you.  The bios loads with the ZeroGS plugin.  My only problem now is controller input.
ya, so i was able to get my xbox one controller to work via lily pad after selecting the "DirectInput" option in the display. The only reason i went through all of this is so i could play phantasy star generation 1, which is working great. The rom was crashing after some time because the log window was open and logging a bunch of stuff. I disabled that and now its fine.
The instructions given don't work anymore as of August 2017.

-Installed Wrapper 2.6.2 and engine 1.9.11

-Updated Wineskin with latest wrapper and changed engine to 1.9.11

-Installed d3dx9_36 and vcrun2013 (since vcrun2015 isn't there in the list to download)

-PCSX-CE fails to launch

Please revisit this topic when you have time, as it needs to be updated.
Unfortunately, nobody on the team here is able to work on the Mac Port right now. Your best bet is to keep searching the forums and Google for help resolving your issue.
[Image: 36a66c559937a1f5d0cd7460362d4093.jpg?bg=2c2c2c]

Users browsing this thread: 2 Guest(s)