Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 Crashes with guitar hero III (3)
#1
Alright so I woke up today and found my thread was closed. Even though I own two PS2's and the game. Anyway I went out and bought an AV cable for them and got the bios image from the fat using PS2 Dumper V2.iso with freemcboot. I still don't have my guitars so I'm intent on using my keyboard. I'm pretty sure that's allowed since that's an option in the menu of PCSX2, correct me if I'm wrong. While I was out I found GH3 for 5$. So I put the game in my PC, booted with my bios and I still have the crashing issue. Pretty sure this is all within community guidelines now.



Reply

Sponsored links

#2
Please post your emulog and, are you using any non-default settings ?
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#3
(02-28-2015, 03:52 PM)ssakash Wrote: Please post your emulog and, are you using any non-default settings ?

Sure I can;
PCSX2 1.2.1.r5873 - compiled on Feb 3 2014
Savestate version: 0x9a0a0000

Host Machine Init:
Operating System = Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit
Physical RAM = 6046 MB
CPU name = Intel® Core™ i5-3210M CPU @ 2.50GHz
Vendor/Model = GenuineIntel (stepping 09)
CPU speed = 2.493 ghz (4 logical threads)
x86PType = Standard OEM
x86Flags = bfebfbff 7fbae3bf
x86EFlags = 28100000

x86 Features Detected:
MMX.. SSE.. SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX

Reserving memory for recompilers...

Loading plugins...
Binding GS: C:\Program Files\PCSX2\plugins\gsdx32-avx-r5875.dll
Windows 6.1.7601 (Service Pack 1 1.0)
Binding PAD: C:\Program Files\PCSX2\plugins\lilypad-r5875.dll
Binding SPU2: C:\Program Files\PCSX2\plugins\spu2-x-r5875.dll
Binding CDVD: C:\Program Files\PCSX2\plugins\cdvdGigaherz.dll
Binding USB: C:\Program Files\PCSX2\plugins\USBnull.dll
Binding FW: C:\Program Files\PCSX2\plugins\FWnull.dll
Binding DEV9: C:\Program Files\PCSX2\plugins\DEV9null.dll
Plugins loaded successfully.

(GameDB) 9655 games on record (loaded in 243ms)
HLE Notice: ELF does not have a path.


Initializing plugins...
Init GS
Windows 6.1.7601 (Service Pack 1 1.0)
Init PAD
Init SPU2
Init CDVD
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Opening plugins...
Opening GS
Opening PAD
Opening SPU2
Opening CDVD
isoFile open ok: C:\Program Files\PCSX2\games\Guitar Hero III - Legends of Rock (USA).iso
Image type = DVD
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (2116528 sectors)
Opening USB
Opening FW
Opening DEV9
McdSlot 0: C:\Program Files\PCSX2\memcards\Mcd001.ps2
McdSlot 1: C:\Program Files\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
Bios Found: USA v01.60(07/02/2002) Console
BIOS rom1 module not found, skipping...
BIOS rom2 module not found, skipping...
BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
# Initialize memory (rev:3.63, ctm:393Mhz, cpuclk:295Mhz detected)

PlayStation 2 ======== Hard reset boot
ROMGEN=2002-0207, IOP info (CPUID=1f, CACH_CONFIG=0, 2MB, IOP mode)
<20020207-164243,ROMconf,PS20160AC20020207.bin:11552>
# Total accessable memory size: 32 MB (B:2:8:0) (363:2:7c30)
# TLB spad=0 kernel=1:12 default=13:30 extended=31:38
# Initialize Start.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize User Memory ...
# Initialize Scratch Pad ...
# Initialize Done.

EE DECI2 Manager version 0.06 Feb 7 2002 16:41:20
CPUID=2e20, BoardID=0, ROMGEN=2002-0207, 32M

(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_216.72;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
ELF (cdrom0:\SLUS_216.72;1) Game CRC = 0xA46E2D44, EntryPoint = 0x00103D08
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_216.72;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC

All the following changes I made because of reading about other issues on PCSX forums and for them it worked. So assuming I didn't just select random options, these were the changes I made;
I switched from the on-board video card to the NVIDIA GeForce GT 650M, the renderer was Direct3D9[hardware] (and was crashing) so I went to Direct3D11[hardware]. I selected allow 8-bit textures.
Under sound settings I switched to directsound because the default didn't play any sounds.
I turned off Enable manual game fixes and there are no other gamefixes selected. I also turned off speedhacks; this had a small effect, the game lasted about 2 seconds longer before crashing but still did at about the same place.

Those are the only changes I can find that I made. Default did not work, like I stated, I searched for fixes and tried all the ones I could find that seemed to work for others.
Reply
#4
Is, enable automatic game fixes checked ?
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#5
(02-28-2015, 05:19 PM)Black Clover Wrote: I turned off Enable manual game fixes and there are no other gamefixes selected.

(02-28-2015, 05:31 PM)ssakash Wrote: Is, enable automatic game fixes checked ?
Reply
#6
Actually, I asked whether the automatic game fixes option in system menu is checked or not. And, try the game using both fast and full boot and, make sure you have disabled mtvu (since, it might cause crashes at few games)
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#7
(02-28-2015, 06:57 PM)ssakash Wrote: Actually, I asked whether the automatic gane fixes option in system menu is checked or not. And, try the game using both fast and full boot and, make sure you have disabled mtvu (since, it might cause crashes at few games)

There are no other gamefixes selected as I stated previously. Speedhacks is turned off and MTVU wasn't checked. But since speedhacks is turned off I'm assuming all related items turn off whether checked or not since the screen makes it impossible to select them after turning off speedhacks? If not I can turn it on to turn the other options off...

I'm not trying to be smart but I did state that there are no other game fixes selected. Thanks for your help so far Smile
Reply
#8
Huh, you're still not getting my question correctly, I'm not talking about the gamefixes tab at emulation settings, I'm taking about the enable automatic game fixes option at system menu and, have you tried testing the game with both full boot and fast boot ?
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#9
Alright so I just changed my GS settings and it seems to be working; I got past the crash you see in the video. I haven't tried to play because I'm only averaging 15fps.
I switched the GS plugin from
GSdx 5875 (MSVC 18.00, AVX) 0.1.16 [gsdx32-avx-r5875
to
ZeroGS 0.97.1 [zerogs-r5875]

Any idea how to up FPS? Is the GS section the Graphics Emulator plugin?

Yes I tried full and fast boot with previous settings. The drop down tab where you load the game/exit the emulator/etc Automatic Game Fixes is NOT checked Tongue
Reply
#10
What if you launch it directly from your DVD instead of using ISO ?.
Care to post the emulog after trying this ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply




Users browsing this thread: 1 Guest(s)