Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 Frame rate drops [Probably my bad]
#1
Okay so, recently I wanted to play Yakuza on my PCSX2 but it was lagging a lot when free roam starts (drop from the usual 60fps to 30fps, sound went crappy etc). I went to YouTube and looked for ways to speed it up, did some configurations here and there but nothing worked, so I put all my settings back to default again.

However, when I started Shin Megami Tensei: Nocturne, my frame rate dropped again. Initially when I first downloaded PCSX2, with default setting, it ALWAYS stayed in a range of 50 to 60fps and it was very smooth but after I played around with the settings (even though I changed it back to default), my Nocturne lagged again.

I thought maybe I forgot to set something back and since I can't remember, I uninstalled PCSX2 and reinstalled it again, removing all BIOS files and everything else except my memcards folder(I don't wanna lose my saves D=) and redid everything, but it still lags when I run Nocturne so I don't know what to do now and I'm not incredibly knowledgable on computers... Help please? Thank you~

PC Specs(I'm just typing out everything I see on dxdiag)
Windows 7 Home Premium 64 bit
Intel Core i7 CPU M620 @ 2.67GHz(4 CPUs)
4096 RAM
DirectX 11

Display
Nvidia GeForce 310M
Approx Total Memory: 2188MB

I hope this is enough.
Reply

Sponsored links

#2
Probably the power plan were set to some kind of power saving mode, try switching it to High Performance.
Reply
#3
Wow! That was simple XD

Yeah it worked out perfectly, thank you very much! My game's back to 60fps now =D
Reply
#4
(01-01-2013, 03:28 PM)LucisFerreX Wrote: Wow! That was simple XD

Yeah it worked out perfectly, thank you very much! My game's back to 60fps now =D

Just remember to return to a power saving plan after playing, to spare the bateries for normal use.
Imagination is where we are truly real
Reply




Users browsing this thread: 1 Guest(s)