Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 P4 Help?
#1
Thumbs Down 
Hello, it's my first time posting here, so I guess I'll start off by posting my current PC specs & what not:

Computer Specs:
Sony VGN-C26G
Intel Core 2 Duo P8600 @ 2.40GHz
NVIDIA GeForce 9300M GS
Memory: DDR2 3GB
Windows Vista Home Premium 32-bit

Using PCSX2 Beta r1888:

Graphics
GSdx 1873 (MSVC15.00, SSE2) 0.1.15
800x600 60Hz
Direct3D9 (Hardware)
Interlacing - None
Aspect Ratio - 4:3
D3D - Native (1024x1024 shaded)
Checked: Texture Filtering/Logarithmic Z/Allow 8-bit/Alpha correction/Windowed

Sound
SPU2-X 1.2.0
Interpolation - Linear
Module - XAudio 2

First Controller
LilyPad svn (r1853) 0.10.0

Cdvdrom
Linuz Iso CDVD 0.9.0

Dev9
DEV9null Driver 0.4.0

= USB =
USBnull Driver 0.6.0

Firewire
FWnull Driver 0.5.0

BIOS
USA V02.00 (14/06/2004) Console

CPU
EERec - Checked
VU0rec - Checked
VUo2rec - Checked
Multi Threaded GS Mode - Checked
Frame limiting: Normal

Speed Hacks
Default
Nothing checked

Advanced
All default


Okay, so the main problem is that P4 runs really slow on this PC with PCSX2 beta. Even with speedhacks on, the intro runs at only about 24ish FPS. In-game is a little bit better, but not by much. I've tried using more speedhacks, but the result is the same. I'm not too sure what the problem is, since I've used a weaker system to play P4 and it was fine (albeit laggy when fighting certain enemies & sometimes when dialogue occurs).

Previous PC:
Fujitsu Lifebook S Series (forget exact model)
Intel Core 2 Duo T7500 @ 2.2GHz
Mobile Intel 965 Express Chipset Family
Memory: DDR2 4GB
Windows Vista Business 32-bit
DirectX 10
&
Same PCSX2 beta but with speedhacks: 1.5 Cycle, INTC, Enable IOP x2, Status Flag, Moderate Cycle Stealing

Can anyone help me please? Thanks in advance!
Reply

Sponsored links

#2
Use SSSE3 or SSE4 of GSDx and use Directx10 on the configuration.(for real?! u are using core2duo lol) Try to use some speedhacks option and move the VU Cycle stealing to slight since it will give huge fps in most games.
Your computer is good enough to run P4, cause i can run it on Pentium4 HT 3.0GHz with GeForce 8400 GS (512MB,dedicated memory)
SPECS:
i7-2630QM
NVIDIA GT540M
500GB SATA
4GB DDR3
Windows 7 Home Premium 64-bit
Windows 7 Professional 64-bit
Windows 8 Pro 64-bit


Acer Aspire 4750G
Reply
#3
Okay, I've tried all of the things you've suggested (Used SSSE3 + DirectX10 + All speed hack options [adding one at a time] + VU Cycle [slight & moderate]) and it's still pretty slow (I did the same thing with SSE4). It seems like I get about 24-27 FPS max in the Intro. and 21 FPS (~30%) in town (if it helps, I'm at the final part of the game with fog in town). I'm just annoyed that the game plays better on my weaker PC than the newer one.

Anyone have any other suggestions/advice? Thanks.

Edit: I also tried FFX for a bit (it seemed fine when I was walking around Besaid) and Xenosaga (After I pressed new game, I got a black screen with a radar on the right. I could enter the menu though and that's it. Just stayed at the black screen).
Reply
#4
That's impossible, try to disable aero in windows vista. if the problem still persists, have u tried enabling the gamefixes for persona games ? maybe your cpu could be too weak. Also, try to enable both microVU in cpu options
SPECS:
i7-2630QM
NVIDIA GT540M
500GB SATA
4GB DDR3
Windows 7 Home Premium 64-bit
Windows 7 Professional 64-bit
Windows 8 Pro 64-bit


Acer Aspire 4750G
Reply
#5
do you happen to have some kind of power saving enabled in your laptop's bios ?
That could explain slowness.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#6
There wasn't much improvement in speed as far as I could tell (tried the gamefix & microVU options). Also, Aero has always been disabled on my computers. I find it a little hard to believe that the CPU of the newer PC is weaker than my previous one...

Edit: Let me check the power-saving thing. I never thought about that before!
Reply
#7
OMG It works! Didn't realize it was on power-saving mode, so I changed it back to high performance. FFX and P4 works, but Xenosaga doesn't unfortunately...still stuck on the black screen + radar + access to menu.

Thanks very much jesalvein & ikazu for your help and patience!
Reply
#8
Xenosaga should work fine with the 1888 beta, make sure you have GSdx set to DX10 hardware, speed hacks disabled and all game fixes disabled
[Image: newsig.jpg]
Reply
#9
Oh I see...hmm I'm supposed to use Linuz Plugin for CD/DVD right? Am I supposed to run CD/DVD or ISO?
Reply
#10
If you're using an ISO image of your disc, use Linuz ISO, if you're running the actual DVD disc, use Gigaherz CDVD
[Image: newsig.jpg]
Reply




Users browsing this thread: 1 Guest(s)