Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 Problem With Cor i7+GTX275
#1
Hi People
I have a lot of problems with the PCSX2 i dont know why it doesn't runs better on My Gaming PC

This my configuration :
Intel Cor i7 920 2.67Ghz
G.Skill 8GB RAM 1600Mhz
Asus ENGTX 275
Monitor Samsung 2233SN Full HD

Please Can Someone Make Give me a tutorial to make PCSX2 runs better on my PC because i have already seen a lot of gameplays on youtube it's good but for me no

Please Help me
These are the result of my last tests on PCSX2
[Image: 834582.png]
Reply

Sponsored links

#2
Not enough info... What version of pcsx2? What graphics plugin versions? What games?

Also... http://forums.pcsx2.net/forum-55.html Configuration guide... make sure you follow it completely.
[Image: 2748844.png]
Reply
#3
(11-18-2009, 07:46 PM)Koji Wrote: Not enough info... What version of pcsx2? What graphics plugin versions? What games?

Also... http://forums.pcsx2.net/forum-55.html Configuration guide... make sure you follow it completely.

I have PCSX2 0.6.9
I have Direct X11 on my PC
and like games i have GOW2 PES8 Tomb Raider Legend

here is the tests in attachement


Attached Files Thumbnail(s)
       
[Image: 834582.png]
Reply
#4
First off, go to the beta thread and download revision 1888 simply because it's a better version to use.

Secondly, make sure that you have GSDX (the graphics plugin) set to DirectX 10... DirectX11 settings are not intended for average use yet... It's very early, very buggy, and could be causing some of these problems. Plus, no nvidia card even supports DX11, so even if that option was developed, it wouldn't do you any good. Also make sure 8-bit textures is disabled.

Thirdly, Make absolutely sure that MTGS is turned on in the CPU options as that's what allows you to have multicore support. There is no reason you should be getting that low of FPS.

The only other possibility is that your i7 isn't properly exitting out of it's cool and quiet setting when your CPU goes under load... You can try disabling it in your bios. That may or may not help.
[Image: 2748844.png]
Reply
#5
(11-18-2009, 07:54 PM)Koji Wrote: First off, go to the beta thread and download revision 1888 simply because it's a better version to use.

Secondly, make sure that you have GSDX (the graphics plugin) set to DirectX 10... DirectX11 settings are not intended for average use yet... It's very early, very buggy, and could be causing some of these problems. Plus, no nvidia card even supports DX11, so even if that option was developed, it wouldn't do you any good. Also make sure 8-bit textures is disabled.

Thirdly, Make absolutely sure that MTGS is turned on in the CPU options as that's what allows you to have multicore support. There is no reason you should be getting that low of FPS.

The only other possibility is that your i7 isn't properly exitting out of it's cool and quiet setting when your CPU goes under load... You can try disabling it in your bios. That may or may not help.

you have seen the screens i have street fighter iv i have maxed it out and its runs so so fast and burnout paradise maxed out too all runs fast but this pcsx2 no i dont know why :s
by the way where i can find this beta thread 1888 ????
[Image: 834582.png]
Reply
#6
http://forums.pcsx2.net/thread-3716.html (it's a sticky in this section...)

BTW, pcsx2 isnt a PC game you cant compare like that.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#7
You can check out my guide in my signature. It has a lot of helpful suggestions and recommended settings which are easy to follow (with pictures).

I'd also say you'd have to overclock your CPU a bit, because PCSX2 is only going to use 2 of your 8 (I think) cores. But don't do this unless you are sure of what you are doing.
Check out my snazzy Youtube channel, with many great PCSX2 emulation videos! Laugh http://www.youtube.com/user/curryking1 Laugh
Reply
#8
lool i will not overclock my CPU because the PCSX2 runs better on Cor duo and the cor i7 is more powerfull than cor duo Wink
[Image: 834582.png]
Reply
#9
That has nothing to do with this.

You need clock power, and your Core i7 is at a lower clock than an e8400 at stock. The recommended frequency is 2.8+ ghz.
Reply
#10
You guys seem to be forgetting that the Intel Core i5-i7 series has Turbo Boost. Which AUTO OC's the CPU depending on what cores have what load. On stock settings, my i5-750 OC's auto to 2.8Ghz (from stock 2.67Ghz) when all 4 cores are in use. When only one is in use, it OC's to 3.2Ghz. Bushido, I would download the CPU-Z program and see what your clock rate bumps up to while playing PCSX2. Keep in mind, that SpeedStep tech needs to be on, and Turbo Boost needs to be on for this to work. Not to mention having a mainboard that supports the technology. I increased my BCLK on my i5-750, and with only 1 core active it clocks at 3.8Ghz. With 4 active, 3.4Ghz. I will not have problems with most if not all PS2 games in terms of speed.
Laptop: Apple MacBook Pro Retina 15' | Intel Core i7-4850HQ @ 2.3-3.5Ghz | Optimus Powered nVidia Geforce GT 750M (2GB GDDR5) + Intel Iris Pro Graphics | 16GB (2x8GB) DDR3 1600Mhz RAM | Intel HD Audio | Apple Magic Trackpad | Samsung 512GB PCI-E Based SSD |
Reply




Users browsing this thread: 1 Guest(s)