Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 Running Very Slowly on Good PC
#1
Hello everyone,
I am having much trouble running this emulator on my computer, which I thought would have no trouble running at all.
The specs are:

Amd Phenom II X4 965 @ 3.8ghz
8gb DDR3 1600mhz RAM
ATI HD 5870
Crosshair III Motherboard
Windows 7 64 bit

I have spent hours on this program trying every settings possible but no matter what i do, all the games run very slowly. Other issues i am getting is vertical lines across the screen and strange shaking video issues.

Thank You,
arsenal553
Reply

Sponsored links

#2
I hope you're using PCSX2 0.9.7 r3113 and not 0.9.6 or below
Custom Desktop
CPU: Ivy Bridge Core i5 3570 3.4 GHz (3.8 GHz w/ Turbo Boost)
CPU Instructions: MMX, SSE1, SSE2, SSE3, SSSE3, SSE4.1,
SSE4.2, EIST, iAMT2, Trusted Execution Technology (TXT)
OS: Windows 7 Professional 64-bit
RAM: 8192MB DDR3 SDRAM PC3-10600 1333
HDD: 1 TB Western Digital HDD
Video: MSI GeForce GTX 660 2 GB GDDR5
Audio: Realtek 5.1 HD Audio
Reply
#3
PCSX2 settings? Plugin settings? Games tried? Screenshots?
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#4
Ok, i switched to 0.9.7 version and it seems to be running much smoother but the graphic glitches are much worse. Im still getting those vertical lines and everything looks like a textureless blob. The games i am trying to run are ratchet and clank and ace combat 4. The video plugin i am using is the SSE2 version of GSdx 0.1.16 and SPU2-X for sound.
Reply
#5
Ive also tried Jack and daxter and it has the same issues
Reply
#6
You have a relatively new CPU, it supports SSE3. So I guess that could improve your performance a bit. Also please post some screenshots, and tell us if you have any background applications running.
i7 @ 3.2Ghz /w Noctua
6GB Dominator 1600Mhz
5770 Vapor-X
1.5 TB Raid 5 /w 3ware 9650SE

Reply
#7
Yes, my cpu does support SSE3 but not SSSE3. Thats why im stuck using the SSE2 version. Screenshots will be posted soon.
Reply
#8
(09-25-2010, 08:41 PM)mantasuk Wrote: You have a relatively new CPU, it supports SSE3.

PCSX2 supports only SSE2, SSS3 and SSE4.1 (not 4a!)
The newest AMD processor have neither of the 2 latter, so you have to stick with SSE2.

Also, like Shadow Lady said, more info
Intel i5 3450
AsRock B75-Pro3-M
Sapphire R9 290 Tri-X OC
8GB DDR3-1333 RAM
Sandisk Ultra Plus 256GB
Seagate 7200.14 1TB x2
Enermax Triathlor 450W PSU
Reply
#9
(09-25-2010, 08:59 PM)SamSoNight Wrote:
(09-25-2010, 08:41 PM)mantasuk Wrote: You have a relatively new CPU, it supports SSE3.

PCSX2 supports only SSE2, SSS3 and SSE4.1 (not 4a!)
The newest AMD processor have neither of the 2 latter, so you have to stick with SSE2.

Also, like Shadow Lady said, more info

Like i said, i am now using the 0.9.7 version of the emulator and it DOES runs much smoother. The main problem now is that all the games are missing textures on objects.

[Image: ac4.png]
Reply
#10
Show us a screen shot of your graphics configuration. That's what's important.
[Image: signature.jpg]
Reply




Users browsing this thread: 1 Guest(s)