Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 Shows no disc
#1
Hello everyone,

Im have an issue playing disc games specifically Xenosaga 1. The Game shows no disc and takes me to the menu on startup.. I am using the cdvdgigahertz plug in and it is set to my disk drive. I have tried other games and they work fine.
Reply

Sponsored links

#2
how long did you wait for the dvd to load?
Reply
#3
(06-30-2014, 09:07 PM)Saiki Wrote: how long did you wait for the dvd to load?

about 3 to 5 minutes.
Reply
#4
Try ripping your game using Imgburn.
[Insert Witty Sig Here.]
Reply
#5
I thought about that but I was curious as to why the disk would not play so that I don't run into this issue in the future.
Reply
#6
Is the image ~8gb?
If not,then you don't have the whole game...the game is dial layer and its ~8gb.

Btw one stupid question...can your DVD drive read DVD9 disks?
Reply
#7
I suspect his drive may be having trouble reading DVD9s.
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#8
@ vsub
I will check the size but I believe its the whole game as its the original game disc.
@ Blyss Sarania
I would love to test your theory but.. pardon my ignorance.. how do you check if the disk is a dvd9?
Reply
#9
Xenosaga is a DVD9. DVD9 just means dual layer. Any DVD with more than 4.7Gbs of data is dual layer and hence DVD9. Some drives have trouble with those type of disc. Heck, PS2s have trouble with those type of discs.
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#10
are wii games dvd9?
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply




Users browsing this thread: 1 Guest(s)