Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 Strange lag in all games need help
#1
Ok so I'm new on this forum, sorry if I do something wrong.

First of all my specs:

CPU: Intel Core i3 530 2.93 GHz (I had read that this CPU is crap for the emulator, but I'm like "Is a fcking i3 what do u want from me?!! xD)
RAM: 4GB DDR3
GPU: GT 430 1GB DDR3 (crappy I know, but is OCed)
OS: Windows 7 Home Basic SP1 32bits

I'm using the latest PCSX2 (downloaded yesterday :| ) that is r5875, am I correct?

Plugins:

[Image: 0BE6BD115.png]

[Image: E473D2783.png]

[Image: 1D849D861.png]


Ok so the thing is that for example I play Valkyrie Profile 2 with this settings (in HW Hacks I only have "Nvidia Hack" by now) the games run at 8 fps, like literally... But when I put skipdraw to at least 1 it run smoth at 50fps (PAL), but the graphics start to glitch and flicker S: Oh and take a look at this if helps:

skipdraw set to 1 hw mode: 50fps EE 60% GS 35-40%
skipdraw set to 1/0 sw mode (f9): 30fps EE 30% GS 100%
skipdraw set to 0 hw mode: 8 fps EE 10% GS 10%

I could play with skipdraw set to 1 but it starts glitch the graphics like flickering and doin weird things at the ingame cinematics and stuff that put me mad and dont like it xD

The other game is Okami, here the thing is even weirder, if I play in hw mode it variates from sw mode a LOT, at the point that those like brush effects (if someone played Okami will know what I mean) just dissapear leaving only the like, polygonal models, like if a filter dissapear in hw mode.
Ill show u. At the intro it works great with EE 95% GS 15% but u know, is just the intro xD

Here:

SW Mode (30 fps really annoying)

[Image: 3A73B81D5.png]

HW Mode (50 fps) Well at least I've seen Orochi true form lol

[Image: 3434BE719.png]


This actually put me very mad lol, I cant figure out what is causing this, so I have no other choice to ask help to u guys!
Reply

Sponsored links

#2
Quote:CPU: Intel Core i3 530 2.93 GHz (I had read that this CPU is crap for the emulator, but I'm like "Is a fcking i3 what do u want from me?!! xD)
a better CPU, maybe ?
Quote:GPU: GT 430 1GB DDR3 (crappy I know, but is OCed)
but crappy anyways.

VP2 is very demanding and skipdraw set to 1 will be a "must have" for you. About the slowness, tinker with speedhacks, but I highly doubt you'll reach full speed.

About Okami : yes, some parts need to be played in software mode to get them right.
unfortunately, software mode will probably be too demanding for your CPU.

In short : better keep playing those games on your actual PS2 until you can afford a better machine.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
I'd say set ee cyle rate to 3. Disable 8 bit textures and texture filtering. In software mode set extra rendering threads to 3. My guess the flickering is due to the vu stealing.
Reply
#4
K guys thanks for ur answers. Im gonna try what mark says and if that dosnt work I'll have to send to repair my old PS2 lol
Reply




Users browsing this thread: 1 Guest(s)