Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 Support
#1
I have a pretty decent computer I believe however, I am not able to run PCSX2...

My specs are...
Intel Quad Core Q6600 @ 2.40GHZ
3GB RAM - (4GB actually but Windows XP doesn't support 4GB RAM)
ATI Radeon 4870 Graphics Card

When I run games like Kingdom Hearts 2, the frames are normal but on movies and actual game play, my frames jumps around. 1 second it will be 20FPS and the next it will be 64FPS then again 30FPS.

What should I do?
Reply

Sponsored links

#2
OK, first thing to do is to update to the latest beta of PCSX 2 if you don't have it already. Click here to get it.
Next, to stop the game from going too fast, go into "Config > Cpu" and click "Limit - Force frames..." on the top right.
Then, to get the game to hopefully stay at a good speed above 20FPS, go into "Config > Speed Hacks" and set the EmotionEngine (EE) Sync Hacks to "x2 Cycle Rate" (this will probably make the voices out of sync from the mouths moving) and then set VU Cycle Stealing to "Moderate" (2 notches). You can mess around with the speed hacks to see what works better or worse. Changing the settings won't break your PC, you can just change them back if they screw up the game =P

Try that for now and we'll see if you need more speed boost.
OS: Windows 7 64bit
CPU: Intel Core i7 3770K @3.5 GHz
RAM: 16GB DDR3 1600MHz
GPU: Nvidia GTX 680 2GB
Reply
#3
Hello, Sorry for changing the topic. I'm new here and
i've using PCSX2 for couple days, and i've tried to run Gran turismo 4 (original disc), but it doesn't run. So, i've made an ISO file of the whole DVD.
So i've tried to run the ISO file, but only what i've seen is some text about the game and black screen. (look at the attachment)

What should i do now??

PS. Sorry for my bad English, i come from Holland


Attached Files Thumbnail(s)
   
Reply
#4
(07-22-2009, 02:50 PM)kotsumu Wrote: I have a pretty decent computer I believe however, I am not able to run PCSX2...

My specs are...
Intel Quad Core Q6600 @ 2.40GHZ
3GB RAM - (4GB actually but Windows XP doesn't support 4GB RAM)
ATI Radeon 4870 Graphics Card

When I run games like Kingdom Hearts 2, the frames are normal but on movies and actual game play, my frames jumps around. 1 second it will be 20FPS and the next it will be 64FPS then again 30FPS.

What should I do?

Are you running the game from disc? if so try making a ISO of the game with an app like ImgBurn and run it with the Linuz ISO cdvd plugin.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#5
Yeah the fps jumping around all the time sounds exactly like running from the DVD. You might get full speed or close to it normally but during any kind of load time the fps will take a pretty good drop.
Reply
#6
Well, yeah that was actually from DVD, but I did try it with ISO and it still kinda have the same effect...

Edit: Ok this worked. With speed hacks and ISO im getting 60 FPS with limit. Without limit about 61-64 FPS on title screen movies etc.
However on actual gameplay, the speed kinda slows down =/ to about 60%
Reply
#7
Try updating to the latest beta, and please show us your PCSX2 settings so we can help easier

http://forums.pcsx2.net/thread-3716.html
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply




Users browsing this thread: 1 Guest(s)