Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 and Final Fantasy X low FPS
#1
Hello everyone,
I've tried everything with my FFX but I still have constant FPS drops, especially in high textured/crowded areas.
If I travel in small streets or hallways, it runs well.

My PC specifics are:
HP Pavillon dv6
Intel Core i7-2630QM CPU 2.00 GHz
8gb RAM
Video ADM RADEON 6770M

I've tried both PCSX2 1.2.1 and the latest SVN from the site (r5927?), but nothing has changed...
Any idea? :/

The fps drops really a lot (from 60 to 20-30) and the characters starts lagging or so...
It's kinda hard to play. Sometimes when I restart PCSX2 it gets better, I don't know why.


[Image: forum1.jpg]

[Image: speed1.jpg]
Reply

Sponsored links

#2
set your windows power plan to high performance and monitor your CPU temps
I suspect an overheating since you have quite a low CPU
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
Windows is already at high performance. :/
Reply
#4
then monitor your cpu temps. I suspect some kind of auto-throttling
get coretemp from http://www.alcpu.com and report back
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#5
Thank you very much for your help!
I don't know if I reported well:

[Image: Core_Temp_Scr.jpg]


Attached Files
.txt   CoreTemp-Dump.txt (Size: 55,73 KB / Downloads: 56)
Reply
#6
if those are the temps while playing, those a really high.
I suggest you clean your fans (remove dust) and possibly buy a cooling pad. It's highly possible your CPU speed is throttled down when reaching those temps. Hence the slowdowns.

IMHO, this laptop isn't made for intensive cpu applications like pcsx2. better play FFX on your PS2 until you can afford a modern machine (preferably a desktop computer)
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#7
Ah, damn. :/
I thought I wouldn't have any problem... I mean, I've run every kind of game on the laptop (from Skyrim to Crysis), and I've never had any problem! How could it heath so much with PCSX?
Are you sure I can't change something from the software settings to reduce the problem? T_T
Reply
#8
(03-24-2014, 02:52 PM)malmal92 Wrote: Ah, damn. :/
I thought I wouldn't have any problem... I mean, I've run every kind of game on the laptop (from Skyrim to Crysis), and I've never had any problem! How could it heath so much with PCSX?
Are you sure I can't change something from the software settings to reduce the problem? T_T

Skyrim & Crysis aren't emulated PS2 games, it's completely irrelevant to compare them to pcsx2. Thise will rely more on your GPU power than CPU power. Pcsx2 loads your CPU really more than those PC games you mentioned.

Back to your PS2, then ... sorry Sad
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#9
Try to enable MTVU speedhack and to use GSDX AVX Direct3D9.

Use a lower custom internal resolution and enable everything under hardware mode settings in gsdx. Set audio to async mix mode.

You can also set pxsx2 process priority to high in task manager and use MSI afterburner to monitor or overclock your GPU. (My i7 2670QM +GT555M runs most games fine in 1920x1080 or 1440x1080 internal resolution)
Reply
#10
GSDX AVX Direct3d9 like this?

[Image: direct.jpg]
Reply




Users browsing this thread: 1 Guest(s)