Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 assertion failed on Gentoo.
#1
Hello, I have a problem like this on Gentoo 4.4.6:


Code:
/var/tmp/portage/games-emulation/pcsx2-1.4.0/work/pcsx2-1.4.0/common/src/Utilities/Linux
/LnxHostSys.cpp(64) : assertion failed:
   Function:  void SysPageFaultSignalFilter(int, siginfo_t*, void*)
   Thread:    Unknown
   Condition: false
   Message:   Unhandled page fault @ 0xedf88000

Stacktrace:
[00] wxNavigationEnabled<wxControl>::AcceptsFocusFromKeyboard() const
[01] __kernel_rt_sigreturn                      
[02] 0x0xefc802eb                                
[03] 0x0xefc7eea1                                
[04] 0x0xefcbaef9                                
[05] 0x0xefcbc735                                
[06] 0x0xefcbdb8d                                
[07] 0x0xefcf3b7c                                
[08] 0x0xf649b2b1                               
[09] clone                                      

I'm trying to run Guilty Gear X2 and X2 Reload (still can play Guilty Gear X)
Using pcsx2-1.4.0, SDL-1.2
Debug and reconfigure OnePAD didn't help at all.
Reply

Sponsored links

#2
You don't have the same error. All memory errors will trigger the same pop up.

Compile a dev build with debug symbol and without the -fno-omit-frame pointer optimization. If pop up info is mostly the same, attach gdb to the process when the windows pop up and dump all backtrace with "thread apply all bt"
Reply
#3
Quote:gregoryYou don't have the same error. All memory errors will trigger the same pop up.

Compile a dev build with debug symbol and without the -fno-omit-frame pointer optimization. If pop up info is mostly the same,  attach gdb to the process when the windows pop up and dump all backtrace with "thread apply all bt"

Gregory,

sorry, but I can't compile any pcsx2 build, that's why I chose ebuild.
Now we have:

Code:
Forcing cross compilation.
Building pcsx2 with -DCMAKE_BUILD_PO=FALSE -GNinja -DSDL2_API=FALSE -DCMAKE_BUILD_TYPE=Debug -DCMAKE_TOOLCHAIN_FILE=cmake/linux-compiler-
i386-multilib.cmake
-- Building with GNU GCC
-- Cross compilation is enabled.
-- Compiling a i386 build on a x86_64 host.
CMake Error at /usr/share/cmake/Modules/FindwxWidgets.cmake:858 (message):
 wxWidgets wx/version.h file not found in .
Call Stack (most recent call first):
 cmake/SearchForStuff.cmake:63 (find_package)
 CMakeLists.txt:61 (include)


-- Configuring incomplete, errors occurred!
See also "/home/pcsx2-c1f45dafa5ea62b8251f9f69e8d9972afc893605/build_dbg/CMakeFiles/CMakeOutput.log".
ninja: error: loading 'build.ninja': No such file or directory
ninja: error: loading 'build.ninja': No such file or directory
Reply
#4
Oh Smile It is a shame, PCSX2 is likely the only program that will be faster if you compile it on your machine (as it will enable SSE3/4 & AVX optimization). I made a wrong shortcut because you use Gentoo.

Do you have a debug package somewhere. If no, yield to the guy that did the build to get the nice debug symbol. Debug symbol + gdb will be enough.

For the record, self-compilation require dev package for all dependencies. You likely miss the wx one.
Reply
#5
(08-24-2016, 11:15 AM)gregory Wrote: Oh Smile It is a shame, PCSX2 is likely the only program that will be faster if you compile it on your machine (as it will enable SSE3/4 & AVX optimization). I made a wrong shortcut because you use Gentoo.

Do you have a debug package somewhere. If no, yield to the guy that did the build to get the nice debug symbol. Debug symbol + gdb will be enough.

For the record, self-compilation require dev package for all dependencies. You likely miss the wx one.

Thank you.
Anyway, how can I fix "self-compilation" problem?

Update: nice, now I can't install ebuild too, same reason.
Reply
#6
Honestly I don't know Gentoo. You can find information here http://forums.pcsx2.net/Thread-PCSX2-for-Gentoo

I hope it can help you.
Reply
#7
(08-24-2016, 02:38 PM)gregory Wrote: Honestly I don't know Gentoo. You can find information here http://forums.pcsx2.net/Thread-PCSX2-for-Gentoo

I hope it can help you.

Oh.

Likely, last time GSdx had wrong settings (renderer or something else). But now, speed is ~70-80% with default video settings (at least, it works).

Thanks again.
Reply
#8
Hum. Maybe DirectX was selected on the default ini. I need to double check it. I'm glad it is working
Reply




Users browsing this thread: 1 Guest(s)