Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 crashes after about 10 minutes
#1
Specs

8 gb ram
nvidia 570 gtx
i7 3770k
windows 7 ultimate 64 bit

it's not overheating.
drivers all updated.
directx run-time installed.
visual c++ 2010 installed.

Doesn't matter what game it is. It always crashes between 10-15 minutes. Never had this problem before 1.0.0

Currently using rev 5541.

please help.
Reply

Sponsored links

#2
can you please post the emulog after a crash ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
I had the same problem until yesterday. Every game crashed randomly and without an error message in the log.
The solution was so simple I had to laugh...some of the newer builds I downloaded seemed to have speedhack enabled - I never used that, so I never checked the options there. I haven't gotten any crashes after disabling speedhack Smile
Maybe you've the same problem.
Reply
#4
(02-05-2013, 06:15 PM)Caion Wrote: I had the same problem until yesterday. Every game crashed randomly and without an error message in the log.
The solution was so simple I had to laugh...some of the newer builds I downloaded seemed to have speedhack enabled - I never used that, so I never checked the options there. I haven't gotten any crashes after disabling speedhack Smile
Maybe you've the same problem.

Can you locate which hack\hacks that causes this (by having "Enable speedhacks" set):
• "Enable INTC Spin Detection"
• "Enable Wait Loop Detection"
• "mVU Flag Hacks"
Maybe the coders can have the scoundrel disabled in new releases.
Reply
#5
(02-05-2013, 09:28 PM)pgert Wrote: Can you locate which hack\hacks that causes this (by having "Enable speedhacks" set):
• "Enable INTC Spin Detection"
• "Enable Wait Loop Detection"
• "mVU Flag Hacks"
Maybe the coders can have the scoundrel disabled in new releases.

Unfortunately not. All of these options were enabled, so I can't locate which one caused the crash.
Reply
#6
(02-05-2013, 09:36 PM)Caion Wrote: Unfortunately not. All of these options were enabled, so I can't locate which one caused the crash.

Simply disable one at a time.
Reply
#7
(02-05-2013, 09:59 PM)pgert Wrote: Simply disable one at a time.

Alright I have opened SMTLaughDS three times now to check each option separately. Let's see which one crashes first :-)
But I can't guarantee that there will be a crash because I don't move/do anything except standing in game.
Reply
#8
(02-05-2013, 10:14 PM)Caion Wrote: Alright I have opened SMTLaughDS three times now to check each option separately. Let's see which one crashes first :-)
But I can't guarantee that there will be a crash because I don't move/do anything except standing in game.

Yeah that was quick. It took only 5 minutes to crash one game.
The cause was "Enable INTC Spin Detection". The others are still working by now.

Blink

Interesting....while typing the first paragraph the second game crashed. This time the cause was "mVU Flag Hack".
Reply
#9
(02-05-2013, 10:25 PM)Caion Wrote: Interesting....while typing the first paragraph the second game crashed. This time the cause was "mVU Flag Hack".

Do you have "EE Cyclerate" set to 1, and "VU Cycle Stealing" set to 0?
Reply
#10
@Caion none of those recommended speedhacks causes crashes in this game and they're recommended couse actually not causing any problems with most other games either plus are disabled in those they do automatically. The crashes must be caused by your system.

For both of you having similar crashes, make sure you have vs 2010 SP1 redistributable installed, there's also non SP1 version which althrough running pcsx2, will cause random crashes soo make sure you have the correct one. If that doesn't help, you can try switching SPU2-X from Xaudio2 to Dsound as it have problems with some sound drivers.
Reply




Users browsing this thread: 1 Guest(s)