Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 crashes on starting FFX
#1
Hi,

I'm having some difficulties with Final Fantasy X
PCSX2 crashes after the sony logo fades away.
It does work using GSdx on Direct3D9(software) but very slow
ZeroGS plugin also does the job, but again very slow.

I'm using PCSX2 0.9.6
Windows XP SP 3
GSdx 890 (SSE2)
AMD Athlon 64 4000+
Nvidia Geforce 6600GT
Latest Direct X 9 version installed
Microsoft Visual C++ 2008 SP1 Redistributable Package (x86) installed

Any help would be appreciated Laugh

Sponsored links

#2
(01-31-2010, 11:14 PM)Wouterk Wrote: Hi,

I'm having some difficulties with Final Fantasy X
PCSX2 crashes after the sony logo fades away.
It does work using GSdx on Direct3D9(software) but very slow
ZeroGS plugin also does the job, but again very slow.

I'm using PCSX2 0.9.6
Windows XP SP 3
GSdx 890 (SSE2)
AMD Athlon 64 4000+
Nvidia Geforce 6600GT
Latest Direct X 9 version installed
Microsoft Visual C++ 2008 SP1 Redistributable Package (x86) installed

Any help would be appreciated Laugh

This is odd. At least the PAL version worked well for me with 0.9.6. Do you have the NTSC version? Have you enabled any Speed Hacks? If yes, turn them off. Perhaps this will fix it. Have you perhaps changed something in the advanced options? If not, try the newest plugins: http://forums.pcsx2.net/thread-6830.html

Edit: Another question: Which CDVD plugin are you using? Because mounting an image and reading it via CDVD Gigaherz can sometimes cause crashes. If you're doing this, try again with Linuz Iso CDVD, it's faster anyway. You don't have to mount the image this way, just select it in the plugin configurations and you're set.

@ iakoboss7: That's right, I forgot to mention that^^.
Rejoice, they say. Color is back.
#3
Quote:This is odd. At least the PAL version worked well for me with 0.9.6. Do you have the NTSC version? Have you enabled any Speed Hacks? If yes, turn them off. Perhaps this will fix it. Have you perhaps changed something in the advanced options? If not, try the newest plugins: http://forums.pcsx2.net/thread-6830.html

in addition to bright-warrior use the 1888 beta with the plugins he said Wink
OS: Win 7 Ultimate x64 sp1, MoBo: Asus P5QD Turbo, CPU: Q6600 @ 3,0Ghz, RAM: Trancend 2x2gb 6-6-6-18 800 MHz, GPU: HD 4850 1gb.
Pcsx2: Always Latest
#4
Question 
I'm not sure if I got the PAL or NTSC version, how can i check this?

Okay I tried the plugins and the beta version, it's running now Laugh

It's not running very smooth though, the screens seems to shake a bit, any idea how to solve this?
#5
(02-04-2010, 10:17 PM)Wouterk Wrote: I'm not sure if I got the PAL or NTSC version, how can i check this?

I'll try the plugin you guys suggest later

thanks for helping out Smile

When you bought your copy in europe, it'll be the PAL one. If you live in North America, it should be NTSC. You can say it is about this, the borders are a bit more complicated^^. Take a look: http://en.wikipedia.org/wiki/File:PAL-NTSC-SECAM.svg

Or you look at the frame counter at the top of the windows of PCSX2 before it crashes. If it shows about 50 fps, it's PAL, if 60 fps, it's NTSC.

Wouterk Wrote:[...]thanks for helping out[...]

Your welcome.

Edit:
(02-04-2010, 10:17 PM)Wouterk Wrote: [...]It's not running very smooth though, the screens seems to shake a bit, any idea how to solve this?

Press "F5" while running the game. This changes or rather activates the different interlancing modes. Just try them out and look which one makes the image look best.

Edit 2: Ah, one more clue: You should change the renderer in the GSDX configuration to "Direct3D9 (Hardware)", if you haven't already done so. Software has a higher compatibility, but it's way slower than hardware. And since Final Fantasy X is working pretty fine, there's no need to use software.
Rejoice, they say. Color is back.
#6
Ah its NTSC Wink

The deinterlacing option did the trick thanks agian Biggrin

I'm off playing FFX Happy
#7
Hmm the ingame menu's are working fine now
but as soon as i start playing the framerate drops to 30-40 and every thing slows down, it's playable i guess but it takes away the greatness of FFX Sad
Is this my bad pc not capable of emulating a ps2 (also tried my (slightly) better laptop, Core 2 duo @ 1,83Ghz, 2GB ram, Geforce Go 7600) or some faulty plugin settings?
#8
If you show us your settings maybe we can help.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
#9
(02-05-2010, 11:12 PM)Shadow Lady Wrote: If you show us your settings maybe we can help.

Will this do?

[Image: 1zzpdop.png]

[Image: 2872gas.png]
#10
use native resolution, try enabing NONE at clamp mode in advanced settings, find the speedhacks that works better with u (try them 1 by 1) but i dont think u can do much, sorry but with that pc even 30 frames look good Tongue (and only use the 1888 with the plugins we 2 said.... 0.9.6 would be 2 slow for u)
OS: Win 7 Ultimate x64 sp1, MoBo: Asus P5QD Turbo, CPU: Q6600 @ 3,0Ghz, RAM: Trancend 2x2gb 6-6-6-18 800 MHz, GPU: HD 4850 1gb.
Pcsx2: Always Latest




Users browsing this thread: 1 Guest(s)