Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 entirely battery dependant!!??
#1
Got the origin of my slowdowns: the battery! Putting FFX as reference, now it only works correctly only when battery is plugged! When it's unplugged, slowdowns the entire game. Even I played switching and unswitching every 5 seconds, and every 5 seconds slowdown - no slowdown. The worst thing is it happens with every version I have (0.9.2, 0.9.4, PG, and the most recent beta).

This is bad... my lap may be crapped... Me and my experiments...

Note: Messenger or visual effects have no effect.

Reply

Sponsored links

#2
@ZLRK
When you plug your laptop, your "power options" switch automatically into "high performance" mode.
When you unplug it, the laptop is only relying on battery and switch to "power saver" mode. Even if your laptop is unplugged , you can force your power options to high performance. And I bet your battery will then loose it's charge quickly.
Reply
#3
(02-14-2009, 07:07 AM)bigmehdi Wrote: @ZLRK
When you plug your laptop, your "power options" switch automatically into "high performance" mode.
When you unplug it, the laptop is only relying on battery and switch to "power saver" mode. Even if your laptop is unplugged , you can force your power options to high performance. And I bet your battery will then loose it's charge quickly.

Yes, I know (please, let's put aside for now the fact that PCSX2 isn't for laptops, I already know it). The maximum the battery can last is aprox 3 hours. When I played FFX or FFX-2 the battery lasted 1 hour before I had to plug it, however there was no difference in fps either plugged or unplugged. That was when I used Vista Basic. Do you or anyone else think the OS can make a difference?

Hope is not hardware issue, or there would be no solution... I must confess that I used to keep the lap plugged even when it was already fully charged. Put itself in sleep mode when plugged for not being used for a long time in 2 times. Oh, men, I'm starting to get nervous...

Reply
#4
Are you using modded Nvidia drivers (or a modded inf)? They tend to have broken Powermizer feature, meaning the GPU often get stuck on 'Low Power 2D' mode when using battery. Stick to official mobile drivers (the latest being 179.48) instead of using modded desktop drivers.
Reply
#5
Sorry for my ignorance, but what are modded drivers or modded infs? All I know is I'm using the default drivers which come with the original drivers disc of my lap, meaning I haven't even updated them (for some reason I don't like Windows Update feature, is it the best option?).

Anyway, I start to believe that is not exactly hardware problem since other emulators like the GC one, Dolphin, have no slowdowns and they work as they should.

Reply
#6
Yes u can just go to the nvidia website on your lap top and get the latest mobile drivers that way
Reply
#7
Don't DL the latest drivers they make bugs in graphic ( sorry fo my ENG) 181.22=bugs in graphic
Reply
#8
Your laptop is not crap, it's a good one, and the problem is when you unplug, it switch to lower performance to save battery just like bigmehdi said, so change your Power options in Control Panel to force your laptop keep running in high performance. Since Pcsx2 uses alot of CPU resources, so there's no doubt your laptop will slowdown when unplug and will run out of battery very quickly. And don't compare with another emulator, Pcsx2 is a beast Tongue

PS: Sorry for my bad English Tongue
Reply
#9
When I said 'crapped' I meant I may have "damaged" it or kind of, because of my bad habits of plugging already mentioned. And I repeat, that didn't happen when I used Vista Home Basic. Do you or someone else think the Operating System could make the difference, or could be something else with the hardware?

Well, if for some reason I'm going offtopic, please let me know...

EDIT: tried setting to high performance without plugging, ans still the same problem. It needs to BE PLUGGED! That's why I was saying I may have crapped my lap....

Reply




Users browsing this thread: 1 Guest(s)