Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 for Debian/Ubuntu
#11
on Ubuntu 11.04 x86, this is my quick installation of all dependencies for compiling pcsx2 0.9.9:
Code:
sudo apt-get install subversion cmake nvidia-cg-toolkit libglew1.5-dev libbz2-dev libsdl1.2-dev libgtk2.0-dev libwxgtk2.8-dev libsparsehash-dev libjpeg8-dev portaudio19-dev

[Image: Ubuntu_11.04_x86-PCSX2_0.9.9_4918-title_screen.png]
durable PC since 2008
CPU : E7200 @ 2.53 GHz 1.04 V / OC 3.7 GHz 1.36 V (390*9.5, 4GB DDR2 780)
GPU : 8600GT (GDDR3, 256 MB) / OC (750 / 900)
BOARD : GA-EP31-DS3L (rev 1.0) broken and bought a second hand one replaced
PSU : 300 W
OS : Windows 7 Home Basic x86
Reply

Sponsored links

#12
hmm..
Reply
#13
alright...
only one command..?
^_^
Reply
#14
that's the command line 4 graphic card of Nvidia right?
But, how if the graphic card is ati radeon or intel..?
Just replace the text of ''nVidia'' with ''ati-radeon''..?
Reply
#15
nvidia-cg-toolkit is not nvidia specific but it was developped by nvidia. However you need opengl and x11 stuff but they are maybe pull from others -dev package.

Note: the specific part for each graphic card is the driver. If you want speed you will binary drivers from nvidia/ati, open-source does not do yet the jobs.
Reply
#16
Hello, first thanks for pcsx2 is a great emulator

i got a problem with kubuntu precise pangolin 12.04 beta 1
and the "nvidia-cg-toolkit" package and the multiarch support

reading this : " https://bugs.launchpad.net/ubuntu/+sourc...bug/811927 "

Quote:This bug was fixed in the package nvidia-cg-toolkit - 3.0.0016-0ubuntu1

---------------
nvidia-cg-toolkit (3.0.0016-0ubuntu1) precise; urgency=low

[ Gregory Hainaut ]
* Build for multiarch (LP: #811927)
+ Move library into libcg package. Update conflict accordingly.
+ Install so in multiarch directory
+ generate multiarch path in .install files
+ Bump debhelper dependency, need for ${miscTonguere-Depends} and dpkg >= 1.16

[ Stefano Rivera ]
* New upstream version
-- Gregory Hainaut <email address hidden> Mon, 28 Nov 2011 18:48:59 +0200

i understand that the 3.0.0016-0ubuntu1 version of nvidia-cg-toolkit is supossed to support multiarch, i got that version
and
i added this repository to install pcsx2

https://launchpad.net/~gregory-hainaut/+...ficial.ppa

pcsx2 need i386 nvidia cg toolkit, at the same time i have installed amd64 version of dolphin-emu to emulate gamecube/wii , that emu needs amd64 nvidia cg toolkit

but if i try to install pcsx2 dpkg says this:

Quote:The following packages will be REMOVED:
dolphin-emu nvidia-cg-toolkit

so what's happen with the multiarch support?

is there a workaround to install i386 and amd64 nvidia cg toolkit?

really i want to install the 2 emulators at the same time Biggrin

thats all and thanks
Reply
#17
Hum that stange! Well thinking of it, I might need to update my ppa. I need to build against libcg... Note dolphin need to do so too.

I don't remember the name, you can use "apt-cache search nvidia cg". I think it is libcg, just check that you install both architecture version. libcg:i386 and libcg:amd64

edit: I launch a new ppa build to support multiarch (well I hope it would be ok). Upgrade will be available in coming hours/days.
Reply
#18
well i did this

Quote:sudo apt-get install libcg:i386

cheking with muon package manager (something like synaptic for kde)
i'm sure i have libcg:i386 and libcg:amd64 both installed without problems

now only have to wait for the ppa update to be available

thanks

edit : no luck, tested the 5132-2 version you recently updated to the ppa

and it's still need the uninstalling of the amd64 nvidia-cg-toolkit
Sad
Reply
#19
Arg... It will be harder. I think there is a bug in the nvidia-cg-toolkit package. That very annoying. I hope we can fixed it before the release (but there are probably freeze by now Sad )

Could tell me the result of those command:
Code:
apt-cache show nvidia-cg-toolkit | grep Multi
apt-cache showpkg pcsx2-plugins-unstable
more /var/lib/dpkg/info/nvidia*.shlibs
more  /var/lib/dpkg/info/libcg*.shlibs
Reply
#20
here is it

apt-cache show nvidia-cg-toolkit | grep Multi

No output

apt-cache showpkg pcsx2-plugins-unstable

Quote:Package: pcsx2-plugins-unstable:i386
Versions:
5131-2 (/var/lib/apt/lists/ppa.launchpad.net_gregory-hainaut_pcsx2.official.ppa_ubuntu_dists_precise_main_binary-i386_Packages)
Description Language:
File: /var/lib/apt/lists/ppa.launchpad.net_gregory-hainaut_pcsx2.official.ppa_ubuntu_dists_precise_main_binary-i386_Packages
MD5: def80798c036ae3ec23feec207a5ef56


Reverse Depends:
pcsx2-plugins-unstable-dbg:i386,pcsx2-plugins-unstable:i386 5131-2
pcsx2-unstable:i386,pcsx2-plugins-unstable:i386 5131-2
Dependencies:
5131-2 - libasound2:i386 (2 1.0.23) libc6:i386 (2 2.15) libgcc1:i386 (2 1:4.1.1) libgl1-mesa-glx:i386 (16 (null)) libgl1:i386 (0 (null)) libglew1.6:i386 (2 1.6.0) libjpeg8:i386 (2 8c) libportaudio2:i386 (2 19+svn20101113) libsoundtouch0:i386 (0 (null)) libstdc++6:i386 (2 4.6) libwxbase2.8-0:i386 (2 2.8.12.1) libwxgtk2.8-0:i386 (2 2.8.12.1) libx11-6:i386 (2 2:1.4.99.1) nvidia-cg-toolkit-pcsx2:i386 (16 (null)) nvidia-cg-toolkit:i386 (2 2.1) pcsx2-unstable:i386 (2 5131-2) pcsx2-data-unstable (0 (null)) pcsx2-data-unstable:i386 (0 (null)) pcsx2-plugins (0 (null)) pcsx2-plugins:i386 (0 (null)) pcsx2-data-unstable (0 (null)) pcsx2-data-unstable:i386 (0 (null))
Provides:
5131-2 -
Reverse Provides:

more /var/lib/dpkg/info/nvidia*.shlibs

Quote:/var/lib/dpkg/info/nvidia*.shlibs: No such file or directory

more /var/lib/dpkg/info/libcg*.shlibs

Quote:libcgraph 5 libcgraph5
Reply




Users browsing this thread: 1 Guest(s)