Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 freezes for a second!
#1
I've been playing the .hack series and have noticed that every so often the sound and game will freeze for a second and then be fine. I'm playing the PAL version so the framerate is capped at 50 but I consistently get this framerate.

I've noticed it happens every time I approach grunty food or cast a skill for the first time, the game will freeze for a second and then resume as if it had to load the sound of the skill or something.

It's really rather annoying.
Reply

Sponsored links

#2
In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
Sounds like this: http://forums.pcsx2.net/Thread-FFX-minor...ne-changes

Or a similar issue that happens in Ar tonelico. Yes it's because the game has to suddenly load and decompress assets.
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#4
(09-25-2015, 02:28 PM)Blyss Sarania Wrote: Sounds like this: http://forums.pcsx2.net/Thread-FFX-minor...ne-changes

Or a similar issue that happens in Ar tonelico. Yes it's because the game has to suddenly load and decompress assets.

Do you know if there is any way to fix this?
Reply
#5
Put your ISO on an SSD can help a tad bit(depending on if the limit is the loading or the decompressing).

Config->Audio->Plugin settings and change Timestretch to Async Mix won't fix it, but it will make you notice it less because the sound won't pause when it happens.
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#6
(09-25-2015, 02:33 PM)Blyss Sarania Wrote: Put your ISO on an SSD can help a tad bit(depending on if the limit is the loading or the decompressing).

Config->Audio->Plugin settings and change Timestretch to Async Mix won't fix it, but it will make you notice it less because the sound won't pause when it happens.

It's already set to async mix but I can still notice the audio pause for a bit.

I don't have an SSD so that's not an option for me.
Reply
#7
Then there really isn't much you can do. Assuming it's the same issue, which it sounds like.

Just to check, please post the info that jesalvein asked for above.
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#8
disable your intel speed step!!!

in your bios setup

this fixed it
Reply
#9
(09-25-2015, 02:41 PM)Blyss Sarania Wrote: Then there really isn't much you can do. Assuming it's the same issue, which it sounds like.

Just to check, please post the info that jesalvein asked for above.

Damn it's a bit annoying.

CPU: Intel i7 3630QM 2.4GHz quad core
GPU: NVIDIA GeForce GT 650M 2GB
Memory: 8GB
OS: Windows 10
PCSX2 Version: 1.2.1

Games are ISOs
All my settings are default except I changed to DirectX 11 and changed audio to async mix.

(09-25-2015, 02:52 PM)knight321 Wrote: disable your intel speed step!!!

in your bios setup

this fixed it

What is this? I can't find something like that only Intel rapid start and rapid storage.
Reply
#10
(09-25-2015, 02:52 PM)knight321 Wrote: disable your intel speed step!!!

in your bios setup

this fixed it

I doubt that's the case.
Also you can force max speed(not turbo too)from windows power management.
I often limit the maximum speed because some games\programs are making the cpu to needlessly run at above max speed(in my case above 3.5ghz which incenses the heat...and decreases the battery life if you are on a laptop)

adymento you can also try OpenGL and by ".hack series" do you mean all games or the first 4 or the second 3
Reply




Users browsing this thread: 1 Guest(s)