Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 lagging a bit on a really high-end pc... Help?
#1
Rainbow 
So I decided to download PCSX2 and I've been having alot of fun with it. But there's one thing that bugs me, apparently in some games the fps just tends to stay really low, like 30, even though I've seen it run at full speed with way worse CPUs.

i7-2600K @ 4,6Ghz
GTX590

Also it seems that games lag LESS when I play them on software mode. And I thought it was supposed to be the exact opposite...
Reply

Sponsored links

#2
what games specifically?
Reply
#3
Fatal Frame 3, Crash Twinsanity, Airblade, All burnouts (except 2 and 1)
Reply
#4
Have you tried downloading CPU-Z and monitoring your Multiplier rate? By default your Multiplier should auto rise under heavy load...maybe that's not happening?
Reply
#5
In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#6
(05-13-2012, 12:41 AM)refraction Wrote: In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.

Specs: ASUS GTX590 3GB, i7-2600K @ 4,6Ghz, 12Gb DDR3 at 1600/1333MHz, Windows 7 Home Premium

PCSX2 0.9.8 (I've also tried with some svn revisions, but it runs just as bad)
Renderer: Direct3D11 (Hardware) with 3x Native (Since that's possibly the only reason I would even want to use Hardware mode)

Games: Fatal Frame 3 and 2, Burnout series (Except for 2 and 1), Crash Twinsanity, Airblade and Crash Tag Team (With sounds off since they're broken for this game.) All of them off ISOs because my CD drive is so horribly slow everything that's ran off a CD just dies on me.
Reply
#7
(05-12-2012, 10:07 PM)bananaclawz Wrote: Have you tried downloading CPU-Z and monitoring your Multiplier rate? By default your Multiplier should auto rise under heavy load...maybe that's not happening?

[Image: ed5017c3d35dde764d9a899.png]

Seems to be working fine

EDIT: Also that's how it looks while playing the game.
Reply
#8
lol maybe u didnt add pcsx2 to your nvidia control panel and choose preferred processor "High performance nvidia processor
Reply
#9
(05-13-2012, 01:35 PM)devilscorner Wrote: lol maybe u didnt add pcsx2 to your nvidia control panel and choose preferred processor "High performance nvidia processor

And how would I go on about doing this? I don't seem to find any option like that in my Nvidia control panel.
Reply
#10
I think he ment optimus drivers, but that's only for laptops(?) where your GPU switch to integrated one when it's not needed. It's pretty clear that the problem comes from your gpu and it's also clear that such gpu shouldn't have slightest problems with x3 multiplier, through I dunno those games to say that for sure;]. Maybe check GPU-Z to see if your gpu uses it's power? It's possible that it runs in power saving mode giving you crappy fps, what power plan you have selected in your windows? If it's on power saving then GPU will sit on lowest-power saving state, but it's not a laptop soo by default it should be higher.
Reply




Users browsing this thread: 1 Guest(s)