Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 lags
#1
Hello Everyone, I have a problem concerning PCSX2. I was using Nvidia Geforce 9400GT and I was running Tenkaichi 3 on that perfectly at Native internal resolution. But now, I upgraded my graphics card to 5750 and also overclocked my processor to 3.25 Ghz. But now when I try to run PCSX2 the game runs all fine except when I duel at the time chamber when the frame rate falls to about 40-45 fps(NTSC version) and at other places it runs perfectly. I don't think my specs bottleneck the game.

Also, on my older video card I ran Contra Shattered Soldier at 60fps but now it runs just at 40-45 fps forever.

One more thing, the fps remains the same(niether rises nor falls) whether I run at 1680*1050 or at native internal resolution.
My specs: Intel Dual Core 3.01 GHz E5200 (240x12.5)
XFX Radeon HD 5750
2GB Ram
Windows 7 64-bit
Reply

Sponsored links

#2
Make sure your overclock is stable and your processor is getting enough volts. If it isn't, it will perform badly
[Image: newsig.jpg]
Reply
#3
My overclock is stable. I ran Intel burn test and Prime 95 and both worked fine. I have been playing highly CPU intensive games like Crysis and GTA 4 at good framerates, so I doubt it's a problem of stability.
My specs: Intel Dual Core 3.01 GHz E5200 (240x12.5)
XFX Radeon HD 5750
2GB Ram
Windows 7 64-bit
Reply
#4
PCSX2 is known to have problems when an overclock is unstable even if it passes hours and hours of Orthos and other torture tests. I've had this problem myself, so just in case try it once with your CPU at stock settings and see how the performance is then so we can rule it out at least.
[Image: newsig.jpg]
Reply
#5
Ok, so now I have my Cpu at stock again. But still the same problem.
My specs: Intel Dual Core 3.01 GHz E5200 (240x12.5)
XFX Radeon HD 5750
2GB Ram
Windows 7 64-bit
Reply
#6
Hm ok so the problem seems to lie with the new graphics card. Make sure in it's drivers that both anti aliasing and vsync are OFF (application controlled won't do either, must be forced off). I guess you already are using the latest drivers
[Image: newsig.jpg]
Reply
#7
Might this be the problem?

http://forums.pcsx2.net/Thread-Catalyst-...000-series
Intel C2D E6550 2.33GHz (OC@2.8GHz)
Corsair CM2X1024 4GB (4x1GB) DDR2 DRAM
ASUS P5K
XFX Radeon HD 5770 1GB

Running on Windows 7 Home Premium 64-bit.
Reply
#8
@bositman: I couldn't find a way to force off antialiasing and vsync. When I uncheck application controlled, it is always at x2. And yes I have the latest 10.2 drivers.

and @k1net1cs: If that might be my problem then I would have to wait for the 10.4 drivers to come out.

Edit: Well after going back to stock, I tried to enable allow 8-bit textures and Wow! it solved my problem. So now, I am gonna overclock to 3.0GHz which was more stable than 3.25GHz. One thing more left to try is Contra: Shattered Soldier.Smile
My specs: Intel Dual Core 3.01 GHz E5200 (240x12.5)
XFX Radeon HD 5750
2GB Ram
Windows 7 64-bit
Reply




Users browsing this thread: 1 Guest(s)