Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 not reading or registering game CRC
#1
A continuation of a thread from the Plugins section, because I thought at first it was a plugin issue.

Quite simply, my version of PCSX2 (1.1.0, but 0.9.8 had the same problem) doesn't seem to completely read what it's meant to. The following is the total output that happens when I try to boot up a game (Shin Megami Tensei Nocturne in this case, but the problem persists with all games I've tried, both ISO and disc).

Quote:(GameDB) 9640 games on record (loaded in 154ms)
HLE Notice: ELF does not have a path.


Initializing plugins...
Init GS
Init PAD
Init SPU2
Init CDVD
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Opening plugins...
Opening GS
Opening PAD
Opening SPU2
Opening CDVD
isoFile open ok: C:\Users\PC\Documents\PCSX2\SMTNOCTURNE.mdf
Image type = DVD
Fileparts = 1
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (2085072 sectors)
Opening USB
Opening FW
Opening DEV9
McdSlot 0: C:\Users\PC\Documents\PCSX2\memcards\Mcd001.ps2
McdSlot 1: C:\Users\PC\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
Bios Found: Europe v01.60(04/10/2001) Console
BIOS rom1 module not found, skipping...
BIOS rom2 module not found, skipping...
BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
(UpdateVSyncRate) Mode Changed to PAL.
(UpdateVSyncRate) FPS Limit Changed : 50.00 fps
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
(UpdateVSyncRate) Mode Changed to PAL.
(UpdateVSyncRate) FPS Limit Changed : 50.00 fps
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps

I know there is meant to be more, specifically the game CRC. In fact, because the emulator isn't reading the game's CRC, I'm getting an old, long-solved graphical bug in SMT Nocturne because GSdx doesn't have anything to match to its exceptions list.

If anyone has any idea how to solve this, or possibly a workaround so at least I can ply the game without seeing through walls, that'd be awesome.
Reply

Sponsored links

#2
that's because as far as I know PCSX2 doesn't support MDF/MDS files, cause the *.MDS file is the file where the data is written. So download IMGBurn here: http://www.imgburn.com and make an ISO Image and retry it again.
Reply
#3
Delete the .MDS file, then rename the .MDF file to .ISO.
Intel Core 2 Quad Q9400 | nVidia GeForce GTX 750 | 4 GiB DDR3 @ 533 Mhz | MSI G41M-P28 | Cooler Master RS-390-PMSR-A3 | Xigmatek TYR SD962 | LG Flatron W1943SE | HP KB-0316 | MotoSpeed F60
Reply
#4
That doesn't always work, cause the *.MDF doesn't have a Table Of Content the *.MDS has it for the *.MDF
Reply
#5
(02-07-2013, 09:01 AM)Livy Wrote: Delete the .MDS file, then rename the .MDF file to .ISO.

Unnecessary. The copy I have made of my PAL version of DBZ Budoaki 3 is .mdf and it works perfectly. Are you using full or fast boot?
My YouTube (Kingdom Hearts II: Final Mix FULLY TRANSLATED!): http://www.youtube.com/tyestor
MyAnimeList: http://www.myanimelist.net/profile/tyestor
Last.fm: http://www.last.fm/user/tyestor
My PCSX2 settings: http://i.imgur.com/za8rp0n.png
My PC Specs: http://i.imgur.com/5bgg9P3.png
Current PCSX2 revision: r5932
Reply
#6
(02-07-2013, 10:43 AM)Tyestor Wrote: Unnecessary. The copy I have made of my PAL version of DBZ Budoaki 3 is .mdf and it works perfectly.

Additionally, I've tried other games that are saved in .iso format, and the same problem is happening to them. Granted, they're not games that need CRC-induced corrections to run properly, but they aren't picking ttem up either.

It's nothing to do with the fact it's saved as .mdf.

EDIT: I've been using full boot, but I'm about to check what a fast boot does for it.

FAKE EDIT (didn't actually submit until after trying: ...Well look at that. That's a weird one, it checks and runs perfectly when I use fast boot. That answers that one!
Reply
#7
(02-07-2013, 10:46 AM)Cleretic Wrote: Additionally, I've tried other games that are saved in .iso format, and the same problem is happening to them. Granted, they're not games that need CRC-induced corrections to run properly, but they aren't picking ttem up either.

It's nothing to do with the fact it's saved as .mdf.

EDIT: I've been using full boot, but I'm about to check what a fast boot does for it.

FAKE EDIT (didn't actually submit until after trying: ...Well look at that. That's a weird one, it checks and runs perfectly when I use fast boot. That answers that one!

Smile - Fast boot is usually the best way to go. In this case, it is.
My YouTube (Kingdom Hearts II: Final Mix FULLY TRANSLATED!): http://www.youtube.com/tyestor
MyAnimeList: http://www.myanimelist.net/profile/tyestor
Last.fm: http://www.last.fm/user/tyestor
My PCSX2 settings: http://i.imgur.com/za8rp0n.png
My PC Specs: http://i.imgur.com/5bgg9P3.png
Current PCSX2 revision: r5932
Reply
#8
This may explain why some Widescreen Patches do not work in full boot mode as PCSX2 doesn't read the CRC meaning it can not load the patch and why Fast boot is the better method and has been for a while now the preferred boot method.
Reply
#9
No, full boot is expected to run the CRC detection just as well as fast boot.
I haven't heard of this problem yet, actually.
We may want to figure out where all the console messages went first.
Cleretic: Please enable all items under "Sources" in the console and post a game startup log.
Reply
#10
As requested, a log of the game starting up, full boot, with every option in the console enabled, and the 'Dev/Verbose' option checked too just to make sure.

I should note that this went until the start of Nocturne's opening cinema, after the developer logos. I don't think that would change anything, that's just where I cut it off.


Attached Files
.txt   FullLog.txt (Size: 103,14 KB / Downloads: 117)
Reply




Users browsing this thread: 1 Guest(s)