Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 on Gentoo x64 doesn't open
#1
hi i have this error... (with pcsx2-1.0.0) here are the results:
Please Help Laugh
/home/user/pcsx2-1.0.0/pcsx2
/home/user/pcsx2-1.0.0/pcsx2: error while loading shared libraries: libwx_baseu-2.8.so.0: cannot open shared object file: No such file or directory

and with:


/home/user/pcsx2-1.0.0/launch_pcsx2_linux.sh
ldd: warning: you do not have execution permission for `plugins/libSPU2null.so'
ldd: warning: you do not have execution permission for `plugins/libUSBnull-0.7.0.so'
ldd: warning: you do not have execution permission for `plugins/libonepad-1.1.0.so'
ERROR the plugin (plugins/libonepad-1.1.0.so) miss some dependencies
ldd: warning: you do not have execution permission for `plugins/libonepad-1.1.0.so'
libSDL-1.2.so.0 => not found

ldd: warning: you do not have execution permission for `plugins/libFWnull-0.7.0.so'
ldd: warning: you do not have execution permission for `plugins/libGSnull.so'
ldd: warning: you do not have execution permission for `plugins/libCDVDlinuz.so'
ldd: warning: you do not have execution permission for `plugins/libspu2x-2.0.0.so'
plugins/libspu2x-2.0.0.so: /usr/lib/gcc/x86_64-pc-linux-gnu/4.5.4/32/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by plugins/libspu2x-2.0.0.so)
ERROR the plugin (plugins/libspu2x-2.0.0.so) miss some dependencies
ldd: warning: you do not have execution permission for `plugins/libspu2x-2.0.0.so'
plugins/libspu2x-2.0.0.so: /usr/lib/gcc/x86_64-pc-linux-gnu/4.5.4/32/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by plugins/libspu2x-2.0.0.so)
libSoundTouch.so.0 => not found
libwx_baseu-2.8.so.0 => not found
libwx_gtk2u_core-2.8.so.0 => not found
libwx_gtk2u_adv-2.8.so.0 => not found

ldd: warning: you do not have execution permission for `plugins/libPADnull.so'
ldd: warning: you do not have execution permission for `plugins/libCDVDiso.so'
ldd: warning: you do not have execution permission for `plugins/libzzogl-0.4.0.so'
plugins/libzzogl-0.4.0.so: /usr/lib/gcc/x86_64-pc-linux-gnu/4.5.4/32/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by plugins/libzzogl-0.4.0.so)
ERROR the plugin (plugins/libzzogl-0.4.0.so) miss some dependencies
ldd: warning: you do not have execution permission for `plugins/libzzogl-0.4.0.so'
plugins/libzzogl-0.4.0.so: /usr/lib/gcc/x86_64-pc-linux-gnu/4.5.4/32/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by plugins/libzzogl-0.4.0.so)
libCg.so => not found
libCgGL.so => not found
libwx_baseu-2.8.so.0 => not found
libwx_gtk2u_core-2.8.so.0 => not found
libwx_gtk2u_adv-2.8.so.0 => not found

ldd: warning: you do not have execution permission for `plugins/libCDVDnull.so'
ldd: warning: you do not have execution permission for `plugins/libdev9null-0.5.0.so'
ldd: warning: you do not have execution permission for `plugins/libGSdx-0.1.16.so'
plugins/libGSdx-0.1.16.so: /usr/lib/gcc/x86_64-pc-linux-gnu/4.5.4/32/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by plugins/libGSdx-0.1.16.so)
./pcsx2: error while loading shared libraries: libwx_baseu-2.8.so.0: cannot open shared object file: No such file or directory
Reply

Sponsored links

#2
PCSX2 is 32 bit only program. You need to install all 32 bits depencencies. Otherwise it won't found them Wink
Reply
#3
(09-08-2012, 07:57 PM)gregory Wrote: PCSX2 is 32 bit only program. You need to install all 32 bits depencencies. Otherwise it won't found them Wink

You mean that i must install chroot32?
Reply
#4
it is 1 solution
Reply
#5
(09-09-2012, 03:21 PM)gregory Wrote: it is 1 solution

whats the other? Ohmy
Reply
#6
something like multiarch on Debian/ubuntu. Or multilib like Fedora.
Reply




Users browsing this thread: 1 Guest(s)