Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 ran perfectly last Spring, but now has framerate issues.
#1
Hi,

I've downloaded, deleted, and redownloaded PCSX2 several times over the past few years and have never had an issue until now. I've always used the same computer and have never had any framerate or performance issues with any game I played. Spring 2013 was the last time I downloaded it and I played Kingdom Hearts 2 to 100% completion with no issues at any point during the game. I just redownloaded PCSX2 a few days ago to play KH2 again but this time my framerate jumps wildly between 40 and 60 fps. It's absolutely awful and not very fun to play.

Does anyone know why this is happening/ how I can fix it? I'm using the exact same computer as I was in the Spring, with the exact same settings and configuration. I run a mid-2009 Macbook Pro with 4 GB installed RAM, an Intel Core 2 Duo CPU T9550 @ 2.66 GHz, and an NVIDIA GeForce 9600M GT. I run dual boot on my computer and use the Windows 7 Enterprise 64-bit OS for my windows partition. I run all of my gaming on the Windows partition, and thats where I have PCSX2 installed.

Can anyone help me stabilize my framerate and make the game playable again?
Reply

Sponsored links

#2
in the gsdx config, make sure you have your nvidia card selected and not the intel one.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#3
(01-22-2014, 12:00 AM)refraction Wrote: in the gsdx config, make sure you have your nvidia card selected and not the intel one.

This was before the whole Optimus craze Wink
Make sure you have the 9600M GT selected and not the 9400M Wink
Reply
#4
Its a laptop so it might have clogged up inside with dust leading to heating issues.
Lenovo IdeaPad Z510
Windows 8.1
Intel i7-4702MQ @ 2.2 GHz (up to 3.1 GHz 2 cores, 2.9 GHz 4 cores)
6 GB DDR3 RAM
Nvidia GT 740M 1 GB
Reply
#5
I have just ran the latest SVN on my old-battered-dented-stucktogetherwithhotglue mid 2009 Macbook Pro 13 inch with a 9400M and a Core2Duo P8700 @ 2.53GHz and Kingdom Hearts 2 runs full speed (one of my old time favourites, completed it on this Mac too at full speed before I got the new laptop) so it should run full speed.

As suggested look for dust, I have a Mac from your generation and it's trivial, unscrew the bottom screws, the lid comes off and right there you can see if there's a problem, if you find dust (specially between the fan and the dissipaters) you should remove the fan, remove the dust and put everything back into place, it's not hard with that Mac (at least with the 13 incher Smile ).

Are you using any speedhacks or MTVU? With that CPU you should have MTVU disabled and turn recommended speedhacks on, I used to run it on my Mac at 1280x720 on GSdx with recommended and all was good, make sure you don't have anything silly like VU Stealing at the max or anything Smile
Reply
#6
I really need to look into the dust thing, my laptop has been feeling incredibly hot lately. I'll also look into the other suggestions and make an update. Thanks!
Reply
#7
It's not a problem of you computer, it has something to do with new PCSX2 revisions, because this has happened to me as well:
I was using r5496 which worked perfectly, then some days ago I downloaded r5802 that was absolutely rubbish...I went from 60 fps in Tomb Raider Angel of Darkness to 28 fps and that with the same PC and same PCSX2 settings!!
My specs are Windows XP, Core2dueo e8400 and Amd hd4850
Reply
#8
I've just downloaded r5820 and it seems to work perfectly...so I suggest you to do the same.
Maybe there was something wrong with some of the latest revision but now the last one seems to work good
Reply
#9
(01-22-2014, 07:28 PM)ratturu Wrote: I've just downloaded r5820 and it seems to work perfectly...so I suggest you to do the same.
Maybe there was something wrong with some of the latest revision but now the last one seems to work good
Or you just forgot to use the same settings...


To OP:
The question is how fast the fps jump. If it is in seconds-range or even faster I would not believe that heat is the problem. If it has stable 60fps for some seconds and then some seconds lower fps. Than heat-throttling would be my favorite.
Reply
#10
No, I had absolutely the same settings (checked 1000 times because I couldn't believe how slow it was)
The only difference that I noticed was that in the zip file of r5802 compiled by the build bot there was only one pcsx2 exe (and not the usual two - btw why are there 2 exes?) and that on top bar r5802 didn't show PCSX2 version number.
Now r5820 has again the two exes and the version number on top bar (5782)
So now I suppose it was a temporary compiling problem of the build bot
Reply




Users browsing this thread: 1 Guest(s)