Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 (some games) run bad on high-end PC
#1
Good day everyone.

I've been using PCSX2 for a while now and I am pleased on this version's compat and speed! Thank you!

Here is my PC spec:
CPU: AMD Phenom II x6 1090T
RAM: 8gb Corsair
PSU: 1000W
OS: Win7-64bit
GPU: 2X ATI Radeon HD 5850 CrossfireX

PCSX2: 0.9.7, basically installed the default full installer from the forums

Now, I don't even have to use speed hacks, or other tweaks to play KH2, Grandia 3, FFXII, or GoW2. Just the GSdx plugin's DX11 Hardware renderer and i'm set, getting 60fps most of the time, with occasional 59fps. Now enough boasting for me.

I tried playing FFX-2 and Valkyrie Profile 2 and obviously found the same problems most people have on the last build of PCSX2.

Valkyrie Profile's LOST FOREST/WOODS gets these red squares all over the screen. The opening movie runs great, and the first town runs great too.

FFX-2's opening movie still has those black strips and is slow. If i switched to Software Render, it gets down to 7fps. lol

My questions are:
Is there a new way to fix the movies in FFX-2 without the Software Render switching method?
I tried out most of the settings in Speed Hacks, Video Plugin (GSdx) and Game Fixes, but no luck on both of these games. So... Is there a certain setting on 0.9.7 that fixes these?
(also, when i try the F12 video capture, i get 2 files, a FILE and an audio file.... what do i do with these?)

Thanks a lot!
Reply

Sponsored links

#2
Software renderer shouldn't reduce FPS in the FFX-2 videos, the GS is barely being used there and software wouldn't cause extra slowdown unless you have a very very slow CPU (single core ~2GHz or something like that).

You can use the "native" option in Hardware renderer and enable some interlacing instead if you want, but I really doubt software mode is causing you that slowdown to begin with.

The "FILE" I suppose is what you named the video file when recording, you should have added the .avi extension, you can still rename the FILE and add ".avi" at the end, should work then. You get 2 files, an audio and a video file and you can merge the with VirtualDub or whatever file you want to use to mux/edit the files together.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
(02-03-2011, 11:02 AM)Shadow Lady Wrote: Software renderer shouldn't reduce FPS in the FFX-2 videos, the GS is barely being used there and software wouldn't cause extra slowdown unless you have a very very slow CPU (single core ~2GHz or something like that).
The same thing happens to me in FFX-2 - when I toggle the software renderrer, the video usually slows down to about 35-45 fps (from 60). BUT, when I set the hardware mode and back the software mode again, I get the full speed. Strange...
Windows 7 Ultimate 64-bit
AMD Athlon II X4 640 @ 3.7 GHz
Sapphire ATI Radeon HD 5670 1 GB DDR5 @ 800/1000 MHz
RAM 2x2 GB DDR 3 Dual channel
Reply
#4
That much sounds like some power saving feature kicking in, slowing down to 7 FPS does not Tongue2
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#5
Forgot to mention my CPU is OC'd @ 4.0Ghz so i doubt that is the problem.
Sorry about that, the video goes down to 7fps when video capture is on.
Reply
#6
I'm with Atlaswing. In FFX-2 when I enable software render it goes much much slower than hardware render at 5120x2880 it just removes all the extra ***** that comes with hardware render.
Reply




Users browsing this thread: 1 Guest(s)