Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 suddenly running at 25-35 FPS
#1
I used to get a stable 60 FPS on every game I've tried on the emulator and all of a sudden it started running really slowly. I've tried reinstalling it, changing from Software to Hardware, I enabled speedhacks and just about everything I can think of at this point and I'm not sure why its running games that ran at a stable 60 FPS at around 25-35 FPS. I tried to install the latest git build and that didn't work either.
Reply

Sponsored links

#2
In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
- AMD Phenom II X4 965, AMD Radeon 7770, 8 GB of RAM, Windows 7 Ultimate
- PCSX2 1.4.0
- MTVU speedhack, Switch to GSdx software rendering when an FMV plays, I never go above x4 native and I normally used Direct3D11(Hardware)
- I've tried multiple games that ran at 60 FPS about 2 days ago which were Dark Cloud, Kingdom Hearts,Kingdom Hearts 2, Arc the Lad: Twilight of the Spirits. None of them run at 60 FPS like they used to with all of the same settings I had before. I'm playing them from ISO.

Also I noticed that the program tends to freeze on me for about a minute or 2 when I start up a game. This never happened before
Reply
#4
is amd cool n' quiet disabled ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#5
Im not sure how to check that
Reply
#6
in your bios
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#7
It's set to Auto
Reply
#8
then disable it
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#9
I did and that didn't seem to do anything
Reply
#10
tried monitoring your temps while playing ?
just to make sure they don't get too high
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply




Users browsing this thread: 1 Guest(s)