Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 unstable git 21122014 from PPA - bugs on Ubuntu
#1
Hello,

for the first time I the PCSX2 unstable git 21122014 from PPA give me this bugs on Ubuntu 14.04:

- sound is awful, crashy
- bios files is recognised with difficulty, PCSX2 seems now to make a difference between upper and lower case

Thank you for your help.

LGDN
Config: Ubuntu 17.04 Zesty Zapus 64 bits - NVIDIA GeForce GTX 770 - official Ubuntu Nvidia drivers 375.66 - 1920x1080 - Processor Intel i5-3570 3,4 Ghz - 8 Go RAM
Reply

Sponsored links

#2
Sound is most likely an issue with sdl2. I had the exact same problem with the ppa. So I compiled my own version and it works perfectly.
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#3
Yes sound is likely linked to SDL2. I think I will redo a PPA that use SDL1 instead. It is a shame.
Quote: - bios files is recognised with difficulty, PCSX2 seems now to make a difference between upper and lower case
It could be linked to wx 3.0. Could you explain it in more details, so I can test it and hopefully improve it because wx3.0 will stay Wink
Reply
#4
Hello Gregory,

I could not play because of the audio plugin, I have no sound,n only sound artefact, with Portaudio and SDL...is it a known bug? Do I have to declare a bug somewhere?

For the upper/lower case, I'm not sure, it could be an error from me...Let's see later if I could repeat the bug.
Config: Ubuntu 17.04 Zesty Zapus 64 bits - NVIDIA GeForce GTX 770 - official Ubuntu Nvidia drivers 375.66 - 1920x1080 - Processor Intel i5-3570 3,4 Ghz - 8 Go RAM
Reply
#5
https://github.com/PCSX2/pcsx2/issues/382
Reply
#6
I found a workaround for the audio: I'm using the libspu plugin from the stable version, it seems to work with SDL option, but not with portaudio.

Gregory, I have another bug:
when I want to load an ISO image, PCSX2 show nothing in the folder, it seems the default extension filter is buggy...If I choose *.* I could see my iso images.
Config: Ubuntu 17.04 Zesty Zapus 64 bits - NVIDIA GeForce GTX 770 - official Ubuntu Nvidia drivers 375.66 - 1920x1080 - Processor Intel i5-3570 3,4 Ghz - 8 Go RAM
Reply
#7
Filter is fixed on git. I really need time to upload a new ppa version
Reply
#8
I uploaded a new version of PPA (if the build didn't fail), sound and pad will work better.

Double check that extension filter is fixed too Smile
Reply
#9
(01-24-2015, 12:49 PM)gregory Wrote: I uploaded a new version of PPA (if the build didn't fail), sound and pad will work better.

Double check that extension filter is fixed too Smile

The build did fail. There are no PAD and sound plugins
Reply
#10
(01-24-2015, 03:41 PM)123_qwe Wrote: The build did fail. There are no PAD and sound plugins

I second that.

On ubuntu 14.04 64-bit
Reply




Users browsing this thread: 1 Guest(s)