Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 version 1.1.0 SPU2 sound issue?
#1
Hello World!

I'm a new user. But anyways I need some help to fix a problem with trying to correctly configure the PCSX2 sound to where it will stop making a constant clicking noise when I'm playing the first Splinter Cell game, tried every sound plugin but still get the same clicking noise. Everything else works in the game no lag and perfect graphics even though thermal vision does not work tried fixing that, but the real problem I'm worried about is the annoying clicking noise. It started when I got to the main menu of the game and even turning down the Ambient sound in the game fixed it but still the clicking noise comes back when Lambert or Fisher starts talking.

Here is my specs of my Computer:

Laptop Microsoft Windows 7 Home Premium Republic Of Gamers
Version 6.1.7601 Service Pack 1 Build 7601
Microsoft Corporation
ASUSTek COMPUTER INC.
G75VW
x64-based PC
Intel® Core™ i7-3610QM CPU @ 2.30GHz, 2301 Mhz, 4 Core(s), 8 Logical Processor(s)
American Megatrends Inc. G75VW.207, 4/6/2012
Hardware Version= "6.1.7601.17514"
Installed Physical Memory (RAM) 12.0 GB
Total Physical Memory 12.0 GB
Available Physical Memory 9.37 GB
Total Virtual Memory 23.9 GB
Available Virtual Memory 21.0 GB

Graphics NVIDIA GeForce GTX 670M
My Sound NVIDIA High Definition Audio

I wish I could find a more better sound plugin but I searched and tried them all same clicking noise, tried different settings and nothing works, so the problem must be the sound plugins and I know its not my computer because its still new. So any help would be good thanks!
Reply

Sponsored links

#2
Dunno the game to help much, but did you tried increasing latency in SPU2-X? People often turn it too low thinking about an improvement and that would be a side effect of it(in some cases default is too low as well;p). The problem could not be related to plugin anyway. It's fairy common for some speedhacks(mostly EE cyclerate I guess, but it's worth checking with them all disabled just to be sure;p).
Reply
#3
It would help if you gave me a complete layout of each setting so that I can use it, and increasing latency only makes it worse and speedhacks are turned off makes no difference when the clicking is still there. Tried every known plugin Graphics plugin, Sound plugin no change after experimenting with different settings, I've even tried down grading and using an older version of the emulator, but still to no end nothing works on newer computers these days. Thanks for trying to help. I might as well uninstall it and be done with Emulating games because they don't do nothing but cause problems in the long run, I wish they came out with a more smart way to use a emulator where it auto detects the sound and recognizes the error and fixes it without the user getting a headache screwing around with settings every time a different game is loaded, plus every plugin should have its own auto detection fix.
Reply
#4
(09-27-2013, 07:31 AM)BioHazardChaos Wrote: I wish they came out with a more smart way to use a emulator where it auto detects the sound and recognizes the error and fixes it without the user getting a headache screwing around with settings every time a different game is loaded, plus every plugin should have its own auto detection fix.

hey, that's a good idea Laugh
when do you think you can show us your own plugin release ?

joke apart, I don't have this game, but I'd bet on a badly emulated weird post-processing effect.
tried disabling post-processing in SPU2-X options ?
that could come from a bad fps rate too.
do you get full speed without speedhacks ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#5
You say PCSX2 v1.1 but don't say which version exactly.

I recommend to download the latest nightly build (which had some SPU2x improvements especially for lower latency few weeks ago), and just play with the output modules (XAudio 2, portaudio, etc), and try to find the one which allows lowest latency without (too many?) clicks on YOUR system.

FWIW, on my system I use portaudio with latency set to 70ms.

As for automatically detecting "best" settings, that's hard to do - technically because it's per game (and areas within the game) as the harder is a game to run for PCSX2, the more clicks (and slowdowns) it will have, but also because "best" is not an objective measure - e.g. one user may prefer lower latency even if it has occasional clicks, while another user might prefer whatever latency as long as it never has clicks. So it's impossible to find a setting which everyone would appreciate as "best".

So second best is to ship with settings that will work well on most systems and for most users, and this is what we're trying to do. IIRC the default is 150ms latency which should have very few clicks, if at all, if your system can play the game relatively consistently at full speed. If your system can't then you should find a setting, maybe with more latency, until it's best for YOU.

Also, use only SPU2-X. This is the most advanced and compatible one, and the other SPU plugins lag way behind and aren't actively maintained.
[i7-3630qm/gt650m-2G/Win-7] [i7-4500u/R.HD8850m/Win-8.1] [2010-MBA/OSX-10.9.x]. Scroll smoothly with SmoothWheel for Firefox.
Reply
#6
Hey jesalvein I wanted to get into modding and programing or codding how ever its called but its too complicated so I gave it up, I wish I could create my own plugins that would be great, but knowing what code to type is complicated to understand without a full list of what exactly what code I should type without doing the guessing. And avih the correct version is PCSX2 1.1.0 5703 SVN (BETA) r5705 Official Release Date: 07/23/2013 look it up google is your friend. And sure I will try your settings but hope it works though not enough info you gave me but I'll try it.
Reply
#7
(09-27-2013, 10:30 AM)BioHazardChaos Wrote: ... though not enough info you gave me but I'll try it.

Apologies for falling short on your expectations. I understand you've read the guides and my suggestions and still can't solve your issue. On that case, you might wanna hire someone to configure it for you.
[i7-3630qm/gt650m-2G/Win-7] [i7-4500u/R.HD8850m/Win-8.1] [2010-MBA/OSX-10.9.x]. Scroll smoothly with SmoothWheel for Firefox.
Reply
#8
All you had to do was to post a image of how the settings on the emulator should look so I could copy it to my emulator. But I guess I'm done with this thread thanks every one for trying to help. Smile
Reply
#9
You could talk yourself death, but I surely won't. Good luck.
[i7-3630qm/gt650m-2G/Win-7] [i7-4500u/R.HD8850m/Win-8.1] [2010-MBA/OSX-10.9.x]. Scroll smoothly with SmoothWheel for Firefox.
Reply




Users browsing this thread: 1 Guest(s)