Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 very laggy and weird models
#1
On every game I tryed so far,  the game lags in general most of the time, sometimes even slowing down with every video settings set to minimum. Problem is my pc isnt a potato and should be able to run those games smoothly with good graphic settings.

Specs:

CPU: Intel Core i5 4590-3.30 GHz
GPU: GeForce GTX 950
RAM: 16 GB DDR3 RAM

And I dont think the rest is important...

I've tryed every single setting or combination of settings to make it work, always unsuccesful, so any tips or help will be greatly appreciated

Thank you

Sponsored links

#2
Which games ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
#3
(07-17-2016, 12:00 AM)jesalvein Wrote: Which games ?

So far I tryed on Ratchet and Clank, Shadow of Colossus, God of War, Jak 3 and Kingdom Hearts, all of them showing the same results
#4
(07-17-2016, 12:36 AM)MrSimbora Wrote: So far I tryed on Ratchet and Clank, Shadow of Colossus, God of War, Jak 3 and Kingdom Hearts, all of them showing the same results

dunno what you mean by "weird models", but about performance (lag) :
- Ratchet & clank : please post your settings. You'll experience lags anyways
- Shadow of the colossus : set vu cylce stealing to 1, disable mtvu speedhack
- God Of war : Please post your settings
- Jak 3 : Please post your settings. you'll experience lags anyways
- Kingdom hearts : Please post your settings. This is one of the lightest games. it should work flawlessly
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
#5
(07-17-2016, 08:16 AM)jesalvein Wrote: dunno what you mean by "weird models", but about performance (lag) :
- Ratchet & clank : please post your settings. You'll experience lags anyways
- Shadow of the colossus : set vu cylce stealing to 1, disable mtvu speedhack
- God Of war : Please post your settings
- Jak 3 : Please post your settings. you'll experience lags anyways
- Kingdom hearts : Please post your settings. This is one of the lightest games. it should work flawlessly

Regarding weird models, sometimes depending on the camera position the colours and the shape of the character or even the environment get messed up on certain camera angles.
-I'm using native settings for every game since its the only way the game can be played witout slowing down or lags (sometimes it does anyway)
-Changing vu cylce stealing to 1 helped a bit with Shadow of Colossus, thanks for the tip
#6
(07-17-2016, 11:04 AM)MrSimbora Wrote: Regarding weird models, sometimes depending on the camera position the colours and the shape of the character or even the environment get messed up on certain camera angles.

I guess you're talking about Ratchet & Clank, then.
the only way to correct this is the use of software mode.
Make sure you set extra software rendering threads to 3, before doing so, btw
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
#7
(07-17-2016, 11:46 AM)jesalvein Wrote: I guess you're talking about Ratchet & Clank, then.
the only way to correct this is the use of software mode.
Make sure you set extra software rendering threads to 3, before doing so, btw

Ok that fixed the models issue completely but the game is still laggy and slowed down
#8
(07-17-2016, 12:39 PM)MrSimbora Wrote: Ok that fixed the models issue completely but the game is still laggy and slowed down

i told you
Quote:You'll experience lags anyways
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
#9
(07-17-2016, 01:36 PM)jesalvein Wrote: i told you

Alright theres really nothing I can do then, gotta play with native sattings.
Any suggestions for games that run smoothly?
#10
What do the ee% & gs% say when you get slowdowns in kh & gow ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go




Users browsing this thread: 1 Guest(s)