Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 wont load cheats anymore [Ubuntu 13.04 64bit]
#1
Hello guys !

Im having a problem now.
I used to use cheats on pcsx2, but now they wont work anymore.

[Image: pcsx2problem1.png]
If you can see, it says :
'Overall 0 Cheats loaded'
'Overall 0 Widescreen hacks loaded'

My cheatfolder were always in /home/ilja/ROMs/cheats/
I start my games with selfmade starters from the desktop by clicking on the gamecovers(so the cheatfolder had to be in the directory where the ISO is, not in the homefolder).

[Image: pcsx2problem2.png]
That's my cheatfolder, but to test it out IF it had to be in the homefolder now, I copied the folder into the homedirectory too.

I checked all my settings and everything, but PCSX2 just dont want to load the cheats anymore (they worked on 12.10 32bit some months ago).

I really want to know, how to fix that, because I love to play my games
in widescreen.

A big thanks in advice,
and sorry for my english <.<
Reply

Sponsored links

#2
For some reason cheats does not cooperate for me when using the executable, so instead I use the shell script. It works everytime.
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#3
I also noted that you have more than just the CRC code as the title of the file. This is not recommended. Just use the CRC only without the gametitle. I personally puch each pnach for each game in a separate folder to keep the all organized. Then when I need to use that particular pnach I copy it over to pcsx2/cheats.
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#4
I changed the names of the .pnach-files some days ago.
But they didnt worked either.
I tried really everything, and I couldnt find a solution on the net (because they're not so many people using PCSX2 on Linux.. <.<)
Reply
#5
Did you try the shell script? Did you make sure that "Enable Cheats" was checked? Are you using PPA or self-compiled SVN build?
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#6
Yeah, I tried this one already, but didnt worked eather ._.
I'm using the official PPA.
When I play PCSX2 via Wine, the cheats are working <.<
Reply
#7
Does Linux version allows adding anything after the CRC?

To be honest I didn't verify it on Windows version also. But for all that I know that could be the reason the file is not found anymore. Ignore this post if that's the case.

PS: I know the parser could be made to ignore anything in between the first 8 digits of the CRC and the .pnach, the question is: it's doing so?
Imagination is where we are truly real
Reply
#8
The naming of the file is exactly the same is windows {name of CRC}.pnach. I had problems with the PPA before in the past but I figured I would test it this morning. I guess we had a regression lately because it would not run with the fglrx driver in software mode (just got a 7850). Hopefully mesa will be up and running soon. In the meantime, if you definitely want pnach cheats that bad, compile the latest SVN yourself. It is tricky with 64 bit but I have a somewhat sloppy yet effective version for doing so. Since I am not doing anything RAM intensive, plus PAE is enabled by default, I switched back to 32 bit for this reason.

http://forums.pcsx2.net/Thread-PCSX2-chroot-issues

With self-copmpiled SVN you must use the shell script of cheats won't work for some reason.
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#9
Well, the file names in the OP are all such: 4D2CAC9D.Disgaea Hour of Darkness.pnach instead 4D2CAC9D.pnach, is this accepted?
Imagination is where we are truly real
Reply
#10
Nope. A couple posts up I reminded the OP about the names of the pnach files. Basically, the rules are the same when creating pnach files.
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply




Users browsing this thread: 1 Guest(s)