Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCXS2 Weird framerate.Problem
#1
Hey guys, it´s me again, a different problem this time.

As you already know i´ve managed to optimize PCXS2 for WWE games which are the ones i mostly play there, sometimes i play NBA 2K3 or NHL 2k5 which also run fine, but that isn´t what matters here.

With my settings, i did some testing and found that the best setting is 420x420 in resolution(kinda low i know). But by mistake i turned on the native resolution and found out that WWE Games and even NBA and NHL run fine on that one, it´s was basically the same speed as at 420x420(maybe 1/2 less fps). But after some 15 minutes, the game begins to slowdown for no reason, CPU and GPU temps are exactly the same no matter the resolution i choose, but when i´m on native the games begin to slowdown. I Thought it was overheating but since when i play on 420x420 the temps are the same as in the native resolution and it´s play fine in 420x420 i kinda ruled out that option.

Any thought?
Reply

Sponsored links

#2
It's possible your gpu can't even handle native as it is quite old and a mobile version, which will always be nerfed compared to its desktop sibling. But just to be sure, please note the game and the EE and GS%, in native resolution, during the slowdown (since slowdowns always seem to occur when in native, not 420 x 420). Also note the fps during the slowdown. Pleas report those here.

Also keep in mind that some scenes may be demanding, and some may not, although it will not appear obvious as to why with using just our eyes.

If all else fails, Saiki has this excellent thread for those with quite low end hardware. But please try the above mentioned task first.
http://forums.pcsx2.net/Thread-Low-end-P...0-settings
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#3
All the games i play have that problem. I Have EE(speed hack to max), and VU to moderate(read that this is the limit, you should not go above this in this speed hack.

EE is between 65% and 75% at slowdown time
GS between 22 and 30%
FPS are like 50/60 before slowdown, down to 35/40 in it

I Kinda get your point when you say it can´t handle it, but if the temps are equal in both resolution, and even native runs well until that slowdown, shouldn´t the card handle it?
Reply
#4
If you have gpu bottleneck, the only way to solve increasing framerate is by decreasing d3d internal resolution.
Im sorry i often misstype because im using cellphone...Y( '',)Y
Reply
#5
When you increase the resolution which means you increase the load of gpu as well as for cpu which in result cause slowdown.
Pentium Dual-core G2010 2.8Ghz
RAM=4GB
nvidia GT 610
pcsx2 version-1.3.1  


Still surfing with Browser?, Try the pcsx2 forum App !
Reply
#6
hmmm use direct3d10 for wwe games,native resolution,enable hw hacks-configure-skipdraw=1
speedhacks-only enable wait loop detection ticked,sliders=0
power options-high performance
these settings work great for me !
Reply
#7
Quote: I Have EE(speed hack to max), and VU to moderate(read that this is the limit, you should not go above this in this speed hack.

Try the EE and GS% test again with no speedhacks. This helps ensure there are control variables.
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#8
Without speed hacks the game is from the start at 25/35 fps.

EE is between 93 and 98%
GS between low 30 and mid 40´s.

Preet those settings didn´t work that well.
Reply
#9
(08-18-2013, 04:53 PM)PedroPM Wrote: Without speed hacks the game is from the start at 25/35 fps.

EE is between 93 and 98%
GS between low 30 and mid 40´s.

Preet those settings didn´t work that well.

ee98 that means your cpu weak thats why you strugle with fps.
Pentium Dual-core G2010 2.8Ghz
RAM=4GB
nvidia GT 610
pcsx2 version-1.3.1  


Still surfing with Browser?, Try the pcsx2 forum App !
Reply
#10
But it isn´t weird that at start it runs well in native(even on the matches, it runs in the same fps than 420x420, and it´s not a false fps reading because it feels the same playing both resolution). But after a while native slow downs, gpu temps and cpu temps are the same no matter what resolution...
Reply




Users browsing this thread: 1 Guest(s)