Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PPA is broken for PCSX2 on Ubuntu 12.04 64-bits
#1
When I attempt to install from PCSX2 using the official Ubuntu PPA (https://launchpad.net/~gregory-hainaut/+...ficial.ppa) I get the following:

Code:
$ sudo apt-get install pcsx2-unstable
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
pcsx2-unstable:i386 : Depends: libwxgtk2.8-0:i386 (>= 2.8.12.1) but it is not going to be installed
                       Depends: pcsx2-plugins-unstable:i386 (>= 5131-3) but it is not going to be installed
E: Unable to correct problems, you have held broken packages

Seems like some dependencies aren't in there for Precise yet...
Reply

Sponsored links

#2
apt-get install pcsx2-unstable:i386.


add also théle library that you canot install
Reply
#3
(04-12-2012, 08:47 PM)gregory Wrote: apt-get install pcsx2-unstable:i386 ;-)

Sorry, forgot to mention I tried that, it fails the same way.

Code:
$ sudo apt-get install pcsx2-unstable:i386
[sudo] password for fredrick:
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
pcsx2-unstable:i386 : Depends: libwxgtk2.8-0:i386 (>= 2.8.12.1) but it is not going to be installed
                       Depends: pcsx2-plugins-unstable:i386 (>= 5131-3) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Reply
#4
se the library stuff above
Reply
#5
(04-12-2012, 08:50 PM)gregory Wrote: se the library stuff above

Uh, sorry? The library is not installable...

Code:
$ sudo apt-get install libwxgtk2.8-0:i386
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libwxgtk2.8-0:i386 : Depends: libgstreamer-plugins-base0.10-0:i386 (>= 0.10.0) but it is not going to be installed
                      Depends: libgstreamer0.10-0:i386 (>= 0.10.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

And if I try to install libgstreamer, it wants to remove half my OS.

Code:
$ sudo apt-get install libgstreamer0.10-0:i386
Reading package lists... Done
Building dependency tree      
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libopenal1:i386 libkrb5-3:i386 libkprintutils4 libsoundtouch0
  libk5crypto3:i386 libpam-winbind libstdc++6:i386 libtwolame0 libxfixes3:i386
  ttf-umefont libqca2 libxcomposite1:i386 libldap-2.4-2:i386 libv4l-0:i386
  liblcms1:i386 libroken18-heimdal:i386 libpolkit-qt-1-1 libgphoto2-port0:i386
  python-matplotlib calibre-bin libknewstuff3-4 libjpeg-turbo8:i386
  libjpeg8:i386 libnepomuksync4 kakasi-dic libkdeclarative5 libnepomukquery4a
  python-routes libsane:i386 libtinyxml2.6.2 libxxf86vm1:i386
  python-matplotlib-data libthreadweaver4 libportsmf0 libgl1-mesa-dri:i386
  libkdecore5 libnepomukutils4 libktexteditor4 libxcb-glx0:i386
  libasn1-8-heimdal:i386 libkmediaplayer4 libgl1-mesa-glx:i386
  oxygen-icon-theme libxslt1.1:i386 libkrosscore4 libflac++6 libchm1 kakasi
  libcapi20-3 libcapi20-3:i386 libx11-xcb1:i386 libgnutls26:i386
  libpodofo0.9.0 libglapi-mesa:i386 libgssapi3-heimdal:i386 python-cherrypy3
  libtasn1-3:i386 libfreetype6:i386 libexpat1:i386 libv4lconvert0:i386
  libsolid4 unixodbc libnepomuk4 libavahi-common-data:i386 python-dnspython
  libattica0.3 libxcb1:i386 libkdnssd4 libkparts4 wine-gecko1.4
  wine-gecko1.4:i386 libp11-kit0:i386 libwind0-heimdal:i386 kde-runtime-data
  libxau6:i386 shared-desktop-ontologies python-sip libcups2:i386 winetricks
  kdoctools libxinerama1:i386 libkrb5support0:i386 libqimageblitz4
  libgif4:i386 libnepomukdatamanagement4 libkidletime4 katepart libice6:i386
  libxdmcp6:i386 libieee1284-3:i386 libgcrypt11:i386 python-mechanize
  audacity-data python-sqlalchemy libkcmutils4 libkeyutils1:i386 libntrack0
  libasound2:i386 libkfile4 libxpm4:i386 libusb-0.1-4:i386 libkpty4
  libxrender1:i386 cabextract libhcrypto4-heimdal:i386 liborc-0.4-0:i386
  libhx509-5-heimdal:i386 python-webob libphonon4 libqtassistantclient4
  libgd2-xpm:i386 libheimbase1-heimdal:i386 libkntlm4 filezilla-common
  libtiff4:i386 libkemoticons4 ntrack-module-libnl-0 kdelibs-bin
  libwxbase2.8-dev libavahi-client3:i386 ttf-unfonts-core libkjsembed4
  libmpg123-0 libmpg123-0:i386 libkio5 libx11-6:i386 libsasl2-2:i386
  libkjsapi4 libfontconfig1:i386 libsm6:i386 libntrack-qt4-1 kdelibs5-data
  libheimntlm0-heimdal:i386 libxdamage1:i386 libvamp-hostsdk3
  python-sqlalchemy-ext winbind wx2.8-headers libodbc1 libexif12:i386
  libglu1-mesa:i386 libgssapi-krb5-2:i386 libxi6:i386 libkde3support4
  libknotifyconfig4 libxcursor1:i386 python-beautifulsoup libxt6:i386
  libxext6:i386 libsasl2-modules:i386 libavahi-common3:i386 libkhtml5
  libkdeui5 libkdesu5 libxrandr2:i386 libkatepartinterfaces4 python-cssutils
  libsqlite3-0:i386 kate-data libltdl7:i386 libkrb5-26-heimdal:i386
  libgpg-error0:i386 libllvm3.0:i386 libgphoto2-2:i386 python-pyparsing
Use 'apt-get autoremove' to remove them.
Suggested packages:
  gstreamer0.10-tools:i386 gstreamer0.10-plugins-base:i386
The following packages will be REMOVED:
  anki apturl audacity bluez-gstreamer brasero brasero-cdrkit calibre empathy
  evolution-data-server filezilla gimp gir1.2-rb-3.0 gir1.2-totem-1.0
  gir1.2-ubuntuoneui-3.0 gir1.2-webkit-3.0 gnome-control-center gnome-media
  gnome-online-accounts gnome-user-guide gstreamer0.10-alsa
  gstreamer0.10-gconf gstreamer0.10-nice gstreamer0.10-plugins-base
  gstreamer0.10-plugins-base-apps gstreamer0.10-plugins-good
  gstreamer0.10-pulseaudio gstreamer0.10-tools gstreamer0.10-x gwibber
  indicator-datetime indicator-power kde-runtime kdelibs5-plugins kolourpaint4
  libbrasero-media3-1 libdmapsharing-3.0-2 libfarstream-0.1-0 libfolks-eds25
  libgnome-media-profiles-3.0-0 libgoa-1.0-0 libgstreamer-plugins-base0.10-0
  libgstreamer0.10-0 libkdewebkit5 libplasma3 libpurple0 libqtwebkit4
  libreoffice-base-core libreoffice-calc libreoffice-common libreoffice-core
  libreoffice-draw libreoffice-emailmerge libreoffice-gnome libreoffice-gtk
  libreoffice-help-en-us libreoffice-impress libreoffice-math
  libreoffice-style-human libreoffice-style-tango libreoffice-writer
  librhythmbox-core5 libsyncdaemon-1.0-1 libtelepathy-farstream2 libtotem0
  libubuntuoneui-3.0-1 libwebkitgtk-1.0-0 libwebkitgtk-3.0-0 libwxgtk2.8-0
  libwxgtk2.8-dev libyelp0 lo-menubar metacity mythes-en-us
  nautilus-sendto-empathy nautilus-share oneconf phonon
  phonon-backend-gstreamer plasma-scriptengine-javascript python-gst0.10
  python-qt4 python-ubuntu-sso-client python-ubuntuone-control-panel
  python-uno rhythmbox rhythmbox-mozilla rhythmbox-plugin-cdrecorder
  rhythmbox-plugin-magnatune rhythmbox-plugin-zeitgeist rhythmbox-plugins
  rhythmbox-ubuntuone sessioninstaller shotwell software-center telepathy-haze
  totem totem-mozilla totem-plugins ubuntu-desktop ubuntu-docs
  ubuntu-sso-client ubuntu-sso-client-gtk ubuntuone-client
  ubuntuone-client-gnome ubuntuone-control-panel unity-2d
  unity-scope-musicstores yelp zenity
The following NEW packages will be installed:
  libgstreamer0.10-0:i386
0 upgraded, 1 newly installed, 109 to remove and 0 not upgraded.
Need to get 0 B/791 kB of archives.
After this operation, 565 MB disk space will be freed.
Do you want to continue [Y/n]? n
Abort.
Reply
#6
What give you:

apt-get install libgstreamer0.10-0:i386 libgstreamer0.10-0:amd64
Reply
#7
Code:
$ sudo apt-get install libgstreamer0.10-0:i386 libgstreamer0.10-0:amd64
[sudo] password for fredrick:
Reading package lists... Done
Building dependency tree      
Reading state information... Done
libgstreamer0.10-0 is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libgstreamer0.10-0 : Breaks: libgstreamer0.10-0:i386 (!= 0.10.36-1ubuntu1) but 0.10.36-1 is to be installed
libgstreamer0.10-0:i386 : Breaks: libgstreamer0.10-0 (!= 0.10.36-1) but 0.10.36-1ubuntu1 is to be installed
E: Unable to correct problems, you have held broken packages.
Reply
#8
Hum somebody is rebuilding the package.
The 32bits version is 0.10.36-1ubuntu1
the 64 bits versions is 0.10.36-1

Wait couple of hours / tommorow Wink
Reply
#9
(04-12-2012, 09:21 PM)gregory Wrote: Hum somebody is rebuilding the package.
The 32bits version is 0.10.36-1ubuntu1
the 64 bits versions is 0.10.36-1

Wait couple of hours / tommorow Wink

Ah, all right. I'll report back in a few days if it's still not working then Smile

Thank you.
Reply
#10
I am trying to install pcsx2 on my brand new ubuntu 12.04 64 bits installation and i cant, there is no a pcsx2-unstable package on the ppa, just see pcsx2-unstable-dbg and so on. Any suggestion Gregory?


(04-12-2012, 09:23 PM)copypaste Wrote: Ah, all right. I'll report back in a few days if it's still not working then Smile

Thank you.
Reply




Users browsing this thread: 1 Guest(s)